Update lftp to 3.7.7 (#4413)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13854 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
75e14394b7
commit
1c48976ef1
@ -10,12 +10,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lftp
|
PKG_NAME:=lftp
|
||||||
PKG_VERSION:=3.7.3
|
PKG_VERSION:=3.7.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://ftp.yars.free.net/pub/source/lftp/old/
|
PKG_SOURCE_URL:=http://ftp.yars.free.net/pub/source/lftp/
|
||||||
PKG_MD5SUM:=fc98506620b059d712341d624eb720d6
|
PKG_MD5SUM:=7b1c58a6289448140b1cd328e1d51f94
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
@ -44,7 +44,7 @@ CONFIGURE_VARS += \
|
|||||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -I$(STAGING_DIR)/usr/include/uClibc++ -nostdinc++" \
|
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -I$(STAGING_DIR)/usr/include/uClibc++ -nostdinc++" \
|
||||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
||||||
LDFLAGS="$$$$LDFLAGS" \
|
LDFLAGS="$$$$LDFLAGS" \
|
||||||
LIBS="-nodefaultlibs -lz -lutil -luClibc++ -lcurses -lgcc_s -ldl" \
|
LIBS="-nodefaultlibs -lz -lutil -luClibc++ -lcurses -lgcc -lgcc_s -ldl" \
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -burN lftp-3.7.4.org/lib/gettext.h lftp-3.7.4/lib/gettext.h
|
diff -burN lftp-3.7.7/lib/gettext.h lftp-3.7.7.patched/lib/gettext.h
|
||||||
--- lftp-3.7.4.org/lib/gettext.h 2008-05-18 07:58:27.000000000 +0200
|
--- lftp-3.7.7/lib/gettext.h 2008-05-16 18:28:43.000000000 +0200
|
||||||
+++ lftp-3.7.4/lib/gettext.h 2008-11-05 16:03:37.769820993 +0100
|
+++ lftp-3.7.7.patched/lib/gettext.h 2009-01-03 18:59:05.374184151 +0100
|
||||||
@@ -22,7 +22,6 @@
|
@@ -22,7 +22,6 @@
|
||||||
#if ENABLE_NLS
|
#if ENABLE_NLS
|
||||||
|
|
||||||
|
23
net/lftp/patches/002-gettimeofday.patch
Normal file
23
net/lftp/patches/002-gettimeofday.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -burN lftp-3.7.7/lib/sys_time.in.h lftp-3.7.7.patched/lib/sys_time.in.h
|
||||||
|
--- lftp-3.7.7/lib/sys_time.in.h 2008-10-24 16:00:33.000000000 +0200
|
||||||
|
+++ lftp-3.7.7.patched/lib/sys_time.in.h 2009-01-03 21:20:34.129104049 +0100
|
||||||
|
@@ -39,6 +39,10 @@
|
||||||
|
# include <time.h>
|
||||||
|
# endif
|
||||||
|
|
||||||
|
+#ifdef __cplusplus
|
||||||
|
+extern "C" {
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
# if ! @HAVE_STRUCT_TIMEVAL@
|
||||||
|
struct timeval
|
||||||
|
{
|
||||||
|
@@ -53,4 +57,8 @@
|
||||||
|
int gettimeofday (struct timeval *restrict, void *restrict);
|
||||||
|
# endif
|
||||||
|
|
||||||
|
+#ifdef __cplusplus
|
||||||
|
+}
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#endif /* _GL_SYS_TIME_H */
|
Loading…
x
Reference in New Issue
Block a user