sipsak fixes:
- fix for SSP detection: gcc accepts -fstack-protector even if SSP is disabled, but will fail at linking - sanitize & cleanup - bump release number git-svn-id: svn://svn.openwrt.org/openwrt/packages@13969 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f10fe9b3ea
commit
1c931a8fbf
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2009 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=sipsak
|
PKG_NAME:=sipsak
|
||||||
PKG_VERSION:=0.9.6
|
PKG_VERSION:=0.9.6
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://download.berlios.de/sipsak/ \
|
PKG_SOURCE_URL:=http://download.berlios.de/sipsak/ \
|
||||||
@ -27,11 +27,8 @@ define Package/sipsak
|
|||||||
URL:=http://www.sipsak.org/
|
URL:=http://www.sipsak.org/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
CONFIGURE_ARGS += \
|
||||||
$(call Build/Configure/Default, \
|
--disable-gnutls \
|
||||||
--disable-gnutls \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
22
net/sipsak/patches/001-ssp.patch
Normal file
22
net/sipsak/patches/001-ssp.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- a/acinclude.m4
|
||||||
|
+++ b/acinclude.m4
|
||||||
|
@@ -363,7 +363,7 @@ AC_DEFUN([SIPSAK_GCC_STACK_PROTECT_CC],[
|
||||||
|
AC_MSG_CHECKING([whether ${CC} accepts -fstack-protector])
|
||||||
|
ssp_old_cflags="$CFLAGS"
|
||||||
|
CFLAGS="$CFLAGS -fstack-protector"
|
||||||
|
- AC_TRY_COMPILE(,,, ssp_cc=no)
|
||||||
|
+ AC_TRY_LINK(,,, ssp_cc=no)
|
||||||
|
echo $ssp_cc
|
||||||
|
if test "X$ssp_cc" = "Xno"; then
|
||||||
|
CFLAGS="$ssp_old_cflags"
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -2923,7 +2923,7 @@ main ()
|
||||||
|
_ACEOF
|
||||||
|
rm -f conftest.$ac_objext
|
||||||
|
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||||
|
- (eval $ac_compile) 2>conftest.er1
|
||||||
|
+ (eval $ac_link) 2>conftest.er1
|
||||||
|
ac_status=$?
|
||||||
|
grep -v '^ *+' conftest.er1 >conftest.err
|
||||||
|
rm -f conftest.er1
|
Loading…
x
Reference in New Issue
Block a user