htop: Bump to v1.0
Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/packages@29810 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a8f17dd19d
commit
1d0a051c42
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=htop
|
PKG_NAME:=htop
|
||||||
PKG_VERSION:=0.9
|
PKG_VERSION:=1.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||||
PKG_MD5SUM:=7c5507f35f363f3f40183a2ba3c561f8
|
PKG_MD5SUM:=325112ca7947ea1f6d6441f631e00384
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
@ -34,6 +34,10 @@ define Package/htop/description
|
|||||||
see all processes and their full command lines.
|
see all processes and their full command lines.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
--disable-native-affinity \
|
||||||
|
--enable-hwloc
|
||||||
|
|
||||||
CONFIGURE_VARS += \
|
CONFIGURE_VARS += \
|
||||||
ac_cv_file__proc_stat=yes \
|
ac_cv_file__proc_stat=yes \
|
||||||
ac_cv_file__proc_meminfo=yes \
|
ac_cv_file__proc_meminfo=yes \
|
||||||
|
@ -1,52 +0,0 @@
|
|||||||
--- a/CRT.c
|
|
||||||
+++ b/CRT.c
|
|
||||||
@@ -11,7 +11,9 @@ in the source distribution for its full
|
|
||||||
#include <signal.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <stdbool.h>
|
|
||||||
+#ifdef HAVE_EXECINFO_H
|
|
||||||
#include <execinfo.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include "String.h"
|
|
||||||
|
|
||||||
@@ -125,12 +127,14 @@ static void CRT_handleSIGSEGV(int sgn) {
|
|
||||||
CRT_done();
|
|
||||||
#if __linux
|
|
||||||
fprintf(stderr, "\n\nhtop " VERSION " aborting. Please report bug at http://htop.sf.net\n");
|
|
||||||
- #else
|
|
||||||
- fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
|
|
||||||
- #endif
|
|
||||||
+ #ifdef HAVE_EXECINFO_H
|
|
||||||
size_t size = backtrace(backtraceArray, sizeof(backtraceArray));
|
|
||||||
fprintf(stderr, "Backtrace: \n");
|
|
||||||
backtrace_symbols_fd(backtraceArray, size, 2);
|
|
||||||
+ #endif
|
|
||||||
+ #else
|
|
||||||
+ fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
|
|
||||||
+ #endif
|
|
||||||
abort();
|
|
||||||
}
|
|
||||||
|
|
||||||
--- a/CRT.h
|
|
||||||
+++ b/CRT.h
|
|
||||||
@@ -14,7 +14,9 @@ in the source distribution for its full
|
|
||||||
#include <signal.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <stdbool.h>
|
|
||||||
+#ifdef HAVE_EXECINFO_H
|
|
||||||
#include <execinfo.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include "String.h"
|
|
||||||
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -25,6 +25,7 @@ AC_HEADER_STDC
|
|
||||||
AC_CHECK_HEADERS([stdlib.h string.h strings.h sys/param.h sys/time.h unistd.h curses.h],[:],[
|
|
||||||
missing_headers="$missing_headers $ac_header"
|
|
||||||
])
|
|
||||||
+AC_CHECK_HEADERS([execinfo.h],[:],[:])
|
|
||||||
|
|
||||||
# Checks for typedefs, structures, and compiler characteristics.
|
|
||||||
AC_HEADER_STDBOOL
|
|
Loading…
x
Reference in New Issue
Block a user