[packages] lighttpd: update to 1.4.29, add patch for OpenSSL's disabled elliptic curve
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27726 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d306f16cd7
commit
1d30eaec87
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
# Copyright (C) 2006-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lighttpd
|
PKG_NAME:=lighttpd
|
||||||
PKG_VERSION:=1.4.28
|
PKG_VERSION:=1.4.29
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/
|
PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x
|
||||||
PKG_MD5SUM:=586eb535d31ac299652495b058dd87c4
|
PKG_MD5SUM:=e6e67b09986cb504db630b5a86b2dd76
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
14
net/lighttpd/patches/001-no_ec.patch
Normal file
14
net/lighttpd/patches/001-no_ec.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- a/src/network.c
|
||||||
|
+++ b/src/network.c
|
||||||
|
@@ -480,9 +480,11 @@ int network_init(server *srv) {
|
||||||
|
network_backend_t backend;
|
||||||
|
|
||||||
|
#if OPENSSL_VERSION_NUMBER >= 0x0090800fL
|
||||||
|
+#ifndef OPENSSL_NO_ECDH
|
||||||
|
EC_KEY *ecdh;
|
||||||
|
int nid;
|
||||||
|
#endif
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#ifdef USE_OPENSSL
|
||||||
|
DH *dh;
|
Loading…
x
Reference in New Issue
Block a user