[packages] httping: update to 1.5.2, refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27985 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
61b2cd6c03
commit
1d392afde9
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=httping
|
PKG_NAME:=httping
|
||||||
PKG_VERSION:=1.5.1
|
PKG_VERSION:=1.5.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=http://www.vanheusden.com/httping
|
PKG_SOURCE_URL:=http://www.vanheusden.com/httping
|
||||||
PKG_MD5SUM:=aeecd67cf90015e50cb03356f89d3c2c
|
PKG_MD5SUM:=49f72b124afb8a60f152ec674a162ad6
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#include "utils.h"
|
#include "utils.h"
|
||||||
#include "error.h"
|
#include "error.h"
|
||||||
|
|
||||||
+#define VERSION "1.5.1"
|
+#define VERSION "1.5.2"
|
||||||
+
|
+
|
||||||
static volatile int stop = 0;
|
static volatile int stop = 0;
|
||||||
|
|
||||||
@ -13,12 +13,12 @@
|
|||||||
|
|
||||||
void version(void)
|
void version(void)
|
||||||
{
|
{
|
||||||
- fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2010 folkert@vanheusden.com\n");
|
- fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2011 folkert@vanheusden.com\n");
|
||||||
+ fprintf(stderr, "HTTPing v%s (C) 2003-2010 folkert@vanheusden.com\n", VERSION);
|
+ fprintf(stderr, "HTTPing v%s (C) 2003-2011 folkert@vanheusden.com\n", VERSION);
|
||||||
#ifndef NO_SSL
|
#ifndef NO_SSL
|
||||||
fprintf(stderr, "SSL support included\n");
|
fprintf(stderr, "SSL support included\n");
|
||||||
#endif
|
#endif
|
||||||
@@ -637,7 +639,7 @@ int main(int argc, char *argv[])
|
@@ -639,7 +641,7 @@ int main(int argc, char *argv[])
|
||||||
if (useragent)
|
if (useragent)
|
||||||
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
||||||
else
|
else
|
||||||
|
Loading…
x
Reference in New Issue
Block a user