sane-backends: update to 1.0.24 and fix configure
- bump to 1.0.24 - get rid of shipped libtool - remove host include paths from configure macros - do not patch generated configure - refresh patches Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39460 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d236eeea3b
commit
1de539c66a
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,16 +8,17 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sane-backends
|
||||
PKG_VERSION:=1.0.23
|
||||
PKG_VERSION:=1.0.24
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://fossies.org/linux/misc \
|
||||
ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION) \
|
||||
https://alioth.debian.org/frs/download.php/3503
|
||||
PKG_MD5SUM:=e226a89c54173efea80e91e9a5eb6573
|
||||
https://alioth.debian.org/frs/download.php/3958
|
||||
PKG_MD5SUM:=1ca68e536cd7c1852322822f5f6ac3a4
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_REMOVE_FILES:=aclocal.m4
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -293,7 +293,7 @@ target_alias = @target_alias@
|
||||
@@ -396,7 +396,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-SUBDIRS = include lib sanei backend frontend tools doc po
|
||||
-SUBDIRS = include lib sanei backend frontend tools doc po testsuite
|
||||
+SUBDIRS = include lib sanei backend frontend
|
||||
DIST_SUBDIRS = include lib sanei backend frontend tools doc po japi testsuite
|
||||
dist_doc_DATA = AUTHORS ChangeLog COPYING LICENSE NEWS PROBLEMS PROJECTS \
|
||||
|
@ -1,12 +1,55 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -5070,9 +5070,6 @@ else
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -82,8 +82,6 @@ AM_CONDITIONAL(CROSS_COMPILING, test x$c
|
||||
dnl ***********************************************************************
|
||||
dnl set compiler/linker flags
|
||||
dnl ***********************************************************************
|
||||
-INCLUDES="${INCLUDES} -I/usr/local/include"
|
||||
-AC_SUBST(INCLUDES)
|
||||
SANE_SET_CFLAGS([$is_release])
|
||||
SANE_SET_LDFLAGS
|
||||
SANE_LINKER_RPATH
|
||||
@@ -332,30 +330,22 @@ if test -c /dev/urandom ; then
|
||||
AC_DEFINE(HAVE_DEV_URANDOM, 1, [Is /dev/urandom available?])
|
||||
fi
|
||||
|
||||
-dnl added by PN 3/2/12 to detect cups
|
||||
-$as_echo "checking for cups"
|
||||
-if test -e /usr/include/cups/cups.h ; then
|
||||
- AC_DEFINE(HAVE_CUPS, 1, [Is /usr/include/cups/cups.h available?])
|
||||
- with_cups="yes"
|
||||
- LIBS="-lcups $LIBS"
|
||||
-else
|
||||
- $as_echo "cups.h not found, you may want to install a cups development package"
|
||||
- $as_echo "in order to autodetect network scanners in kodakaio."
|
||||
- with_cups="no"
|
||||
+AC_CHECK_HEADERS([cups/cups.h], [with_cups=yes], [with_cups=no])
|
||||
+if test "x${with_cups}" = "xyes"; then
|
||||
+ AC_DEFINE(HAVE_CUPS,[1],[Is cups/cups.h available?])
|
||||
+ AC_PATH_PROG(CUPS_CONFIG, cups-config)
|
||||
+ if test "x${CUPS_CONFIG}" != "x"; then
|
||||
+ LIBS="$LIBS `$CUPS_CONFIG --libs`"
|
||||
+ fi
|
||||
fi
|
||||
|
||||
-INCLUDES="${INCLUDES} -I/usr/local/include"
|
||||
-
|
||||
-
|
||||
if test "${ac_cv_c_compiler_gnu}" = "yes"; then
|
||||
NORMAL_CFLAGS="\
|
||||
-W \
|
||||
-dnl added by llagendijk 12/7/2012 to detect systemd for saned
|
||||
-$as_echo_n "Checking for systemd..."
|
||||
-if test -e /usr/include/systemd/sd-daemon.h ; then
|
||||
- AC_DEFINE(HAVE_SYSTEMD, 1, [Is /usr/include/systemd/sd-daemon.h available?])
|
||||
- with_systemd="yes"
|
||||
- SYSTEMD_LIBS=" -lsystemd-daemon"
|
||||
- AC_SUBST(SYSTEMD_LIBS)
|
||||
- $as_echo "yes"
|
||||
-else
|
||||
- with_systemd="no"
|
||||
- $as_echo "no"
|
||||
+AC_CHECK_HEADERS([systemd/sd-daemon.h])
|
||||
+PKG_CHECK_MODULES([HAVE_SYSTEMD], [libsystemd-daemon], [with_systemd=yes], [with_systemd=no])
|
||||
+if test "x${with_systemd}" = "xyes"; then
|
||||
+ AC_DEFINE(HAVE_SYSTEMD,[1],[Is systemd/sd-daemon.h available?])
|
||||
+ SYSTEMD_LIBS="-lsystemd-daemon"
|
||||
fi
|
||||
+AC_SUBST(SYSTEMD_LIBS)
|
||||
|
||||
dnl ***********
|
||||
dnl USB Support
|
||||
|
Loading…
x
Reference in New Issue
Block a user