mysql: update to version 5.1.53

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24053 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2010-11-21 14:09:24 +00:00
parent b3ce8fa3a2
commit 1e0adcb336
4 changed files with 7609 additions and 3308 deletions

View File

@ -8,16 +8,16 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=mysql PKG_NAME:=mysql
PKG_VERSION:=5.0.18 PKG_VERSION:=5.1.53
PKG_RELEASE:=3 PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=\ PKG_SOURCE_URL:=\
http://mysql.planetmirror.com/Downloads/MySQL-5.0/ \ http://mysql.planetmirror.com/Downloads/MySQL-5.1/ \
http://mysql.he.net/Downloads/MySQL-5.0/ \ http://mysql.he.net/Downloads/MySQL-5.1/ \
http://www.linorg.usp.br/mysql/Downloads/MySQL-5.0/ \ http://www.linorg.usp.br/mysql/Downloads/MySQL-5.1/ \
http://mysql.holywar.net/Downloads/MySQL-5.0/ http://mysql.holywar.net/Downloads/MySQL-5.1/
PKG_MD5SUM:=f18153b0239aaa03fc5a751f2d82cb71 PKG_MD5SUM:=e5e7c5b0b5c382489e6a66778703bc46
PKG_BUILD_DEPENDS:=libncurses libreadline PKG_BUILD_DEPENDS:=libncurses libreadline
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
@ -71,6 +71,7 @@ define Build/Configure
config.h.in \ config.h.in \
configure \ configure \
); );
$(CP) files/lex_hash.h $(PKG_BUILD_DIR)/sql/lex_hash.h
$(call Build/Configure/Default, \ $(call Build/Configure/Default, \
--enable-shared \ --enable-shared \
@ -90,7 +91,7 @@ define Build/Configure
--without-query-cache \ --without-query-cache \
--without-mysqlfs \ --without-mysqlfs \
--without-vio \ --without-vio \
--without-openssl \ --without-ssl \
--without-docs \ --without-docs \
--without-man \ --without-man \
--without-bench \ --without-bench \
@ -100,6 +101,7 @@ define Build/Configure
, \ , \
mysql_cv_compress=yes \ mysql_cv_compress=yes \
mysql_cv_gethostname_style=glibc2 \ mysql_cv_gethostname_style=glibc2 \
ac_cv_c_stack_direction=-1 \
); );
endef endef
@ -178,7 +180,6 @@ define Package/mysql-server/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mysqladmin $(1)/usr/bin/ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mysqladmin $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mysqldump $(1)/usr/bin/ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mysqldump $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mysql_install_db $(1)/usr/bin/ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mysql_install_db $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mysql_create_system_tables $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/my_print_defaults $(1)/usr/bin/ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/my_print_defaults $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/init.d/ $(INSTALL_DIR) $(1)/etc/init.d/
$(INSTALL_BIN) files/mysqld.init $(1)/etc/init.d/mysqld $(INSTALL_BIN) files/mysqld.init $(1)/etc/init.d/mysqld

6190
libs/mysql/files/lex_hash.h Normal file

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -1,112 +1,117 @@
--- mysql.old/sql/Makefile.am 2005-12-21 12:39:32.000000000 -0700 --- a/sql/Makefile.am
+++ mysql.dev/sql/Makefile.am 2010-08-07 15:13:34.399776279 -0600 +++ b/sql/Makefile.am
@@ -148,8 +148,8 @@ @@ -41,7 +41,6 @@ mysqld_DEPENDENCIES= @mysql_plugin_libs@
@echo "If it fails, re-run configure with --with-low-memory" LDADD = $(SUPPORTING_LIBS) @ZLIB_LIBS@ @NDB_SCI_LIBS@
$(CXXCOMPILE) $(LM_CFLAGS) -c $< mysqld_LDADD = libndb.la \
@MYSQLD_EXTRA_LDFLAGS@ \
-lex_hash.h: gen_lex_hash$(EXEEXT) - @pstack_libs@ \
- ./gen_lex_hash$(EXEEXT) > $@ @mysql_plugin_libs@ \
+#lex_hash.h: gen_lex_hash$(EXEEXT)
+# ./gen_lex_hash$(EXEEXT) > $@
# For testing of udf_example.so; Works on platforms with gcc
# (This is not part of our build process but only provided as an example)
--- mysql.old/sql/Makefile.in 2005-12-21 12:41:41.000000000 -0700
+++ mysql.dev/sql/Makefile.in 2010-08-07 15:15:39.747273400 -0600
@@ -1253,8 +1253,8 @@
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@
+#lex_hash.h: gen_lex_hash$(EXEEXT)
+# ./gen_lex_hash$(EXEEXT) > $@
# For testing of udf_example.so; Works on platforms with gcc
# (This is not part of our build process but only provided as an example)
--- mysql.old/extra/Makefile.am 2005-12-21 12:39:55.000000000 -0700
+++ mysql.dev/extra/Makefile.am 2010-08-07 16:44:45.649771408 -0600
@@ -29,14 +29,14 @@
DIST_SUBDIRS= yassl
# This will build mysqld_error.h and sql_state.h
-$(top_builddir)/include/mysqld_error.h: comp_err$(EXEEXT)
- $(top_builddir)/extra/comp_err$(EXEEXT) \
- --charset=$(top_srcdir)/sql/share/charsets \
- --out-dir=$(top_builddir)/sql/share/ \
- --header_file=$(top_builddir)/include/mysqld_error.h \
- --name_file=$(top_builddir)/include/mysqld_ername.h \
- --state_file=$(top_builddir)/include/sql_state.h \
- --in_file=$(top_srcdir)/sql/share/errmsg.txt
+#$(top_builddir)/include/mysqld_error.h: comp_err$(EXEEXT)
+# $(top_builddir)/extra/comp_err$(EXEEXT) \
+# --charset=$(top_srcdir)/sql/share/charsets \
+# --out-dir=$(top_builddir)/sql/share/ \
+# --header_file=$(top_builddir)/include/mysqld_error.h \
+# --name_file=$(top_builddir)/include/mysqld_ername.h \
+# --state_file=$(top_builddir)/include/sql_state.h \
+# --in_file=$(top_srcdir)/sql/share/errmsg.txt
$(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h
--- mysql.old/extra/Makefile.in 2005-12-21 12:41:16.000000000 -0700
+++ mysql.dev/extra/Makefile.in 2010-08-07 16:44:29.537273634 -0600
@@ -870,14 +870,14 @@
# This will build mysqld_error.h and sql_state.h
-$(top_builddir)/include/mysqld_error.h: comp_err$(EXEEXT)
- $(top_builddir)/extra/comp_err$(EXEEXT) \
- --charset=$(top_srcdir)/sql/share/charsets \
- --out-dir=$(top_builddir)/sql/share/ \
- --header_file=$(top_builddir)/include/mysqld_error.h \
- --name_file=$(top_builddir)/include/mysqld_ername.h \
- --state_file=$(top_builddir)/include/sql_state.h \
- --in_file=$(top_srcdir)/sql/share/errmsg.txt
+#$(top_builddir)/include/mysqld_error.h: comp_err$(EXEEXT)
+# $(top_builddir)/extra/comp_err$(EXEEXT) \
+# --charset=$(top_srcdir)/sql/share/charsets \
+# --out-dir=$(top_builddir)/sql/share/ \
+# --header_file=$(top_builddir)/include/mysqld_error.h \
+# --name_file=$(top_builddir)/include/mysqld_ername.h \
+# --state_file=$(top_builddir)/include/sql_state.h \
+# --in_file=$(top_srcdir)/sql/share/errmsg.txt
$(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h
--- mysql.old/sql/Makefile.am 2010-08-07 16:53:38.047275454 -0600
+++ mysql.dev/sql/Makefile.am 2010-08-07 17:20:05.947271939 -0600
@@ -40,7 +40,7 @@
$(top_builddir)/strings/libmystrings.a @ZLIB_LIBS@ @NDB_SCI_LIBS@
mysqld_LDADD = @MYSQLD_EXTRA_LDFLAGS@ \
- @bdb_libs@ @innodb_libs@ @pstack_libs@ \
+ @bdb_libs@ @innodb_libs@ \
@innodb_system_libs@ \
@ndbcluster_libs@ @ndbcluster_system_libs@ \
$(LDADD) $(CXXLDFLAGS) $(WRAPLIBS) @LIBDL@ \ $(LDADD) $(CXXLDFLAGS) $(WRAPLIBS) @LIBDL@ \
$(yassl_libs) $(openssl_libs) @MYSQLD_EXTRA_LIBS@
--- mysql.old/sql/Makefile.in 2010-08-07 16:53:38.047275454 -0600 @@ -174,10 +173,10 @@ link_sources:
+++ mysql.dev/sql/Makefile.in 2010-08-07 17:20:23.197362907 -0600 # This generates lex_hash.h
@@ -483,8 +483,6 @@ # NOTE Built sources should depend on their sources not the tool
openssl_libs = @openssl_libs@ # this avoid the rebuild of the built files in a source dist
-lex_hash.h: gen_lex_hash.cc lex.h
- $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@-t
- $(MV) $@-t $@
+#lex_hash.h: gen_lex_hash.cc lex.h
+# $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
+# ./gen_lex_hash$(EXEEXT) > $@-t
+# $(MV) $@-t $@
# For testing of udf_example.so
udf_example_la_SOURCES= udf_example.c
--- a/sql/Makefile.in
+++ b/sql/Makefile.in
@@ -486,8 +486,6 @@ plugin_partition_static_target = @plugin
prefix = @prefix@ prefix = @prefix@
program_transform_name = @program_transform_name@ program_transform_name = @program_transform_name@
-pstack_dirs = @pstack_dirs@ psdir = @psdir@
-pstack_dir = @pstack_dir@
-pstack_libs = @pstack_libs@ -pstack_libs = @pstack_libs@
readline_basedir = @readline_basedir@ readline_basedir = @readline_basedir@
readline_dir = @readline_dir@ readline_dir = @readline_dir@
readline_h_ln_cmd = @readline_h_ln_cmd@ readline_h_ln_cmd = @readline_h_ln_cmd@
@@ -533,7 +531,7 @@ @@ -541,7 +539,6 @@ mysqld_DEPENDENCIES = @mysql_plugin_libs
$(top_builddir)/strings/libmystrings.a @ZLIB_LIBS@ @NDB_SCI_LIBS@ LDADD = $(SUPPORTING_LIBS) @ZLIB_LIBS@ @NDB_SCI_LIBS@
mysqld_LDADD = libndb.la \
mysqld_LDADD = @MYSQLD_EXTRA_LDFLAGS@ \ @MYSQLD_EXTRA_LDFLAGS@ \
- @bdb_libs@ @innodb_libs@ @pstack_libs@ \ - @pstack_libs@ \
+ @bdb_libs@ @innodb_libs@ \ @mysql_plugin_libs@ \
@innodb_system_libs@ \
@ndbcluster_libs@ @ndbcluster_system_libs@ \
$(LDADD) $(CXXLDFLAGS) $(WRAPLIBS) @LIBDL@ \ $(LDADD) $(CXXLDFLAGS) $(WRAPLIBS) @LIBDL@ \
$(yassl_libs) $(openssl_libs) @MYSQLD_EXTRA_LIBS@
@@ -1308,10 +1305,10 @@ link_sources:
# This generates lex_hash.h
# NOTE Built sources should depend on their sources not the tool
# this avoid the rebuild of the built files in a source dist
-lex_hash.h: gen_lex_hash.cc lex.h
- $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@-t
- $(MV) $@-t $@
+#lex_hash.h: gen_lex_hash.cc lex.h
+# $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
+# ./gen_lex_hash$(EXEEXT) > $@-t
+# $(MV) $@-t $@
# We might have some stuff not built in this build, but that we want to install
install-exec-hook:
--- a/extra/Makefile.am
+++ b/extra/Makefile.am
@@ -29,16 +29,16 @@ DIST_SUBDIRS = yassl
# This will build mysqld_error.h, mysqld_ername.h and sql_state.h
# NOTE Built files should depend on their sources to avoid
# the built files being rebuilt in source dist
-$(top_builddir)/include/mysqld_error.h: comp_err.c \
- $(top_srcdir)/sql/share/errmsg.txt
- $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
- $(top_builddir)/extra/comp_err$(EXEEXT) \
- --charset=$(top_srcdir)/sql/share/charsets \
- --out-dir=$(top_builddir)/sql/share/ \
- --header_file=$(top_builddir)/include/mysqld_error.h \
- --name_file=$(top_builddir)/include/mysqld_ername.h \
- --state_file=$(top_builddir)/include/sql_state.h \
- --in_file=$(top_srcdir)/sql/share/errmsg.txt
+#$(top_builddir)/include/mysqld_error.h: comp_err.c \
+# $(top_srcdir)/sql/share/errmsg.txt
+# $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
+# $(top_builddir)/extra/comp_err$(EXEEXT) \
+# --charset=$(top_srcdir)/sql/share/charsets \
+# --out-dir=$(top_builddir)/sql/share/ \
+# --header_file=$(top_builddir)/include/mysqld_error.h \
+# --name_file=$(top_builddir)/include/mysqld_ername.h \
+# --state_file=$(top_builddir)/include/sql_state.h \
+# --in_file=$(top_srcdir)/sql/share/errmsg.txt
$(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h
--- a/extra/Makefile.in
+++ b/extra/Makefile.in
@@ -938,16 +938,16 @@ uninstall-am: uninstall-binPROGRAMS unin
# This will build mysqld_error.h, mysqld_ername.h and sql_state.h
# NOTE Built files should depend on their sources to avoid
# the built files being rebuilt in source dist
-$(top_builddir)/include/mysqld_error.h: comp_err.c \
- $(top_srcdir)/sql/share/errmsg.txt
- $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
- $(top_builddir)/extra/comp_err$(EXEEXT) \
- --charset=$(top_srcdir)/sql/share/charsets \
- --out-dir=$(top_builddir)/sql/share/ \
- --header_file=$(top_builddir)/include/mysqld_error.h \
- --name_file=$(top_builddir)/include/mysqld_ername.h \
- --state_file=$(top_builddir)/include/sql_state.h \
- --in_file=$(top_srcdir)/sql/share/errmsg.txt
+#$(top_builddir)/include/mysqld_error.h: comp_err.c \
+# $(top_srcdir)/sql/share/errmsg.txt
+# $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
+# $(top_builddir)/extra/comp_err$(EXEEXT) \
+# --charset=$(top_srcdir)/sql/share/charsets \
+# --out-dir=$(top_builddir)/sql/share/ \
+# --header_file=$(top_builddir)/include/mysqld_error.h \
+# --name_file=$(top_builddir)/include/mysqld_ername.h \
+# --state_file=$(top_builddir)/include/sql_state.h \
+# --in_file=$(top_srcdir)/sql/share/errmsg.txt
$(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h