Cleanup glib2 package.
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12844 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1a2a302150
commit
1f000ad08d
@ -91,9 +91,6 @@ define Build/InstallDev
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
|
||||
$(1)/usr/lib/pkgconfig
|
||||
$(SED) \
|
||||
"s,=\(glib-genmarshal\|gobject-query\|glib-mkenums\),=$(STAGING_DIR_HOST)/bin/\1,g" \
|
||||
$(1)/usr/lib/pkgconfig/glib-2.0.pc
|
||||
|
||||
$(INSTALL_DIR) $(2)/share/aclocal/
|
||||
$(INSTALL_DATA) \
|
||||
|
@ -1,59 +0,0 @@
|
||||
diff -urN glib-2.16.5.orig/gio/Makefile.in glib-2.16.5/gio/Makefile.in
|
||||
--- glib-2.16.5.orig/gio/Makefile.in 2008-09-02 01:43:09.000000000 +0200
|
||||
+++ glib-2.16.5/gio/Makefile.in 2008-09-02 01:47:01.000000000 +0200
|
||||
@@ -165,7 +165,7 @@
|
||||
distclean-recursive maintainer-clean-recursive
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
-DIST_SUBDIRS = xdgmime inotify . fam tests
|
||||
+DIST_SUBDIRS = xdgmime inotify . fam
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
ACLOCAL = @ACLOCAL@
|
||||
ALLOCA = @ALLOCA@
|
||||
@@ -380,7 +380,7 @@
|
||||
pltcheck.sh $(NULL)
|
||||
TEST_PROGS =
|
||||
NULL =
|
||||
-SUBDIRS = $(am__append_1) $(am__append_2) . $(am__append_4) tests
|
||||
+SUBDIRS = $(am__append_1) $(am__append_2) . $(am__append_4)
|
||||
@MS_LIB_AVAILABLE_TRUE@noinst_DATA = gio-2.0.lib
|
||||
@HAVE_GNUC_VISIBILITY_TRUE@@OS_LINUX_TRUE@TESTS = abicheck.sh pltcheck.sh
|
||||
AM_CPPFLAGS = \
|
||||
diff -urN glib-2.16.5.orig/glib/Makefile.in glib-2.16.5/glib/Makefile.in
|
||||
--- glib-2.16.5.orig/glib/Makefile.in 2008-09-02 01:43:17.000000000 +0200
|
||||
+++ glib-2.16.5/glib/Makefile.in 2008-09-02 01:44:48.000000000 +0200
|
||||
@@ -396,8 +396,8 @@
|
||||
@ENABLE_REGEX_TRUE@gregex_c = gregex.c
|
||||
@ENABLE_REGEX_FALSE@gregex_h =
|
||||
@ENABLE_REGEX_TRUE@gregex_h = gregex.h
|
||||
-SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
|
||||
-DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
|
||||
+SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
|
||||
+DIST_SUBDIRS = libcharset gnulib pcre update-pcre
|
||||
AM_CPPFLAGS = \
|
||||
-I$(top_srcdir) \
|
||||
$(pcre_inc) \
|
||||
diff -urN glib-2.16.5.orig/gobject/Makefile.in glib-2.16.5/gobject/Makefile.in
|
||||
--- glib-2.16.5.orig/gobject/Makefile.in 2008-09-02 01:43:06.000000000 +0200
|
||||
+++ glib-2.16.5/gobject/Makefile.in 2008-09-02 01:46:05.000000000 +0200
|
||||
@@ -343,7 +343,7 @@
|
||||
# GObject - GLib Type, Object, Parameter and Signal Library
|
||||
# Copyright (C) 1997,98,99,2000 Tim Janik and Red Hat, Inc.
|
||||
#
|
||||
-SUBDIRS = . tests
|
||||
+SUBDIRS = .
|
||||
AM_CPPFLAGS = \
|
||||
-DG_LOG_DOMAIN=\"GLib-GObject\" \
|
||||
-I$(top_srcdir) \
|
||||
diff -urN glib-2.16.5.orig/Makefile.in glib-2.16.5/Makefile.in
|
||||
--- glib-2.16.5.orig/Makefile.in 2008-09-02 01:42:56.000000000 +0200
|
||||
+++ glib-2.16.5/Makefile.in 2008-09-02 01:44:05.000000000 +0200
|
||||
@@ -342,7 +342,7 @@
|
||||
gio-2.0-uninstalled.pc.in gio-unix-2.0-uninstalled.pc.in
|
||||
TEST_PROGS =
|
||||
AUTOMAKE_OPTIONS = 1.7
|
||||
-SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
|
||||
+SUBDIRS = . m4macros glib gmodule gthread gobject gio po
|
||||
DIST_SUBDIRS = $(SUBDIRS) build
|
||||
bin_SCRIPTS = glib-gettextize
|
||||
AM_CPPFLAGS = \
|
10
libs/glib2/patches/010-move-iconv-to-libs.patch
Normal file
10
libs/glib2/patches/010-move-iconv-to-libs.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- glib-2.18.1/glib-2.0.pc.in.orig 2008-10-03 22:32:17.000000000 +0200
|
||||
+++ glib-2.18.1/glib-2.0.pc.in 2008-10-03 22:32:42.000000000 +0200
|
||||
@@ -10,6 +10,5 @@
|
||||
Name: GLib
|
||||
Description: C Utility Library
|
||||
Version: @VERSION@
|
||||
-Libs: -L${libdir} -lglib-2.0 @INTLLIBS@
|
||||
-Libs.private: @ICONV_LIBS@
|
||||
+Libs: -L${libdir} -lglib-2.0 @INTLLIBS@ @ICONV_LIBS@
|
||||
Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include @GLIB_EXTRA_CFLAGS@
|
50
libs/glib2/patches/020-dont-build-tests.patch
Normal file
50
libs/glib2/patches/020-dont-build-tests.patch
Normal file
@ -0,0 +1,50 @@
|
||||
diff -urN glib-2.18.1.orig/gio/Makefile.in glib-2.18.1/gio/Makefile.in
|
||||
--- glib-2.18.1.orig/gio/Makefile.in 2008-10-03 23:13:00.000000000 +0200
|
||||
+++ glib-2.18.1/gio/Makefile.in 2008-10-03 23:15:25.000000000 +0200
|
||||
@@ -180,7 +180,7 @@
|
||||
distclean-recursive maintainer-clean-recursive
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
-DIST_SUBDIRS = xdgmime inotify fen win32 . fam tests
|
||||
+DIST_SUBDIRS = xdgmime inotify fen . fam
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
ACLOCAL = @ACLOCAL@
|
||||
ALLOCA = @ALLOCA@
|
||||
diff -urN glib-2.18.1.orig/glib/Makefile.in glib-2.18.1/glib/Makefile.in
|
||||
--- glib-2.18.1.orig/glib/Makefile.in 2008-10-03 23:12:28.000000000 +0200
|
||||
+++ glib-2.18.1/glib/Makefile.in 2008-10-03 23:14:46.000000000 +0200
|
||||
@@ -412,8 +412,8 @@
|
||||
@ENABLE_REGEX_TRUE@gregex_c = gregex.c
|
||||
@ENABLE_REGEX_FALSE@gregex_h =
|
||||
@ENABLE_REGEX_TRUE@gregex_h = gregex.h
|
||||
-SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
|
||||
-DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
|
||||
+SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
|
||||
+DIST_SUBDIRS = libcharset gnulib pcre update-pcre
|
||||
AM_CPPFLAGS = \
|
||||
-I$(top_srcdir) \
|
||||
$(pcre_inc) \
|
||||
diff -urN glib-2.18.1.orig/gobject/Makefile.in glib-2.18.1/gobject/Makefile.in
|
||||
--- glib-2.18.1.orig/gobject/Makefile.in 2008-10-03 23:12:46.000000000 +0200
|
||||
+++ glib-2.18.1/gobject/Makefile.in 2008-10-03 23:16:12.000000000 +0200
|
||||
@@ -341,7 +341,7 @@
|
||||
# GObject - GLib Type, Object, Parameter and Signal Library
|
||||
# Copyright (C) 1997,98,99,2000 Tim Janik and Red Hat, Inc.
|
||||
#
|
||||
-SUBDIRS = . tests
|
||||
+SUBDIRS = .
|
||||
AM_CPPFLAGS = \
|
||||
-DG_LOG_DOMAIN=\"GLib-GObject\" \
|
||||
-I$(top_srcdir) \
|
||||
diff -urN glib-2.18.1.orig/Makefile.in glib-2.18.1/Makefile.in
|
||||
--- glib-2.18.1.orig/Makefile.in 2008-10-03 23:12:28.000000000 +0200
|
||||
+++ glib-2.18.1/Makefile.in 2008-10-03 23:14:14.000000000 +0200
|
||||
@@ -340,7 +340,7 @@
|
||||
gio-2.0-uninstalled.pc.in gio-unix-2.0-uninstalled.pc.in
|
||||
TEST_PROGS =
|
||||
AUTOMAKE_OPTIONS = 1.7
|
||||
-SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
|
||||
+SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs
|
||||
DIST_SUBDIRS = $(SUBDIRS) build
|
||||
bin_SCRIPTS = glib-gettextize
|
||||
AM_CPPFLAGS = \
|
Loading…
x
Reference in New Issue
Block a user