[packages] miniupnpc: update to 1.5
* add libminiupnpc package * use PKG_INSTALL & MAKE_FLAGS * add copyright info * refresh patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@26921 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cbe675b40f
commit
1f3cbf484c
@ -1,28 +1,72 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2010-2011 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=miniupnpc
|
PKG_NAME:=miniupnpc
|
||||||
PKG_VERSION:=1.4
|
PKG_VERSION:=1.5
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
|
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_MD5SUM:=e8de10c42d64e77c321e57400d50e7e4
|
PKG_MD5SUM:=0efa7498d27c82a56a0300b0c05c4f58
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/miniupnpc/Default
|
||||||
|
TITLE:=Lightweight UPnP
|
||||||
|
URL:=http://miniupnp.tuxfamily.org/
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/miniupnpc
|
define Package/miniupnpc
|
||||||
|
$(call Package/miniupnpc/Default)
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
SUBMENU:=Firewall
|
SUBMENU:=Firewall
|
||||||
TITLE:=Lightweight UPnP client
|
TITLE+= client
|
||||||
URL:=http://miniupnp.tuxfamily.org/
|
DEPENDS:=+libminiupnpc
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libminiupnpc
|
||||||
|
$(call Package/miniupnpc/Default)
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
TITLE+= library
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC)
|
||||||
|
|
||||||
|
MAKE_FLAGS += \
|
||||||
|
PREFIX="$(PKG_INSTALL_DIR)"
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr/include/miniupnpc
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/include/miniupnpc/*.h \
|
||||||
|
$(1)/usr/include/miniupnpc/
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/*.{so*,a} \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/miniupnpc/install
|
define Package/miniupnpc/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/upnpc-static $(1)/usr/bin/upnpc
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/upnpc $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libminiupnpc/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/libminiupnpc.so.* \
|
||||||
|
$(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,miniupnpc))
|
$(eval $(call BuildPackage,miniupnpc))
|
||||||
|
$(eval $(call BuildPackage,libminiupnpc))
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- miniupnpc-1.4/Makefile 2009-10-10 12:19:40.000000000 -0700
|
--- a/Makefile
|
||||||
+++ miniupnpc-1.4/Makefile 2010-03-03 13:31:02.000000000 -0800
|
+++ b/Makefile
|
||||||
@@ -67,8 +67,8 @@
|
@@ -107,8 +107,8 @@ installpythonmodule: pythonmodule
|
||||||
python setup.py install
|
python setup.py install
|
||||||
|
|
||||||
validateminixml: minixmlvalid
|
validateminixml: minixmlvalid
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- miniupnpc-1.4/upnpcommands.c 2009-07-13 01:44:43.000000000 -0700
|
--- a/upnpcommands.c
|
||||||
+++ miniupnpc-1.4/upnpcommands.c 2010-03-03 13:33:21.000000000 -0800
|
+++ b/upnpcommands.c
|
||||||
@@ -335,7 +335,7 @@
|
@@ -351,7 +351,7 @@ UPNP_AddPortMapping(const char * control
|
||||||
AddPortMappingArgs[5].elt = "NewEnabled";
|
AddPortMappingArgs[5].elt = "NewEnabled";
|
||||||
AddPortMappingArgs[5].val = "1";
|
AddPortMappingArgs[5].val = "1";
|
||||||
AddPortMappingArgs[6].elt = "NewPortMappingDescription";
|
AddPortMappingArgs[6].elt = "NewPortMappingDescription";
|
||||||
@ -8,4 +8,4 @@
|
|||||||
+ AddPortMappingArgs[6].val = desc?desc:"miniupnpc";
|
+ AddPortMappingArgs[6].val = desc?desc:"miniupnpc";
|
||||||
AddPortMappingArgs[7].elt = "NewLeaseDuration";
|
AddPortMappingArgs[7].elt = "NewLeaseDuration";
|
||||||
AddPortMappingArgs[7].val = "0";
|
AddPortMappingArgs[7].val = "0";
|
||||||
simpleUPnPcommand(-1, controlURL, servicetype, "AddPortMapping", AddPortMappingArgs, buffer, &bufsize);
|
if(simpleUPnPcommand(-1, controlURL, servicetype, "AddPortMapping", AddPortMappingArgs, buffer, &bufsize) < 0) {
|
||||||
|
Loading…
x
Reference in New Issue
Block a user