[packages] mc: update to v4.6.2, update URLs, cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17940 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
04445c97bb
commit
1f82846b13
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2009 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,14 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mc
|
PKG_NAME:=mc
|
||||||
PKG_VERSION:=4.6.1
|
PKG_VERSION:=4.6.2
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/
|
PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
|
||||||
PKG_MD5SUM:=18b20db6e40480a53bac2870c56fc3c4
|
PKG_MD5SUM:=ec92966f4d0c8b50c344fe901859ae2a
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=glib1 libncurses
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -24,7 +22,7 @@ define Package/mc
|
|||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
DEPENDS:=+glib1 +libncurses
|
DEPENDS:=+glib1 +libncurses
|
||||||
TITLE:=midnight commander - a powerful file manager
|
TITLE:=midnight commander - a powerful file manager
|
||||||
URL:=http://www.ibiblio.org/mc/
|
URL:=http://www.midnight-commander.org/
|
||||||
SUBMENU:=filemanager
|
SUBMENU:=filemanager
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -39,8 +37,6 @@ define Package/mc/description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--prefix=/usr \
|
|
||||||
--disable-nls \
|
|
||||||
--with-included-gettext \
|
--with-included-gettext \
|
||||||
--with-ncurses \
|
--with-ncurses \
|
||||||
--without-sco \
|
--without-sco \
|
||||||
@ -66,13 +62,11 @@ CONFIGURE_ARGS += \
|
|||||||
--disable-glibtest \
|
--disable-glibtest \
|
||||||
--with-glib12 \
|
--with-glib12 \
|
||||||
--with-glib-prefix="$(STAGING_DIR)/usr" \
|
--with-glib-prefix="$(STAGING_DIR)/usr" \
|
||||||
, \
|
|
||||||
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
|
|
||||||
|
|
||||||
define Package/mc/install
|
define Package/mc/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/
|
||||||
ln -sf mc $(1)/usr/bin/mcedit
|
ln -nsf mc $(1)/usr/bin/mcedit
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,mc))
|
$(eval $(call BuildPackage,mc))
|
||||||
|
@ -1,19 +1,14 @@
|
|||||||
Index: mc-4.6.1/edit/syntax.c
|
--- a/edit/syntax.c
|
||||||
===================================================================
|
+++ b/edit/syntax.c
|
||||||
--- mc-4.6.1.orig/edit/syntax.c 2007-07-26 17:35:14.000000000 +0200
|
@@ -1193,10 +1193,7 @@ edit_load_syntax (WEdit *edit, char ***p
|
||||||
+++ mc-4.6.1/edit/syntax.c 2007-07-26 17:35:14.000000000 +0200
|
r = edit_read_syntax_file (edit, pnames, f, edit ? edit->filename : 0,
|
||||||
@@ -1113,13 +1113,8 @@
|
|
||||||
f = catstrs (home_dir, SYNTAX_FILE, (char *) NULL);
|
|
||||||
r = edit_read_syntax_file (edit, names, f, edit ? edit->filename : 0,
|
|
||||||
get_first_editor_line (edit), type);
|
get_first_editor_line (edit), type);
|
||||||
- if (r == -1) {
|
if (r == -1) {
|
||||||
- edit_free_syntax_rules (edit);
|
- edit_free_syntax_rules (edit);
|
||||||
- message (D_ERROR, _(" Load syntax file "),
|
- message (D_ERROR, _(" Load syntax file "),
|
||||||
- _(" Cannot open file %s \n %s "), f,
|
- _(" Cannot open file %s \n %s "), f,
|
||||||
- unix_error_string (errno));
|
- unix_error_string (errno));
|
||||||
+ if (r == -1)
|
+ /* missing syntax file */
|
||||||
return;
|
} else if (r) {
|
||||||
- }
|
|
||||||
if (r) {
|
|
||||||
edit_free_syntax_rules (edit);
|
edit_free_syntax_rules (edit);
|
||||||
message (D_ERROR, _(" Load syntax file "),
|
message (D_ERROR, _(" Load syntax file "),
|
||||||
|
Loading…
x
Reference in New Issue
Block a user