Fix wrt-radauth compilation (#3282)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@10701 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-04-01 20:51:36 +00:00
parent a42c9d6e6c
commit 2043dba261
2 changed files with 16 additions and 3 deletions

View File

@ -9,10 +9,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wrt-radauth
PKG_VERSION:=1.0
PKG_VERSION:=0.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME).tar.gz
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.zerfleddert.de/wrt54g/
PKG_MD5SUM:=f941e3139175dc6b87f6c89ba8848a07
@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/wrt-radauth
SECTION:=net
CATEGORY:=Network
DEPENDS:=kmod-brcm-wl +nvram
DEPENDS:=+kmod-brcm-wl +nvram
TITLE:=A Radius MAC authenticator for Broadcom based access points
URL:=http://www.zerfleddert.de/wrt54g/
endef
@ -35,6 +35,7 @@ define Package/wrt-radauth/description
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) clean
$(call Build/Compile/Default, \
CFLAGS="$(EXTRA_CFLAGS)" \
LDFLAGS="$(EXTRA_LDFLAGS)" \

View File

@ -0,0 +1,12 @@
diff -urN wrt-radauth/Makefile wrt-radauth.new/Makefile
--- wrt-radauth/Makefile 2007-01-07 20:05:21.000000000 +0100
+++ wrt-radauth.new/Makefile 2008-04-01 22:50:09.000000000 +0200
@@ -7,7 +7,7 @@
all: wrt-radauth radius-client
wrt-radauth: wrt-radauth.o md5.o wireless.o radius.o
- $(CC) $(LDFLAGS) -L$(WRT_BUILDROOT)/build_mipsel/root/usr/lib -lshared -lnvram $^ -o $@
+ $(CC) $(CFLAGS) $(LDFLAGS) -L$(STAGING_DIR)/usr/lib -lshared -lnvram $^ -o $@
radius-client: radius-client.o md5.o radius.o