packages: znc: update to 1.2

Various fixes and small enhancements as well as the return of the
fakeonline module (now known as modules_online).

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39136 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jogo 2013-12-19 11:33:40 +00:00
parent 7a4869aed3
commit 206eb9fdca
4 changed files with 15 additions and 16 deletions

View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=znc PKG_NAME:=znc
PKG_VERSION:=1.0 PKG_VERSION:=1.2
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://znc.in/releases \ PKG_SOURCE_URL:=http://znc.in/releases \
http://znc.in/releases/archive http://znc.in/releases/archive
PKG_MD5SUM:=23807ca830c27392cccb6774f542df6e PKG_MD5SUM:=ef18e5402a82cc3fcab5c2ac5c2e6f3b
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
@ -25,7 +25,7 @@ define Package/znc/default
CATEGORY:=Network CATEGORY:=Network
TITLE:=ZNC TITLE:=ZNC
URL:=http://en.znc.in/ URL:=http://en.znc.in/
MAINTAINER:=Jonas Gorski <jonas.gorski+openwrt@gmail.com> MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
endef endef
define Package/znc define Package/znc
@ -205,6 +205,9 @@ $(eval $(call module,listsockets,This module displays a list of all open \
$(eval $(call module,log,Log conversations to file.)) $(eval $(call module,log,Log conversations to file.))
$(eval $(call module,modules_online,This module fakes the online status of \
ZNC-*users.))
$(eval $(call module,nickserv,Auths you with NickServ.)) $(eval $(call module,nickserv,Auths you with NickServ.))
$(eval $(call module,notes,This modules stores and displays short notes using \ $(eval $(call module,notes,This modules stores and displays short notes using \

View File

@ -9,9 +9,9 @@ Subject: [PATCH] Move the root check to after config parsing
--- a/src/main.cpp --- a/src/main.cpp
+++ b/src/main.cpp +++ b/src/main.cpp
@@ -211,19 +211,6 @@ int main(int argc, char** argv) { @@ -243,19 +243,6 @@ int main(int argc, char** argv) {
CUtils::PrintStatus(true, "");
} }
#endif
- if (isRoot()) { - if (isRoot()) {
- CUtils::PrintError("You are running ZNC as root! Don't do that! There are not many valid"); - CUtils::PrintError("You are running ZNC as root! Don't do that! There are not many valid");
@ -29,7 +29,7 @@ Subject: [PATCH] Move the root check to after config parsing
if (bMakeConf) { if (bMakeConf) {
if (!pZNC->WriteNewConfig(sConfig)) { if (!pZNC->WriteNewConfig(sConfig)) {
delete pZNC; delete pZNC;
@@ -244,6 +231,20 @@ int main(int argc, char** argv) { @@ -276,6 +263,20 @@ int main(int argc, char** argv) {
return 1; return 1;
} }

View File

@ -9,21 +9,17 @@ Subject: [PATCH] Add a uClibc++ build workaround
--- a/modules/webadmin.cpp --- a/modules/webadmin.cpp
+++ b/modules/webadmin.cpp +++ b/modules/webadmin.cpp
@@ -15,9 +15,11 @@ @@ -20,6 +20,7 @@
#include <znc/Listener.h>
#include <znc/IRCNetwork.h> #include <znc/IRCNetwork.h>
#include <znc/IRCSock.h> #include <znc/IRCSock.h>
+#include <string>
#include <sstream>
#include <utility>
+using std::string; +using std::string;
using std::stringstream; using std::stringstream;
using std::make_pair; using std::make_pair;
using std::set; using std::set;
@@ -55,7 +57,7 @@ class CWebAdminMod : public CGlobalModul @@ -75,7 +76,7 @@ class CWebAdminMod : public CModule {
public: public:
GLOBALMODCONSTRUCTOR(CWebAdminMod) { MODCONSTRUCTOR(CWebAdminMod) {
VPair vParams; VPair vParams;
- vParams.push_back(make_pair("user", "")); - vParams.push_back(make_pair("user", ""));
+ vParams.push_back(make_pair((string)"user", (string)"")); + vParams.push_back(make_pair((string)"user", (string)""));

View File

@ -10,7 +10,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
--- a/Makefile.in --- a/Makefile.in
+++ b/Makefile.in +++ b/Makefile.in
@@ -96,7 +96,7 @@ clean: @@ -104,7 +104,7 @@ clean:
distclean: clean distclean: clean
rm -rf $(DISTCLEAN) rm -rf $(DISTCLEAN)
@ -21,7 +21,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
$(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MD -MF .depend/$*.dep -MT $@ $(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MD -MF .depend/$*.dep -MT $@
--- a/modules/Makefile.in --- a/modules/Makefile.in
+++ b/modules/Makefile.in +++ b/modules/Makefile.in
@@ -114,12 +114,12 @@ install_datadir: @@ -117,12 +117,12 @@ install_datadir:
clean: clean:
rm -rf $(CLEAN) rm -rf $(CLEAN)
@ -33,6 +33,6 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
-%.so: %.o Makefile -%.so: %.o Makefile
+%.so: %.o +%.so: %.o
$(E) Linking module $(notdir $(basename $@))... $(E) "Linking module" $(notdir $(basename $@))...
$(Q)$(CXX) $(MODFLAGS) $(LDFLAGS) $(MODLINK) -o $@ $< $($(notdir $(basename $@))LDFLAGS) $(LIBS) $(Q)$(CXX) $(MODFLAGS) $(LDFLAGS) $(MODLINK) -o $@ $< $($(notdir $(basename $@))LDFLAGS) $(LIBS)