[package] make arpd depend on librt, refresh patches (#5816)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17633 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
437cd50685
commit
211cee0578
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=arpd
|
||||
PKG_VERSION:=0.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_MD5SUM:=e2911fa9de1b92ef50deda1489ae944d
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/arpd
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpcap +libdnet +libevent
|
||||
DEPENDS:=+libpcap +libdnet +libevent +librt
|
||||
TITLE:=A daemon to fake ARP replies
|
||||
URL:=http://niels.xtdnet.nl/honeyd/
|
||||
endef
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- arpd/configure.orig Sun Feb 9 19:31:28 2003
|
||||
+++ arpd/configure Thu Jul 21 16:05:16 2005
|
||||
@@ -2258,8 +2258,7 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2258,8 +2258,7 @@ echo "${ECHO_T}$withval" >&6
|
||||
if cd $withval; then withval=`pwd`; cd $owd; fi
|
||||
PCAPINC="-I$withval -I$withval/bpf"
|
||||
PCAPLIB="-L$withval -lpcap"
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- arpd/arpd.c.orig Sun Feb 9 05:20:40 2003
|
||||
+++ arpd/arpd.c Thu Jul 21 17:05:40 2005
|
||||
@@ -265,7 +265,7 @@
|
||||
--- a/arpd.c
|
||||
+++ b/arpd.c
|
||||
@@ -265,7 +265,7 @@ arpd_send(eth_t *eth, int op,
|
||||
spa->addr_ip, tha->addr_eth, tpa->addr_ip);
|
||||
|
||||
if (op == ARP_OP_REQUEST) {
|
||||
@ -9,7 +9,7 @@
|
||||
addr_ntoa(tpa), addr_ntoa(spa));
|
||||
} else if (op == ARP_OP_REPLY) {
|
||||
syslog(LOG_INFO, "arp reply %s is-at %s",
|
||||
@@ -282,7 +282,7 @@
|
||||
@@ -282,7 +282,7 @@ arpd_lookup(struct addr *addr)
|
||||
int error;
|
||||
|
||||
if (addr_cmp(addr, &arpd_ifent.intf_addr) == 0) {
|
||||
@ -18,7 +18,7 @@
|
||||
addr_ntoa(addr), addr_ntoa(&arpd_ifent.intf_link_addr));
|
||||
return (0);
|
||||
}
|
||||
@@ -291,10 +291,10 @@
|
||||
@@ -291,10 +291,10 @@ arpd_lookup(struct addr *addr)
|
||||
error = arp_get(arpd_arp, &arpent);
|
||||
|
||||
if (error == -1) {
|
||||
@ -31,7 +31,7 @@
|
||||
addr_ntoa(addr), addr_ntoa(&arpent.arp_ha));
|
||||
}
|
||||
return (error);
|
||||
@@ -423,7 +423,7 @@
|
||||
@@ -423,7 +423,7 @@ arpd_recv_cb(u_char *u, const struct pca
|
||||
if ((req = SPLAY_FIND(tree, &arpd_reqs, &tmp)) != NULL) {
|
||||
addr_pack(&src.arp_ha, ADDR_TYPE_ETH, ETH_ADDR_BITS,
|
||||
ethip->ar_sha, ETH_ADDR_LEN);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- arpd/arpd.c Sun Feb 9 05:20:40 2003
|
||||
+++ arpd/arpd.c.new Mon Aug 1 00:50:40 2005
|
||||
@@ -70,7 +70,7 @@
|
||||
--- a/arpd.c
|
||||
+++ b/arpd.c
|
||||
@@ -70,7 +70,7 @@ static int arpd_sig;
|
||||
static void
|
||||
usage(void)
|
||||
{
|
||||
@ -9,7 +9,7 @@
|
||||
exit(1);
|
||||
}
|
||||
|
||||
@@ -182,7 +182,7 @@
|
||||
@@ -182,7 +182,7 @@ arpd_expandips(int naddresses, char **ad
|
||||
}
|
||||
|
||||
static void
|
||||
@ -18,7 +18,7 @@
|
||||
{
|
||||
struct bpf_program fcode;
|
||||
char filter[1024], ebuf[PCAP_ERRBUF_SIZE], *dst;
|
||||
@@ -214,9 +214,13 @@
|
||||
@@ -214,9 +214,13 @@ arpd_init(char *dev, int naddresses, cha
|
||||
errx(1, "bad interface configuration: not IP or Ethernet");
|
||||
arpd_ifent.intf_addr.addr_bits = IP_ADDR_BITS;
|
||||
|
||||
@ -34,7 +34,7 @@
|
||||
|
||||
if ((arpd_pcap = pcap_open_live(dev, 128, 0, 500, ebuf)) == NULL)
|
||||
errx(1, "pcap_open_live: %s", ebuf);
|
||||
@@ -465,14 +469,14 @@
|
||||
@@ -465,14 +469,14 @@ main(int argc, char *argv[])
|
||||
{
|
||||
struct event recv_ev;
|
||||
extern int (*event_sigcb)(void);
|
||||
@ -51,7 +51,7 @@
|
||||
switch (c) {
|
||||
case 'd':
|
||||
debug = 1;
|
||||
@@ -480,6 +484,9 @@
|
||||
@@ -480,6 +484,9 @@ main(int argc, char *argv[])
|
||||
case 'i':
|
||||
dev = optarg;
|
||||
break;
|
||||
@ -61,7 +61,7 @@
|
||||
default:
|
||||
usage();
|
||||
break;
|
||||
@@ -489,9 +496,9 @@
|
||||
@@ -489,9 +496,9 @@ main(int argc, char *argv[])
|
||||
argv += optind;
|
||||
|
||||
if (argc == 0)
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -urN arpd/configure arpd.new/configure
|
||||
--- arpd/configure 2003-02-09 19:31:28.000000000 +0100
|
||||
+++ arpd.new/configure 2008-10-12 14:23:35.000000000 +0200
|
||||
@@ -2170,8 +2170,7 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2170,8 +2170,7 @@ echo "${ECHO_T}$withval" >&6
|
||||
DNETLIB="`$withval/bin/dnet-config --libs`"
|
||||
else
|
||||
{ { echo "$as_me:2172: error: dnet-config not found in $withval/bin" >&5
|
||||
|
Loading…
x
Reference in New Issue
Block a user