From 22e00235c78e463623056b21dce28199836141f9 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sat, 24 Mar 2007 10:45:26 +0000
Subject: [PATCH] Add httptunnel (#1500)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@6661 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 net/httptunnel/Makefile | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
 create mode 100644 net/httptunnel/Makefile

diff --git a/net/httptunnel/Makefile b/net/httptunnel/Makefile
new file mode 100644
index 000000000..f4e0e6125
--- /dev/null
+++ b/net/httptunnel/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=httptunnel
+PKG_VERSION:=3.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.nocrew.org/pub/nocrew/unix/
+PKG_MD5SUM:=493cc0f5f21e9955db27ee9cd9a976d5
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/httptunnel
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenssl
+  TITLE:=bidirectional virtual data connection tunnelled in HTTP requests
+  DESCRIPTION:=\
+	httptunnel creates a bidirectional virtual data connection tunnelled in HTTP requests.\\\
+	The HTTP requests can be sent via an HTTP proxy if so desired.
+  URL:=http://www.nocrew.org/software/httptunnel.html
+endef
+
+define Package/httptunnel/install	
+	$(INSTALL_DIR) $(1)/usr/sbin
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/hts $(1)/usr/sbin/
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/htc $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,httptunnel))