added dillo2 - a lightweight webbrowser based on fltk2
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14815 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8866ac5984
commit
2352a59edf
68
Xorg/app/dillo/Makefile
Normal file
68
Xorg/app/dillo/Makefile
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006-2008 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id: Makefile 12228 2008-08-06 22:43:15Z nbd $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=dillo
|
||||||
|
PKG_REV:=cc974615ae39
|
||||||
|
PKG_VERSION:=r$(PKG_REV)
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE_PROTO:=hg
|
||||||
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://freehg.org/u/dillo/main
|
||||||
|
PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/dillo
|
||||||
|
SECTION:=xorg-app
|
||||||
|
CATEGORY:=Xorg
|
||||||
|
SUBMENU:=app
|
||||||
|
TITLE:=Dillo2
|
||||||
|
URL:=http://fltk.org/
|
||||||
|
DEPENDS:=+libstdcpp +libpthread +zlib +fltk2
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dillo/description
|
||||||
|
Dillo is a web browser project completely written in C.
|
||||||
|
Dillo aims to be a multi-platform browser alternative that
|
||||||
|
is small, stable, developer-friendly, usable, fast, and
|
||||||
|
extensible.
|
||||||
|
|
||||||
|
Note: This is the fltk2 based dillo.
|
||||||
|
endef
|
||||||
|
|
||||||
|
EXTRA_CPPFLAGS+=-I$(STAGING_DIR)/usr/lib/libiconv/include
|
||||||
|
EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib/libiconv/lib -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
(cd $(PKG_BUILD_DIR); ./autogen.sh );
|
||||||
|
$(call Build/Configure/Default)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Install
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" $(MAKE) -C $(PKG_BUILD_DIR) install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dillo/install
|
||||||
|
$(INSTALL_DIR) $(1)/etc $(1)/usr/share/applications $(1)/usr/share/icons
|
||||||
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/* $(1)/etc/
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dillo $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dpid $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dpidc $(1)/usr/bin
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dillo $(1)/usr/lib/
|
||||||
|
$(CP) ./files/dillo.png $(1)/usr/share/icons/
|
||||||
|
$(INSTALL_DATA) ./files/dillo.desktop $(1)/usr/share/applications/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,dillo))
|
12
Xorg/app/dillo/files/dillo.desktop
Normal file
12
Xorg/app/dillo/files/dillo.desktop
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
GenericName=Web Browser
|
||||||
|
GenericName[lt]=Web naršyklė
|
||||||
|
Name=Dillo
|
||||||
|
Comment=Lightweight browser
|
||||||
|
Comment[lt]=Labai paprasta naršyklė
|
||||||
|
MimeType=text/html;text/xml;application/xhtml+xml;
|
||||||
|
Exec=dillo
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Categories=Application;Network;
|
||||||
|
Icon=/usr/share/icons/dillo.png
|
BIN
Xorg/app/dillo/files/dillo.png
Normal file
BIN
Xorg/app/dillo/files/dillo.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 5.4 KiB |
21
Xorg/app/dillo/patches/000-do-not-need-flt2-util.patch
Normal file
21
Xorg/app/dillo/patches/000-do-not-need-flt2-util.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
--- dillo-rcc974615ae39.orig/configure.in 2009-03-09 15:40:08.000000000 +0100
|
||||||
|
+++ dillo-rcc974615ae39/configure.in 2009-03-09 15:52:42.000000000 +0100
|
||||||
|
@@ -145,14 +145,10 @@
|
||||||
|
dnl
|
||||||
|
dnl For debugging and to be user friendly
|
||||||
|
AC_MSG_CHECKING([FLTK2])
|
||||||
|
-if sh -c "fltk2-config --version" >/dev/null 2>&1
|
||||||
|
-then AC_MSG_RESULT(yes)
|
||||||
|
- LIBFLTK_CXXFLAGS=`fltk2-config --cxxflags`
|
||||||
|
- LIBFLTK_CFLAGS=`fltk2-config --cflags`
|
||||||
|
- LIBFLTK_LIBS=`fltk2-config --use-images --ldflags`
|
||||||
|
-else AC_MSG_RESULT(no)
|
||||||
|
- AC_ERROR(FLTK2 must be installed!)
|
||||||
|
-fi
|
||||||
|
+AC_MSG_RESULT(yes)
|
||||||
|
+ LIBFLTK_CXXFLAGS="-I. -I/usr/include/freetype2 -Wno-non-virtual-dtor"
|
||||||
|
+ LIBFLTK_CFLAGS="-I."
|
||||||
|
+ LIBFLTK_LIBS="-L./lib -Wl,-rpath,/usr/local/lib -lfltk2_images -lfltk2_images -lfltk2 -lX11 -lXi -lXft -lpthread -lm -lXext -lsupc++"
|
||||||
|
|
||||||
|
|
||||||
|
dnl ----------------
|
Loading…
x
Reference in New Issue
Block a user