[package] ahcpd: upstream release 0.52
INCOMPATIBLE CHANGE: client mode configuration cannot be done in /etc/config/network anymore (at least for this release). It will be added back in the near future. git-svn-id: svn://svn.openwrt.org/openwrt/packages@27932 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5ac8a65006
commit
263a36402f
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ahcpd
|
PKG_NAME:=ahcpd
|
||||||
PKG_VERSION:=0.51
|
PKG_VERSION:=0.52
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
|
PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
|
||||||
PKG_MD5SUM:=86b70d278dfb5a1e33cd1a1ceae9e715
|
PKG_MD5SUM:=a354b55e775c9f7d26561de360309358
|
||||||
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -71,21 +71,7 @@ ahcp_config() {
|
|||||||
setup_interface_ahcp() {
|
setup_interface_ahcp() {
|
||||||
local interface="$1"
|
local interface="$1"
|
||||||
local config="$2"
|
local config="$2"
|
||||||
local pid_file="/var/run/ahcpd-$interface.pid"
|
|
||||||
local id_file="/var/lib/ahcp-unique-id-$interface"
|
|
||||||
local log_file="/var/log/ahcpd-$interface.log"
|
|
||||||
unset args
|
|
||||||
|
|
||||||
mkdir -p /var/lib
|
echo "WARNING: ahcp client cannot be configured in /etc/config/network anymore."
|
||||||
|
echo "Please add $interface to /etc/config/ahcpd instead."
|
||||||
ahcp_config "$config"
|
|
||||||
eval "/usr/sbin/ahcpd -D -I $pid_file -i $id_file -L $log_file $args $interface"
|
|
||||||
}
|
|
||||||
|
|
||||||
stop_interface_ahcp() {
|
|
||||||
local cfg="$1"
|
|
||||||
local interface
|
|
||||||
config_get interface "$cfg" device
|
|
||||||
local pid_file="/var/run/ahcpd-$interface.pid"
|
|
||||||
[ -f "$pid_file" ] && kill $(cat "$pid_file")
|
|
||||||
}
|
}
|
||||||
|
@ -1,11 +1,8 @@
|
|||||||
package ahcpd
|
package ahcpd
|
||||||
|
|
||||||
# This configuration file is used to set up ahcpd in server or forwarder
|
|
||||||
# mode. To use ahcpd in client mode, use 'proto' 'ahcp' in
|
|
||||||
# /etc/config/network (see example below).
|
|
||||||
|
|
||||||
config ahcpd
|
config ahcpd
|
||||||
option 'mode' 'server' # or 'forwarder' but NOT 'client'
|
# Choose ahcp mode: client (default), server or forwarder
|
||||||
|
## option 'mode' 'client'
|
||||||
# Uncomment the following lines to enable ahcpd on the desired
|
# Uncomment the following lines to enable ahcpd on the desired
|
||||||
# interfaces.
|
# interfaces.
|
||||||
## list 'interface' 'lan'
|
## list 'interface' 'lan'
|
||||||
@ -33,18 +30,3 @@ config ahcpd
|
|||||||
# option 'lease_time' '3666'
|
# option 'lease_time' '3666'
|
||||||
# option 'debug' '1'
|
# option 'debug' '1'
|
||||||
|
|
||||||
# Sample client mode configuration
|
|
||||||
# THIS MUST BE COPIED IN /etc/config/network. Ahcpd will ignore it
|
|
||||||
# otherwise.
|
|
||||||
## config 'interface' 'wlan'
|
|
||||||
## option 'ifname' 'ath0'
|
|
||||||
## option 'proto' 'ahcp'
|
|
||||||
## # The following lines are optional
|
|
||||||
## option 'multicast_address' 'ff02::cca6:c0f9:e182:5359'
|
|
||||||
## option 'port' '5359'
|
|
||||||
## option 'ipv4_only' 'false'
|
|
||||||
## option 'ipv6_only' 'false'
|
|
||||||
## option 'no_dns' 'false'
|
|
||||||
## option 'lease_time' '3666'
|
|
||||||
## option 'debug' '1'
|
|
||||||
## option 'script' '/etc/ahcp/ahcp-config.sh'
|
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
Tue Jul 20 00:25:27 CEST 2010 Juliusz Chroboczek <jch@pps.jussieu.fr>
|
|
||||||
* Fix typo -- ignore autoconf prefixes for plen > 64.
|
|
||||||
Thanks to Gabriel Kerneis.
|
|
||||||
--- old-ahcpd/configure.c 2010-07-20 09:31:19.000000000 +0200
|
|
||||||
+++ new-ahcpd/configure.c 2010-07-20 09:31:19.000000000 +0200
|
|
||||||
@@ -505,7 +505,7 @@
|
|
||||||
if(config->ipv6_address) {
|
|
||||||
config->our_ipv6_address = copy_prefix_list(config->ipv6_address);
|
|
||||||
} else if(config->ipv6_prefix && config->ipv6_prefix->n > 0 &&
|
|
||||||
- config->ipv6_prefix->l[0].plen >= 64) {
|
|
||||||
+ config->ipv6_prefix->l[0].plen <= 64) {
|
|
||||||
unsigned char address[16];
|
|
||||||
int have_address = 0;
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user