[packages] lxc: update to 1.0.3

Signed-off-by: Luka Perkov <luka@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@40817 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
luka 2014-05-21 13:07:47 +00:00
parent a67e4519c0
commit 26991441ef
3 changed files with 23 additions and 12 deletions

View File

@ -8,14 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lxc
PKG_VERSION:=2014-01-25
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_VERSION:=1.0.3
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/lxc/lxc.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=0b3a6504e51795e738de8e017c22d209a93bc169
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/
PKG_MD5SUM:=55873b1411a606397309aa6c4c4263b3
PKG_BUILD_DEPENDS:=lua
PKG_BUILD_PARALLEL:=1
@ -28,7 +26,7 @@ LXC_APPLETS_BIN += \
freeze info monitor snapshot start stop unfreeze unshare usernsexec wait
LXC_APPLETS_LIB += \
init monitord user-nic
monitord user-nic
LXC_SCRIPTS += \
checkconfig ls top
@ -88,6 +86,12 @@ define Package/lxc-lua
DEPENDS:= lxc +liblua +liblxc +luafilesystem
endef
define Package/lxc-init
$(call Package/lxc/Default)
TITLE:=LXC Lua bindings
DEPENDS:= lxc +liblxc
endef
CONFIGURE_ARGS += \
--disable-apparmor \
--disable-doc \
@ -177,14 +181,21 @@ endef
define Package/lxc-lua/install
$(INSTALL_DIR) $(1)/usr/lib/lua
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/lua/lxc.lua \
$(PKG_INSTALL_DIR)/usr/share/lua/5.1/lxc.lua \
$(1)/usr/lib/lua/
$(INSTALL_DIR) $(1)/usr/lib/lua/lxc
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/lua/lxc/core.so \
$(PKG_INSTALL_DIR)/usr/lib/lua/5.1/lxc/core.so \
$(1)/usr/lib/lua/lxc/
endef
define Package/lxc-init/install
$(INSTALL_DIR) $(1)/sbin
$(CP) \
$(PKG_INSTALL_DIR)/usr/sbin/init.lxc \
$(1)/sbin/
endef
define GenPlugin
define Package/lxc-$(1)
$(call Package/lxc/Default)

View File

@ -8,7 +8,7 @@
-# for some distro-specific build options.
-AC_MSG_CHECKING([host distribution])
-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, oracle, centos, fedora, suse, gentoo, debian, arch, slackware, paldo, openmandriva or pardus.]))
-if test "z$with_distro" = "z"; then
-if type lsb_release >/dev/null 2>&1 && test "z$with_distro" = "z"; then
- with_distro=`lsb_release -is`
-fi
-if test "z$with_distro" = "z"; then

View File

@ -1,6 +1,6 @@
--- a/src/lxc/utils.h
+++ b/src/lxc/utils.h
@@ -44,11 +44,7 @@ extern const char *get_rundir(void);
@@ -44,11 +44,7 @@ extern char *get_rundir(void);
extern const char *lxc_global_config_value(const char *option_name);
/* Define getline() if missing from the C library */