[nginx]: fix compile errors and upgrade to 1.4.4
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39042 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a7119dd6bc
commit
273d9b9c86
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nginx
|
||||
PKG_VERSION:=1.2.8
|
||||
PKG_VERSION:=1.4.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://nginx.org/download/
|
||||
PKG_MD5SUM:=b9f7640cca35196d0e719ac5da24c7bd
|
||||
PKG_MD5SUM:=5dfaba1cbeae9087f3949860a02caa9f
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
33
net/nginx/patches/300-crosscompile_ccflags.patch
Normal file
33
net/nginx/patches/300-crosscompile_ccflags.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- a/auto/endianness
|
||||
+++ b/auto/endianness
|
||||
@@ -21,7 +21,7 @@ int main() {
|
||||
|
||||
END
|
||||
|
||||
-ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \
|
||||
+ngx_test="$CC $NGX_CC_OPT $CC_TEST_FLAGS $CC_AUX_FLAGS \
|
||||
-o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs"
|
||||
|
||||
eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1"
|
||||
--- a/auto/feature
|
||||
+++ b/auto/feature
|
||||
@@ -39,7 +39,7 @@ int main() {
|
||||
END
|
||||
|
||||
|
||||
-ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS $ngx_feature_inc_path \
|
||||
+ngx_test="$CC $NGX_CC_OPT $CC_TEST_FLAGS $CC_AUX_FLAGS $ngx_feature_inc_path \
|
||||
-o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_TEST_LD_OPT $ngx_feature_libs"
|
||||
|
||||
ngx_feature_inc_path=
|
||||
--- a/auto/include
|
||||
+++ b/auto/include
|
||||
@@ -27,7 +27,7 @@ int main() {
|
||||
END
|
||||
|
||||
|
||||
-ngx_test="$CC -o $NGX_AUTOTEST $NGX_AUTOTEST.c"
|
||||
+ngx_test="$CC $NGX_CC_OPT -o $NGX_AUTOTEST $NGX_AUTOTEST.c"
|
||||
|
||||
eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1"
|
||||
|
Loading…
x
Reference in New Issue
Block a user