[package] update amule to 2.2.5 (#3788)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17773 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
452bdace51
commit
275c6d0176
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2007-2008 OpenWrt.org
|
||||
# Copyright (C) 2007-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=aMule
|
||||
PKG_VERSION:=2.1.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.2.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/amule
|
||||
PKG_MD5SUM:=0aafdd159edb8ad5f0064da87998b47d
|
||||
PKG_MD5SUM:=
|
||||
|
||||
PKG_BUILD_DEPENDS:=libgd
|
||||
|
||||
@ -25,7 +25,7 @@ define Package/amule
|
||||
CATEGORY:=Network
|
||||
TITLE:=A multi-platform eMule-like ed2k client
|
||||
URL:=http://www.amule.org/
|
||||
DEPENDS:=+libpng +libpthread +libncurses +libreadline +libwxbase
|
||||
DEPENDS:=+libpng +libpthread +libncurses +libreadline +libwxbase +libcryptoxx
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
@ -54,12 +54,13 @@ CONFIGURE_ARGS+= \
|
||||
--enable-embedded-crypto \
|
||||
--enable-gsocket \
|
||||
--disable-gtktest \
|
||||
--disable-crypto \
|
||||
\
|
||||
--with-zlib="$(STAGING_DIR)/usr" \
|
||||
--with-gdlib-prefix="$(STAGING_DIR)/usr" \
|
||||
--with-libpng-prefix="$(STAGING_DIR)/usr" \
|
||||
--with-wx-prefix="$(STAGING_DIR)/usr" \
|
||||
--without-crypto-prefix \
|
||||
--with-crypto-prefix="$(STAGING_DIR)/usr" \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--without-x \
|
||||
|
@ -2,15 +2,6 @@ Index: aMule-2.1.3/src/libs/common/MuleDebug.cpp
|
||||
===================================================================
|
||||
--- aMule-2.1.3.orig/src/libs/common/MuleDebug.cpp 2007-09-23 21:47:41.000000000 +0200
|
||||
+++ aMule-2.1.3/src/libs/common/MuleDebug.cpp 2007-09-23 21:47:41.000000000 +0200
|
||||
@@ -32,7 +32,7 @@
|
||||
#include "MuleDebug.h" // Interface declaration
|
||||
#include "StringFunctions.h" // Needed for unicode2char
|
||||
|
||||
-#ifdef __LINUX__
|
||||
+#if defined(__LINUX__) && !defined(__UCLIBC__)
|
||||
#include <execinfo.h>
|
||||
#include <cxxabi.h>
|
||||
#include <wx/thread.h>
|
||||
@@ -151,7 +151,7 @@
|
||||
return walker.m_trace;
|
||||
}
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/ExternalConnector.h b/src/ExternalConnector.h
|
||||
index 3d214f6..30d12a7 100644
|
||||
--- a/src/ExternalConnector.h
|
||||
+++ b/src/ExternalConnector.h
|
||||
@@ -143,7 +143,7 @@ public:
|
||||
bool Parse_Command(const wxString& buffer);
|
||||
void GetCommand(const wxString &prompt, char* buffer, size_t buffer_size);
|
||||
const CECPacket *SendRecvMsg_v2(const CECPacket *request) { return m_ECClient->SendRecvPacket(request); }
|
||||
- void ConnectAndRun(const wxString &ProgName, const wxString& ProgName);
|
||||
+ void ConnectAndRun(const wxString &ProgName, const wxString& ProgVersion);
|
||||
void ShowGreet();
|
||||
|
||||
//
|
Loading…
x
Reference in New Issue
Block a user