move some webcam/sound related stuff from trunk to packages
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12260 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5308193568
commit
27a2008db4
39
multimedia/gspcav1/Makefile
Normal file
39
multimedia/gspcav1/Makefile
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
|
PKG_NAME:=gspcav1
|
||||||
|
PKG_VERSION:=20071224
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download
|
||||||
|
PKG_MD5SUM:=14853ba1f4edc1e685039fca56e5ebf
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define KernelPackage/video-gspca
|
||||||
|
SUBMENU:=Video Support
|
||||||
|
TITLE:=SPCA5xx based USB webcam support
|
||||||
|
URL:=http://mxhaard.free.fr/
|
||||||
|
DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/gspca.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,90,gspca)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(LINUX_DIR) \
|
||||||
|
ARCH="$(LINUX_KARCH)" \
|
||||||
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
|
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||||
|
modules
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,video-gspca))
|
43
multimedia/linux-uvc/Makefile
Normal file
43
multimedia/linux-uvc/Makefile
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2007 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
|
PKG_NAME:=linux-uvc
|
||||||
|
PKG_REV:=215
|
||||||
|
PKG_VERSION:=r$(PKG_REV)
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=http://svn.berlios.de/svnroot/repos/linux-uvc/linux-uvc/trunk/
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
|
PKG_SOURCE_PROTO:=svn
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define KernelPackage/video-uvc
|
||||||
|
SUBMENU:=Video Support
|
||||||
|
TITLE:=USB Video Class (UVC) support
|
||||||
|
URL:=http://linux-uvc.berlios.de/
|
||||||
|
DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/uvcvideo.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
echo "#define DRIVER_VERSION \"SVN $(PKG_VERSION)\"" > "$(PKG_BUILD_DIR)/version.h"
|
||||||
|
$(MAKE) -C $(LINUX_DIR) \
|
||||||
|
ARCH="$(LINUX_KARCH)" \
|
||||||
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
|
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||||
|
modules
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,video-uvc))
|
45
multimedia/nw802-2.4/Makefile
Normal file
45
multimedia/nw802-2.4/Makefile
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006-2008 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
|
PKG_NAME:=nw802-2.4
|
||||||
|
PKG_VERSION:=0.0.99
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=@SF/nw802
|
||||||
|
PKG_MD5SUM:=bf3512efaa48cfa972b16318011c1963
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define KernelPackage/video-nw8xx
|
||||||
|
SUBMENU:=Video Support
|
||||||
|
TITLE:=NW8xx based USB webcam support
|
||||||
|
URL:=http://nw802.sourceforge.net/
|
||||||
|
DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-video kmod-video-core
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/nw8xx.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,70,nw8xx)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/video-nw8xx/description
|
||||||
|
Kernel support for NW8xx based USB cameras.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
ln -sf $(LINUX_DIR)/drivers/media/video/usbvideo/usbvideo.h \
|
||||||
|
$(PKG_BUILD_DIR)/
|
||||||
|
$(MAKE) -C $(LINUX_DIR) \
|
||||||
|
ARCH="$(LINUX_KARCH)" \
|
||||||
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
|
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||||
|
modules
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,video-nw8xx))
|
2980
multimedia/nw802-2.4/patches/001-linux_2_6_cvs.patch
Normal file
2980
multimedia/nw802-2.4/patches/001-linux_2_6_cvs.patch
Normal file
File diff suppressed because it is too large
Load Diff
134
multimedia/nw802-2.4/patches/100-compile_fix.patch
Normal file
134
multimedia/nw802-2.4/patches/100-compile_fix.patch
Normal file
@ -0,0 +1,134 @@
|
|||||||
|
--- a/nw8xx_jpgl.c
|
||||||
|
+++ b/nw8xx_jpgl.c
|
||||||
|
@@ -111,18 +111,18 @@
|
||||||
|
// Clamping table
|
||||||
|
#define SAFE_CLAMP
|
||||||
|
#ifdef SAFE_CLAMP
|
||||||
|
-inline unsigned char clamp(int x) {
|
||||||
|
+inline unsigned char nw8xx_clamp(int x) {
|
||||||
|
if ( x > 255 )
|
||||||
|
return 255;
|
||||||
|
if ( x < 0 )
|
||||||
|
return 0;
|
||||||
|
return x;
|
||||||
|
}
|
||||||
|
-#define clamp_adjust(x) clamp(x+128)
|
||||||
|
+#define nw8xx_clamp_adjust(x) nw8xx_clamp(x+128)
|
||||||
|
#else
|
||||||
|
-#define clamp(x) clampTbl[(x)+512]
|
||||||
|
-#define clamp_adjust(x) clampTbl[(x)+640]
|
||||||
|
-static char clampTbl[1280];
|
||||||
|
+#define nw8xx_clamp(x) nw8xx_clampTbl[(x)+512]
|
||||||
|
+#define nw8xx_clamp_adjust(x) nw8xx_clampTbl[(x)+640]
|
||||||
|
+static char nw8xx_clampTbl[1280];
|
||||||
|
#endif
|
||||||
|
|
||||||
|
// Code to initialize those tables
|
||||||
|
@@ -195,19 +195,19 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
#ifndef SAFE_CLAMP
|
||||||
|
-static void clampTbl_init(void)
|
||||||
|
+static void nw8xx_clampTbl_init(void)
|
||||||
|
{
|
||||||
|
// Instead of doing if(...) to test for overrange, we use
|
||||||
|
- // a clamping table
|
||||||
|
+ // a nw8xx_clamping table
|
||||||
|
|
||||||
|
int i;
|
||||||
|
|
||||||
|
for (i=0 ; i < 512 ; i++)
|
||||||
|
- clampTbl[i] = 0;
|
||||||
|
+ nw8xx_clampTbl[i] = 0;
|
||||||
|
for (i=512 ; i < 768 ; i++ )
|
||||||
|
- clampTbl[i] = i - 512;
|
||||||
|
+ nw8xx_clampTbl[i] = i - 512;
|
||||||
|
for (i=768 ; i < 1280 ; i++ )
|
||||||
|
- clampTbl[i] = 255;
|
||||||
|
+ nw8xx_clampTbl[i] = 255;
|
||||||
|
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
@@ -521,16 +521,16 @@
|
||||||
|
for ( x=0 ; x<4 ; x++ )
|
||||||
|
{
|
||||||
|
// Y block
|
||||||
|
- Yline[ 0] = clamp_adjust(block_y[block_idx ]);
|
||||||
|
- Yline[ 4] = clamp_adjust(block_y[block_idx+16]);
|
||||||
|
- Yline[ 8] = clamp_adjust(block_y[block_idx+32]);
|
||||||
|
- Yline[12] = clamp_adjust(block_y[block_idx+48]);
|
||||||
|
+ Yline[ 0] = nw8xx_clamp_adjust(block_y[block_idx ]);
|
||||||
|
+ Yline[ 4] = nw8xx_clamp_adjust(block_y[block_idx+16]);
|
||||||
|
+ Yline[ 8] = nw8xx_clamp_adjust(block_y[block_idx+32]);
|
||||||
|
+ Yline[12] = nw8xx_clamp_adjust(block_y[block_idx+48]);
|
||||||
|
|
||||||
|
// U block
|
||||||
|
- *Uline = clamp_adjust(block_u[block_idx]);
|
||||||
|
+ *Uline = nw8xx_clamp_adjust(block_u[block_idx]);
|
||||||
|
|
||||||
|
// V block
|
||||||
|
- *Vline = clamp_adjust(block_v[block_idx]);
|
||||||
|
+ *Vline = nw8xx_clamp_adjust(block_v[block_idx]);
|
||||||
|
|
||||||
|
// Ajust pointers & index
|
||||||
|
block_idx++;
|
||||||
|
@@ -596,9 +596,9 @@
|
||||||
|
vc = Vline[0];
|
||||||
|
|
||||||
|
// B G R
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
#ifdef _JPGL_TEST_
|
||||||
|
fb++;
|
||||||
|
#endif
|
||||||
|
@@ -609,9 +609,9 @@
|
||||||
|
vc = ( 3*Vline[0] + Vline[1] ) >> 2;
|
||||||
|
|
||||||
|
// B G R
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
#ifdef _JPGL_TEST_
|
||||||
|
fb++;
|
||||||
|
#endif
|
||||||
|
@@ -622,9 +622,9 @@
|
||||||
|
vc = ( Vline[0] + Vline[1] ) >> 1;
|
||||||
|
|
||||||
|
// B G R
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
#ifdef _JPGL_TEST_
|
||||||
|
fb++;
|
||||||
|
#endif
|
||||||
|
@@ -635,9 +635,9 @@
|
||||||
|
vc = ( Vline[0] + 3*Vline[1] ) >> 2;
|
||||||
|
|
||||||
|
// B G R
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
- *(fb++) = clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_v2[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc - yuvTbl_u2[uc] - yuvTbl_v1[vc] ) >> 16);
|
||||||
|
+ *(fb++) = nw8xx_clamp(( yc + yuvTbl_u1[uc] ) >> 16);
|
||||||
|
#ifdef _JPGL_TEST_
|
||||||
|
fb++;
|
||||||
|
#endif
|
||||||
|
@@ -707,6 +707,6 @@
|
||||||
|
vlcTbl_init();
|
||||||
|
yuvTbl_init();
|
||||||
|
#ifndef SAFE_CLAMP
|
||||||
|
- clampTbl_init();
|
||||||
|
+ nw8xx_clampTbl_init();
|
||||||
|
#endif
|
||||||
|
}
|
76
multimedia/ov51x-jpeg/Makefile
Normal file
76
multimedia/ov51x-jpeg/Makefile
Normal file
@ -0,0 +1,76 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2007-2008 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
|
PKG_NAME:=ov51x-jpeg
|
||||||
|
PKG_VERSION:=1.5.7
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://www.rastageeks.org/downloads/ov51x-jpeg/ \
|
||||||
|
http://www.rastageeks.org/downloads/ov51x-jpeg/old-releases/
|
||||||
|
PKG_MD5SUM:=7de1f426a48bdb55218913e2d713f813
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/ov51x-jpeg/Default
|
||||||
|
URL:=http://www.rastageeks.org/ov51x-jpeg/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ov51x-jpeg-utils
|
||||||
|
$(call Package/ov51x-jpeg/Default)
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=OV51x based USB webcam utilities
|
||||||
|
DEPENDS:=+kmod-video-ov51x-jpeg
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ov51x-jpeg-utils/description
|
||||||
|
Utility programs for the video-ov51x kernel module
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/video-ov51x-jpeg
|
||||||
|
$(call Package/ov51x-jpeg/Default)
|
||||||
|
SUBMENU:=Video Support
|
||||||
|
TITLE:=OV51x based USB webcam support (JPEG)
|
||||||
|
DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/ov51x-jpeg.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,70,ov51x-jpeg)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/video-ov51x-jpeg/description
|
||||||
|
Kernel module for OV51x based USB cameras, with in-driver JPEG support.
|
||||||
|
endef
|
||||||
|
|
||||||
|
ifneq ($(CONFIG_PACKAGE_kmod-video-ov51x-jpeg),)
|
||||||
|
define Build/Compile/kmod
|
||||||
|
$(MAKE) -C $(LINUX_DIR) \
|
||||||
|
ARCH="$(LINUX_KARCH)" \
|
||||||
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
|
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||||
|
modules
|
||||||
|
endef
|
||||||
|
endif
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(call Build/Compile/kmod)
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR)/test \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
CC="$(TARGET_CC)" \
|
||||||
|
getjpeg
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ov51x-jpeg-utils/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/test/getjpeg $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,ov51x-jpeg-utils))
|
||||||
|
$(eval $(call KernelPackage,video-ov51x-jpeg))
|
20
multimedia/ov51x-jpeg/patches/100-compile_fix.patch
Normal file
20
multimedia/ov51x-jpeg/patches/100-compile_fix.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- a/ov51x-jpeg-core.c
|
||||||
|
+++ b/ov51x-jpeg-core.c
|
||||||
|
@@ -753,7 +753,7 @@
|
||||||
|
* -claudio
|
||||||
|
*/
|
||||||
|
|
||||||
|
- ov51x_jpeg_proc_entry = create_proc_entry("ov51x-jpeg", S_IFDIR, &proc_root);
|
||||||
|
+ ov51x_jpeg_proc_entry = create_proc_entry("ov51x-jpeg", S_IFDIR, NULL);
|
||||||
|
if (ov51x_jpeg_proc_entry)
|
||||||
|
ov51x_jpeg_proc_entry->owner = THIS_MODULE;
|
||||||
|
else
|
||||||
|
@@ -771,7 +771,7 @@
|
||||||
|
|
||||||
|
/* Destroy proc entry */
|
||||||
|
PDEBUG(4, "destroying /proc/ov51x-jpeg");
|
||||||
|
- remove_proc_entry("ov51x-jpeg", &proc_root);
|
||||||
|
+ remove_proc_entry("ov51x-jpeg", NULL);
|
||||||
|
ov51x_jpeg_proc_entry = NULL;
|
||||||
|
|
||||||
|
}
|
41
multimedia/spca5xx-le/Makefile
Normal file
41
multimedia/spca5xx-le/Makefile
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id: Makefile 7137 2007-05-08 18:40:02Z nbd $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
|
PKG_NAME:=spca5xx-le
|
||||||
|
PKG_VERSION:=1
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt/
|
||||||
|
PKG_MD5SUM:=
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define KernelPackage/video-spca5xx-le
|
||||||
|
SUBMENU:=Video Support
|
||||||
|
TITLE:=SPCA5xx based USB webcam support (Light Edition)
|
||||||
|
URL:=http://mxhaard.free.fr/
|
||||||
|
DEPENDS:=@LINUX_2_6_23||LINUX_2_6_24||LINUX_2_6_25 @USB_SUPPORT +kmod-usb-core kmod-video-core
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,90,spca5xx)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(LINUX_DIR) \
|
||||||
|
ARCH="$(LINUX_KARCH)" \
|
||||||
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
|
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||||
|
modules
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,video-spca5xx-le))
|
21
multimedia/spca5xx-le/patches/100-compile_pud_shift.patch
Normal file
21
multimedia/spca5xx-le/patches/100-compile_pud_shift.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -Naur spca5xx-le/spca_core.c spca5xx-le-new/spca_core.c
|
||||||
|
--- spca5xx-le/spca_core.c 2007-06-03 21:30:29.000000000 +0100
|
||||||
|
+++ spca5xx-le-new/spca_core.c 2008-01-06 12:48:08.000000000 +0000
|
||||||
|
@@ -535,7 +535,7 @@
|
||||||
|
|
||||||
|
if (!pgd_none (*pgd))
|
||||||
|
{
|
||||||
|
-#if PUD_SHIFT
|
||||||
|
+#ifdef PUD_SHIFT
|
||||||
|
pud_t *pud = pud_offset (pgd, adr);
|
||||||
|
if (!pud_none (*pud))
|
||||||
|
{
|
||||||
|
@@ -552,7 +552,7 @@
|
||||||
|
ret = (unsigned long) page_address (pte_page (pte));
|
||||||
|
ret |= (adr & (PAGE_SIZE - 1));
|
||||||
|
}
|
||||||
|
-#if PUD_SHIFT
|
||||||
|
+#ifdef PUD_SHIFT
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
}
|
13
multimedia/spca5xx-le/patches/101-linux_2_6.patch
Normal file
13
multimedia/spca5xx-le/patches/101-linux_2_6.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -ruN spca5xx-le-orig/spca_core.c spca5xx-le/spca_core.c
|
||||||
|
--- spca5xx-le-orig/spca_core.c 2008-04-12 18:09:57.000000000 +0200
|
||||||
|
+++ spca5xx-le/spca_core.c 2008-04-12 18:16:45.000000000 +0200
|
||||||
|
@@ -2799,7 +2799,9 @@
|
||||||
|
.owner = THIS_MODULE,
|
||||||
|
.name = "SPCA5XX USB Camera",
|
||||||
|
.type = VID_TYPE_CAPTURE,
|
||||||
|
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
|
||||||
|
.hardware = VID_HARDWARE_SPCA5XX,
|
||||||
|
+#endif
|
||||||
|
.fops = &spca5xx_fops,
|
||||||
|
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0)
|
||||||
|
.release = video_device_release,
|
51
multimedia/spca5xx-view/Makefile
Normal file
51
multimedia/spca5xx-view/Makefile
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id: Makefile 7006 2007-04-19 12:06:39Z kaloz $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=spca5xx-view
|
||||||
|
PKG_VERSION:=1
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=spca5xx-view.tar.bz2
|
||||||
|
PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt
|
||||||
|
PKG_MD5SUM:=
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/spca5xx-view
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=spca5xx streaming applicaton
|
||||||
|
DEPENDS:=+kmod-video-spca5xx-le +libpthread
|
||||||
|
URL:=http://www.acmesystems.it/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/spca5xx-view/description
|
||||||
|
This package contains a streaming daemon for spca5xx based webcams
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR)/servfox/ CFLAGS="$(TARTGET_CFLAGS)" CC="$(TARGET_CC)" all
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR)/servfox/ PREFIX="$(PKG_INSTALL_DIR)" install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/spca5xx-view/install
|
||||||
|
$(INSTALL_DIR) $(1)/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/* $(1)
|
||||||
|
$(INSTALL_DIR) $(1)/www/
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/html-files/* $(1)/www/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/config
|
||||||
|
$(INSTALL_DATA) ./files/servfox.config $(1)/etc/config/servfox
|
||||||
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
$(INSTALL_BIN) ./files/servfox.init $(1)/etc/init.d/servfox
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,spca5xx-view))
|
4
multimedia/spca5xx-view/files/servfox.config
Normal file
4
multimedia/spca5xx-view/files/servfox.config
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
config servfox
|
||||||
|
option Device '/dev/video0'
|
||||||
|
option Port '7070'
|
||||||
|
option Resolution '640x480'
|
31
multimedia/spca5xx-view/files/servfox.init
Normal file
31
multimedia/spca5xx-view/files/servfox.init
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
#!/bin/sh /etc/rc.common
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
START=90
|
||||||
|
|
||||||
|
config_cb() {
|
||||||
|
local cfg="$CONFIG_SECTION"
|
||||||
|
local res
|
||||||
|
local dev
|
||||||
|
local port
|
||||||
|
local cfgt
|
||||||
|
config_get cfgt "$cfg" TYPE
|
||||||
|
|
||||||
|
case "$cfgt" in
|
||||||
|
servfox)
|
||||||
|
config_get res $cfg Resolution
|
||||||
|
config_get dev $cfg Device
|
||||||
|
config_get port $cfg Port
|
||||||
|
|
||||||
|
SERVFOX_ARGS="${dev:+-d $dev} ${res:+-s $res} ${port:+-w $port}"
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
}
|
||||||
|
|
||||||
|
start() {
|
||||||
|
config_load servfox
|
||||||
|
/bin/servfox $SERVFOX_ARGS &
|
||||||
|
}
|
||||||
|
|
||||||
|
stop() {
|
||||||
|
killall servfox
|
||||||
|
}
|
68
sound/alsa/Makefile
Normal file
68
sound/alsa/Makefile
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
|
PKG_NAME:=alsa-driver
|
||||||
|
PKG_VERSION:=1.0.14rc1
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
|
||||||
|
PKG_MD5SUM:=4cff99be4b225e96663fbd61cabe3182
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define KernelPackage/alsa
|
||||||
|
SUBMENU:=Other modules
|
||||||
|
DEPENDS:=@USB_SUPPORT @LINUX_2_4
|
||||||
|
TITLE:=Advanced Linux Sound Architecture
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD=$(call AutoLoad,70,$(shell cat ./files/alsa.modules))
|
||||||
|
endef
|
||||||
|
|
||||||
|
ifeq ($(KERNEL),2.4)
|
||||||
|
ifeq ($(LINUX_KARCH),i386)
|
||||||
|
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
|
||||||
|
endif
|
||||||
|
ifeq ($(LINUX_KARCH),mips)
|
||||||
|
KERNEL_C_OPTS:= -Os -G 0 -mlong-calls -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
ifeq ($(LINUX_KARCH),i386)
|
||||||
|
KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
|
||||||
|
endif
|
||||||
|
ifeq ($(LINUX_KARCH),mips)
|
||||||
|
KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
|
||||||
|
endif
|
||||||
|
|
||||||
|
CONFIGURE_VARS:= \
|
||||||
|
CFLAGS="$(KERNEL_C_INCS)"
|
||||||
|
|
||||||
|
CONFIGURE_ARGS:= \
|
||||||
|
--with-build="$(LINUX_DIR)" \
|
||||||
|
--with-kernel="$(LINUX_DIR)" \
|
||||||
|
--with-cross="$(KERNEL_CROSS)" \
|
||||||
|
--with-redhat=no \
|
||||||
|
--with-suse=no \
|
||||||
|
--with-oss=yes \
|
||||||
|
--with-isapnp=no \
|
||||||
|
--with-sequencer=no \
|
||||||
|
--with-cards=usb-audio
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
ARCH="$(LINUX_KARCH)" \
|
||||||
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
|
c_opts="$(KERNEL_C_OPTS)" \
|
||||||
|
CP="$(CP)" \
|
||||||
|
all
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,alsa))
|
10
sound/alsa/files/alsa.modules
Normal file
10
sound/alsa/files/alsa.modules
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
snd-page-alloc
|
||||||
|
snd
|
||||||
|
snd-timer
|
||||||
|
snd-pcm
|
||||||
|
snd-rawmidi
|
||||||
|
snd-usb-lib
|
||||||
|
snd-hwdep
|
||||||
|
snd-usb-audio
|
||||||
|
snd-mixer-oss
|
||||||
|
snd-pcm-oss
|
19
sound/alsa/patches/100-compile_fix.patch
Normal file
19
sound/alsa/patches/100-compile_fix.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
Index: alsa-driver-1.0.14rc1/include/adriver.h
|
||||||
|
===================================================================
|
||||||
|
--- alsa-driver-1.0.14rc1.orig/include/adriver.h 2007-06-04 13:22:44.887031416 +0200
|
||||||
|
+++ alsa-driver-1.0.14rc1/include/adriver.h 2007-06-04 13:22:44.956020928 +0200
|
||||||
|
@@ -514,7 +514,7 @@
|
||||||
|
#endif /* < 2.6.0 */
|
||||||
|
|
||||||
|
/* workarounds for USB API */
|
||||||
|
-#if defined(SND_NEED_USB_WRAPPER) && (defined(CONFIG_USB) || defined(CONFIG_USB_MODULE))
|
||||||
|
+#if 1
|
||||||
|
|
||||||
|
#include <linux/usb.h>
|
||||||
|
|
||||||
|
@@ -1360,4 +1360,5 @@
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#undef info /* used in several structs */
|
||||||
|
#endif /* __SOUND_LOCAL_DRIVER_H */
|
13
sound/alsa/patches/110-cp_command.patch
Normal file
13
sound/alsa/patches/110-cp_command.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: alsa-driver-1.0.14rc1/Makefile
|
||||||
|
===================================================================
|
||||||
|
--- alsa-driver-1.0.14rc1.orig/Makefile 2007-06-04 13:22:44.865034760 +0200
|
||||||
|
+++ alsa-driver-1.0.14rc1/Makefile 2007-06-04 13:22:45.149991440 +0200
|
||||||
|
@@ -115,7 +115,7 @@
|
||||||
|
if [ ! -d include/sound -a ! -L include/sound ]; then \
|
||||||
|
ln -sf ../alsa-kernel/include include/sound ; \
|
||||||
|
fi
|
||||||
|
- cp -puvf include/version.h include/sound/version.h
|
||||||
|
+ $(CP) include/version.h include/sound/version.h
|
||||||
|
|
||||||
|
utils/mod-deps: utils/mod-deps.c
|
||||||
|
gcc utils/mod-deps.c -o utils/mod-deps
|
13
sound/alsa/patches/120-sndfops.patch
Normal file
13
sound/alsa/patches/120-sndfops.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: alsa-driver-1.0.14rc1/alsa-kernel/core/sound.c
|
||||||
|
===================================================================
|
||||||
|
--- alsa-driver-1.0.14rc1.orig/alsa-kernel/core/sound.c 2007-07-11 12:15:11.408530571 +0200
|
||||||
|
+++ alsa-driver-1.0.14rc1/alsa-kernel/core/sound.c 2007-07-11 12:15:26.421386105 +0200
|
||||||
|
@@ -171,7 +171,7 @@
|
||||||
|
return err;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static struct file_operations snd_fops =
|
||||||
|
+struct file_operations snd_fops =
|
||||||
|
{
|
||||||
|
.owner = THIS_MODULE,
|
||||||
|
.open = snd_open
|
Loading…
x
Reference in New Issue
Block a user