Port miax to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4464 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ed570c4cf4
commit
27c0fa67aa
49
net/miax/Makefile
Normal file
49
net/miax/Makefile
Normal file
@ -0,0 +1,49 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=miax
|
||||
PKG_VERSION:=1.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=44f0d2ef46ee2697d890b7b96846adc7
|
||||
|
||||
PKG_SOURCE_URL:=http://mesh.dl.sourceforge.net/sourceforge/miax/
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/miax
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpthread +bluez-libs
|
||||
TITLE:=A console iax (asterisk) client
|
||||
DESCRIPTION:=miax is a console iax (asterisk) client, it can work with\\\
|
||||
a soundcard as a normal voip phone, taking input/output from\\\
|
||||
keyboard, analog/gsm/isdn modem or bluetooth phones.\\\
|
||||
URL:=http://www.eja.it/?l=gpl&testo=miax
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
||||
CC="$(TARGET_CC)" \
|
||||
OFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
all
|
||||
endef
|
||||
|
||||
define Package/miax/install
|
||||
install -d -m0755 $(1)/usr/bin
|
||||
install -m0755 $(PKG_BUILD_DIR)/miax $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,miax))
|
24
net/miax/patches/01-cross.patch
Normal file
24
net/miax/patches/01-cross.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ruN miax-1.4-old/Makefile miax-1.4-new/Makefile
|
||||
--- miax-1.4-old/Makefile 2005-04-27 18:56:13.000000000 +0200
|
||||
+++ miax-1.4-new/Makefile 2005-11-30 01:07:21.000000000 +0100
|
||||
@@ -1,4 +1,5 @@
|
||||
-CFLAGS= -Iiax/ -Igsm/inc -DIAXC_IAX2 -DLIBIAX -g -DPOSIXSLEEP -DLINUX -O2
|
||||
+OFLAGS= -02 -g
|
||||
+CFLAGS= -Iiax/ -Igsm/inc $(CPPFLAGS) -DIAXC_IAX2 -DLIBIAX -DPOSIXSLEEP -DLINUX $(OFLAGS)
|
||||
SYSLIBS=-lpthread -lm -lbluetooth
|
||||
|
||||
|
||||
@@ -32,11 +33,10 @@
|
||||
miax.o
|
||||
|
||||
all: $(OBJS)
|
||||
- gcc $(OBJS) $(CFLAGS) $(SYSLIBS) -o miax
|
||||
- cp miax /bin/miax
|
||||
+ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -o miax
|
||||
|
||||
static: $(OBJS) bluetooth.o
|
||||
- gcc $(OBJS) $(CFLAGS) $(SYSLIBS) -static -o miax
|
||||
+ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -static -o miax
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) miax
|
Loading…
x
Reference in New Issue
Block a user