[packages] ethtool: update to 3.4
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32149 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
10cc2c2966
commit
289e3bc591
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2011 OpenWrt.org
|
# Copyright (C) 2006-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ethtool
|
PKG_NAME:=ethtool
|
||||||
PKG_VERSION:=2.6.38
|
PKG_VERSION:=3.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/software/network/ethtool
|
PKG_SOURCE_URL:=@KERNEL/software/network/ethtool
|
||||||
PKG_MD5SUM:=4cc35c59e4fd0defff768f9f59fa41ad
|
PKG_MD5SUM:=cc4c4cf3ac086a53cd24f17d426f2b8f
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
@ -25,17 +25,16 @@ define Package/ethtool
|
|||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
TITLE:=Display or change ethernet card settings
|
TITLE:=Display or change ethernet card settings
|
||||||
URL:=http://www.kernel.org/pub/software/network/ethtool/
|
URL:=http://www.kernel.org/pub/software/network/ethtool/
|
||||||
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/ethtool/description
|
define Package/ethtool/description
|
||||||
ethtool is a small utility for examining and tuning your ethernet-based
|
ethtool is a small utility for examining and tuning your ethernet-based
|
||||||
network interface.
|
network interface
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/ethtool/install
|
define Package/ethtool/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ethtool $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ethtool $(1)/usr/sbin
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,ethtool))
|
$(eval $(call BuildPackage,ethtool))
|
||||||
|
@ -1,38 +1,83 @@
|
|||||||
--- ethtool-2.6.38/ethtool.c 2011-02-21 20:06:00.000000000 +0100
|
--- a/Makefile.am
|
||||||
+++ ethtool-2.6.38/ethtool.c 2011-03-31 23:30:20.433874703 +0200
|
+++ b/Makefile.am
|
||||||
@@ -1680,6 +1680,7 @@
|
@@ -9,7 +9,7 @@ ethtool_SOURCES = ethtool.c ethtool-copy
|
||||||
|
fec_8xx.c ibm_emac.c ixgb.c ixgbe.c natsemi.c \
|
||||||
|
pcnet32.c realtek.c tg3.c marvell.c vioc.c \
|
||||||
|
smsc911x.c at76c50x-usb.c sfc.c stmmac.c \
|
||||||
|
- rxclass.c sfpid.c
|
||||||
|
+ rxclass.c sfpid.c ixp4xx.c
|
||||||
|
|
||||||
|
TESTS = test-cmdline test-features
|
||||||
|
check_PROGRAMS = test-cmdline test-features
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -60,7 +60,7 @@ am_ethtool_OBJECTS = ethtool.$(OBJEXT) a
|
||||||
|
realtek.$(OBJEXT) tg3.$(OBJEXT) marvell.$(OBJEXT) \
|
||||||
|
vioc.$(OBJEXT) smsc911x.$(OBJEXT) at76c50x-usb.$(OBJEXT) \
|
||||||
|
sfc.$(OBJEXT) stmmac.$(OBJEXT) rxclass.$(OBJEXT) \
|
||||||
|
- sfpid.$(OBJEXT)
|
||||||
|
+ sfpid.$(OBJEXT) ixp4xx.$(OBJEXT)
|
||||||
|
ethtool_OBJECTS = $(am_ethtool_OBJECTS)
|
||||||
|
ethtool_LDADD = $(LDADD)
|
||||||
|
am__objects_1 = test_cmdline-ethtool.$(OBJEXT) \
|
||||||
|
@@ -247,7 +247,7 @@ ethtool_SOURCES = ethtool.c ethtool-copy
|
||||||
|
fec_8xx.c ibm_emac.c ixgb.c ixgbe.c natsemi.c \
|
||||||
|
pcnet32.c realtek.c tg3.c marvell.c vioc.c \
|
||||||
|
smsc911x.c at76c50x-usb.c sfc.c stmmac.c \
|
||||||
|
- rxclass.c sfpid.c
|
||||||
|
+ rxclass.c sfpid.c ixp4xx.c
|
||||||
|
|
||||||
|
test_cmdline_SOURCES = test-cmdline.c test-common.c $(ethtool_SOURCES)
|
||||||
|
test_cmdline_CFLAGS = -DTEST_ETHTOOL
|
||||||
|
@@ -389,6 +389,7 @@ distclean-compile:
|
||||||
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/sfpid.Po@am__quote@
|
||||||
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/smsc911x.Po@am__quote@
|
||||||
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/stmmac.Po@am__quote@
|
||||||
|
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ixp4xx.Po@am__quote@
|
||||||
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_cmdline-amd8111e.Po@am__quote@
|
||||||
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_cmdline-at76c50x-usb.Po@am__quote@
|
||||||
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_cmdline-de2104x.Po@am__quote@
|
||||||
|
--- a/ethtool.c
|
||||||
|
+++ b/ethtool.c
|
||||||
|
@@ -826,7 +826,7 @@ static const struct {
|
||||||
|
{ "e1000e", e1000_dump_regs },
|
||||||
{ "igb", igb_dump_regs },
|
{ "igb", igb_dump_regs },
|
||||||
{ "ixgb", ixgb_dump_regs },
|
{ "ixgb", ixgb_dump_regs },
|
||||||
{ "ixgbe", ixgbe_dump_regs },
|
- { "ixgbe", ixgbe_dump_regs },
|
||||||
+ { "ixp4xx_mac", ixp4xx_dump_regs },
|
+ { "ixp4xx", ixp4xx_dump_regs },
|
||||||
{ "natsemi", natsemi_dump_regs },
|
{ "natsemi", natsemi_dump_regs },
|
||||||
{ "e100", e100_dump_regs },
|
{ "e100", e100_dump_regs },
|
||||||
{ "amd8111e", amd8111e_dump_regs },
|
{ "amd8111e", amd8111e_dump_regs },
|
||||||
--- ethtool-2.6.38/ethtool-util.h 2011-02-21 19:23:37.000000000 +0100
|
@@ -842,6 +842,7 @@ static const struct {
|
||||||
+++ ethtool-2.6.38/ethtool-util.h 2011-03-31 23:34:06.130541369 +0200
|
{ "sfc", sfc_dump_regs },
|
||||||
@@ -100,7 +100,10 @@
|
{ "st_mac100", st_mac100_dump_regs },
|
||||||
int sfc_dump_regs(struct ethtool_drvinfo *info, struct ethtool_regs *regs);
|
{ "st_gmac", st_gmac_dump_regs },
|
||||||
|
+ { "ixgbe", ixgbe_dump_regs },
|
||||||
|
};
|
||||||
|
|
||||||
/* STMMAC embedded ethernet controller */
|
void dump_hex(FILE *file, const u8 *data, int len, int offset)
|
||||||
-int st_mac100_dump_regs(struct ethtool_drvinfo *info,
|
--- a/internal.h
|
||||||
- struct ethtool_regs *regs);
|
+++ b/internal.h
|
||||||
+int st_mac100_dump_regs(struct ethtool_drvinfo *info, struct ethtool_regs *regs);
|
@@ -238,6 +238,9 @@ int st_mac100_dump_regs(struct ethtool_d
|
||||||
|
struct ethtool_regs *regs);
|
||||||
int st_gmac_dump_regs(struct ethtool_drvinfo *info, struct ethtool_regs *regs);
|
int st_gmac_dump_regs(struct ethtool_drvinfo *info, struct ethtool_regs *regs);
|
||||||
+
|
|
||||||
+/* Intel IXP4xx internal MAC */
|
+/* Intel IXP4xx internal MAC */
|
||||||
+int ixp4xx_dump_regs(struct ethtool_drvinfo *info, struct ethtool_regs *regs);
|
+int ixp4xx_dump_regs(struct ethtool_drvinfo *info, struct ethtool_regs *regs);
|
||||||
+
|
+
|
||||||
#endif
|
/* Rx flow classification */
|
||||||
--- ethtool-2.6.38/ixp4xx.c 1970-01-01 01:00:00.000000000 +0100
|
int rxclass_parse_ruleopts(struct cmd_context *ctx,
|
||||||
+++ ethtool-2.6.38/ixp4xx.c 2011-03-31 23:30:37.267208035 +0200
|
struct ethtool_rx_flow_spec *fsp);
|
||||||
@@ -0,0 +1,131 @@
|
--- /dev/null
|
||||||
|
+++ b/ixp4xx.c
|
||||||
|
@@ -0,0 +1,130 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Copyright (c) 2006 Christian Hohnstaed <chohnstaedt@innominate.com>
|
+ * Copyright (c) 2006 Christian Hohnstaed <chohnstaedt@innominate.com>
|
||||||
+ * This file is released under the GPLv2
|
+ * This file is released under the GPLv2
|
||||||
+ */
|
+ */
|
||||||
+
|
+
|
||||||
+#include <stdio.h>
|
+#include <stdio.h>
|
||||||
+#include "ethtool-util.h"
|
+#include "internal.h"
|
||||||
+
|
+
|
||||||
+#ifndef BIT
|
+#ifndef BIT
|
||||||
+#define BIT(x) (1<<x)
|
+#define BIT(x) (1<<x)
|
||||||
@ -156,43 +201,3 @@
|
|||||||
+
|
+
|
||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
+
|
|
||||||
--- ethtool-2.6.38/Makefile.am 2011-01-14 21:23:57.000000000 +0100
|
|
||||||
+++ ethtool-2.6.38/Makefile.am 2011-03-31 23:37:15.913874702 +0200
|
|
||||||
@@ -8,7 +8,7 @@
|
|
||||||
amd8111e.c de2104x.c e100.c e1000.c igb.c \
|
|
||||||
fec_8xx.c ibm_emac.c ixgb.c ixgbe.c natsemi.c \
|
|
||||||
pcnet32.c realtek.c tg3.c marvell.c vioc.c \
|
|
||||||
- smsc911x.c at76c50x-usb.c sfc.c stmmac.c
|
|
||||||
+ smsc911x.c at76c50x-usb.c sfc.c stmmac.c ixp4xx.c
|
|
||||||
|
|
||||||
dist-hook:
|
|
||||||
cp $(top_srcdir)/ethtool.spec $(distdir)
|
|
||||||
--- ethtool-2.6.38/Makefile.in 2011-03-15 18:18:58.000000000 +0100
|
|
||||||
+++ ethtool-2.6.38/Makefile.in 2011-03-31 23:39:01.823874703 +0200
|
|
||||||
@@ -57,7 +57,7 @@
|
|
||||||
ixgbe.$(OBJEXT) natsemi.$(OBJEXT) pcnet32.$(OBJEXT) \
|
|
||||||
realtek.$(OBJEXT) tg3.$(OBJEXT) marvell.$(OBJEXT) \
|
|
||||||
vioc.$(OBJEXT) smsc911x.$(OBJEXT) at76c50x-usb.$(OBJEXT) \
|
|
||||||
- sfc.$(OBJEXT) stmmac.$(OBJEXT)
|
|
||||||
+ sfc.$(OBJEXT) stmmac.$(OBJEXT) ixp4xx.$(OBJEXT)
|
|
||||||
ethtool_OBJECTS = $(am_ethtool_OBJECTS)
|
|
||||||
ethtool_LDADD = $(LDADD)
|
|
||||||
DEFAULT_INCLUDES = -I.@am__isrc@
|
|
||||||
@@ -201,7 +201,7 @@
|
|
||||||
amd8111e.c de2104x.c e100.c e1000.c igb.c \
|
|
||||||
fec_8xx.c ibm_emac.c ixgb.c ixgbe.c natsemi.c \
|
|
||||||
pcnet32.c realtek.c tg3.c marvell.c vioc.c \
|
|
||||||
- smsc911x.c at76c50x-usb.c sfc.c stmmac.c
|
|
||||||
+ smsc911x.c at76c50x-usb.c sfc.c stmmac.c ixp4xx.c
|
|
||||||
|
|
||||||
all: ethtool-config.h
|
|
||||||
$(MAKE) $(AM_MAKEFLAGS) all-am
|
|
||||||
@@ -321,6 +321,7 @@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/igb.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ixgb.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ixgbe.Po@am__quote@
|
|
||||||
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ixp4xx.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/marvell.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/natsemi.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pcnet32.Po@am__quote@
|
|
Loading…
x
Reference in New Issue
Block a user