[package] opencdk: fix verification of clearsigned documents
This patch fixes a bug in the upstream library that prevents the verification of clearsigned documents with \r\n line endings. Obviously, it should go under feeds/packages/libs/opencdk/patches/ Signed-off-by: Daniel A. Nagy <nagydani@epointsystem.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@25437 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a7f4619820
commit
2a3ec41bb3
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006, 2007 OpenWrt.org
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=opencdk
|
||||
PKG_VERSION:=0.6.6
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
|
||||
|
13
libs/opencdk/patches/200-verify-clearsigned.patch
Normal file
13
libs/opencdk/patches/200-verify-clearsigned.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- opencdk-0.6.6/src/stream.c 2007-11-08 19:31:45.000000000 +0100
|
||||
+++ opencdk-0.6.6-my/src/stream.c 2011-01-17 20:30:19.000000000 +0100
|
||||
@@ -1384,7 +1384,9 @@
|
||||
while (!cdk_stream_eof (s) && count > 0)
|
||||
{
|
||||
c = cdk_stream_getc (s);
|
||||
- if (c == EOF || c == '\r' || c == '\n' )
|
||||
+ if (c == '\r')
|
||||
+ c = cdk_stream_getc (s);
|
||||
+ if (c == EOF || c == '\n' )
|
||||
{
|
||||
buf[i++] = '\0';
|
||||
break;
|
Loading…
x
Reference in New Issue
Block a user