stm32flash: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41191 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
82105b824f
commit
2a778b09e4
@ -1,40 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2012-2014 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=stm32flash
|
|
||||||
PKG_REV:=61
|
|
||||||
PKG_VERSION:=r$(PKG_REV)
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=http://stm32flash.googlecode.com/svn/trunk
|
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
|
||||||
PKG_SOURCE_PROTO:=svn
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/stm32flash
|
|
||||||
SECTION:=utils
|
|
||||||
CATEGORY:=Utilities
|
|
||||||
URL:=http://code.google.com/p/stm32flash/
|
|
||||||
TITLE:=Firmware flash tool for STM32's serial bootloader
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/stm32flash/description
|
|
||||||
This tool can be used to burn firmware images to STM32 ARM processors
|
|
||||||
using the built-in serial bootloader.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/stm32flash/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/stm32flash $(1)/usr/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,stm32flash))
|
|
@ -1,30 +0,0 @@
|
|||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -5,7 +5,7 @@ export AR
|
|
||||||
|
|
||||||
all:
|
|
||||||
$(MAKE) -C parsers
|
|
||||||
- $(CC) -g -o stm32flash -I./ \
|
|
||||||
+ $(CC) $(LDFLAGS) -o stm32flash -I./ \
|
|
||||||
main.c \
|
|
||||||
utils.c \
|
|
||||||
stm32.c \
|
|
||||||
@@ -13,7 +13,7 @@ all:
|
|
||||||
serial_platform.c \
|
|
||||||
parsers/parsers.a \
|
|
||||||
stm32/stmreset_binary.c \
|
|
||||||
- -Wall
|
|
||||||
+ $(CFLAGS)
|
|
||||||
|
|
||||||
clean:
|
|
||||||
$(MAKE) -C parsers clean
|
|
||||||
--- a/parsers/Makefile
|
|
||||||
+++ b/parsers/Makefile
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
|
|
||||||
all:
|
|
||||||
- $(CC) -g -Wall -c -I../ binary.c hex.c
|
|
||||||
+ $(CC) $(CFLAGS) -Wall -c -I../ binary.c hex.c
|
|
||||||
$(AR) r parsers.a binary.o hex.o
|
|
||||||
|
|
||||||
clean:
|
|
Loading…
x
Reference in New Issue
Block a user