[packages] collectd: lazily evaluate CONFIGURE_PLUGIN (thanks nbd) (#6447), update to 4.9.1
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19154 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e52fd74998
commit
2b53176259
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2009 OpenWrt.org
|
# Copyright (C) 2006-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,14 +8,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=collectd
|
PKG_NAME:=collectd
|
||||||
PKG_VERSION:=4.9.0
|
PKG_VERSION:=4.9.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://collectd.org/files/
|
PKG_SOURCE_URL:=http://collectd.org/files/
|
||||||
PKG_MD5SUM:=5b2e5f57716f2485a3b4eb57774a3818
|
PKG_MD5SUM:=5753496651c8c84afaea1fe290876bfc
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
COLLECTD_PLUGINS_DISABLED:= \
|
COLLECTD_PLUGINS_DISABLED:= \
|
||||||
apple_sensors \
|
apple_sensors \
|
||||||
@ -147,7 +148,7 @@ CONFIGURE_VARS+= \
|
|||||||
LDFLAGS="$$$$LDFLAGS -lm -lz" \
|
LDFLAGS="$$$$LDFLAGS -lm -lz" \
|
||||||
KERNEL_DIR="$(LINUX_DIR)" \
|
KERNEL_DIR="$(LINUX_DIR)" \
|
||||||
|
|
||||||
CONFIGURE_PLUGIN:= \
|
CONFIGURE_PLUGIN= \
|
||||||
$(foreach m, $(1), \
|
$(foreach m, $(1), \
|
||||||
$(if $(CONFIG_PACKAGE_collectd-mod-$(m)),--enable-$(m),--disable-$(m)) \
|
$(if $(CONFIG_PACKAGE_collectd-mod-$(m)),--enable-$(m),--disable-$(m)) \
|
||||||
)
|
)
|
||||||
@ -177,10 +178,6 @@ ifneq ($(CONFIG_PACKAGE_collectd-mod-rrdtool),)
|
|||||||
CONFIGURE_ARGS+= --with-librrd="$(STAGING_DIR)/usr/lib/rrdtool-1.0"
|
CONFIGURE_ARGS+= --with-librrd="$(STAGING_DIR)/usr/lib/rrdtool-1.0"
|
||||||
endif
|
endif
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
all install
|
|
||||||
|
|
||||||
define Package/collectd/conffiles
|
define Package/collectd/conffiles
|
||||||
/etc/collectd.conf
|
/etc/collectd.conf
|
||||||
endef
|
endef
|
||||||
|
@ -71,7 +71,12 @@ LoadPlugin wireless
|
|||||||
|
|
||||||
#<Plugin ping>
|
#<Plugin ping>
|
||||||
# Host "host.foo.bar"
|
# Host "host.foo.bar"
|
||||||
|
# Interval 1.0
|
||||||
|
# Timeout 0.9
|
||||||
# TTL 255
|
# TTL 255
|
||||||
|
# SourceAddress "1.2.3.4"
|
||||||
|
# Device "eth0"
|
||||||
|
# MaxMissed -1
|
||||||
#</Plugin>
|
#</Plugin>
|
||||||
|
|
||||||
#<Plugin processes>
|
#<Plugin processes>
|
||||||
|
@ -17,7 +17,7 @@
|
|||||||
/* consolidation_functions = */ NULL,
|
/* consolidation_functions = */ NULL,
|
||||||
/* consolidation_functions_num = */ 0
|
/* consolidation_functions_num = */ 0
|
||||||
};
|
};
|
||||||
@@ -975,6 +978,14 @@ static int rrd_config (const char *key,
|
@@ -976,6 +979,14 @@ static int rrd_config (const char *key,
|
||||||
|
|
||||||
free (value_copy);
|
free (value_copy);
|
||||||
}
|
}
|
||||||
|
Loading…
x
Reference in New Issue
Block a user