fix miniupnpd.. please be careful merging in changes...
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6274 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
07e70aee64
commit
2b59378c81
@ -31,7 +31,8 @@ define Package/miniupnpd
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.linux \
|
||||
ln -sf $(PKG_BUILD_DIR)/config.h.openwrt $(PKG_BUILD_DIR)/config.h
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I $(STAGING_DIR)/usr/include" \
|
||||
LIBS="$(STAGING_DIR)/usr/lib/libiptc.a"
|
||||
|
35
net/miniupnpd/patches/001-makefile-tweaks.patch
Normal file
35
net/miniupnpd/patches/001-makefile-tweaks.patch
Normal file
@ -0,0 +1,35 @@
|
||||
--- miniupnpd-1.0-RC3/Makefile.openwrt.orig 2007-02-06 22:50:56.000000000 -0600
|
||||
+++ miniupnpd-1.0-RC3/Makefile.openwrt 2007-02-06 22:51:00.000000000 -0600
|
||||
@@ -11,17 +11,15 @@
|
||||
CFLAGS += -D_GNU_SOURCE
|
||||
RM = rm -f
|
||||
INSTALL = install
|
||||
-IPTABLESINC=$(BUILD_DIR)/iptables-1.3.3/include
|
||||
+IPTABLESINC=$(STAGING_DIR)/usr/include
|
||||
|
||||
BASEOBJS = miniupnpd.o upnphttp.o upnpdescgen.o upnpsoap.o \
|
||||
upnpreplyparse.o minixml.o \
|
||||
upnpredirect.o getifaddr.o daemonize.o upnpglobalvars.o \
|
||||
- options.o
|
||||
+ options.o upnppermissions.o
|
||||
|
||||
LNXOBJS = linux/getifstats.o linux/iptcrdr.o
|
||||
|
||||
-LIBS = $(BUILD_DIR)/iptables-1.3.3/libiptc/libiptc.a
|
||||
-
|
||||
TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o
|
||||
|
||||
EXECUTABLES = miniupnpd testupnpdescgen
|
||||
@@ -38,6 +36,7 @@
|
||||
@echo no install for now...
|
||||
|
||||
miniupnpd: $(BASEOBJS) $(LNXOBJS) $(LIBS)
|
||||
+ $(CC) $(CFLAGS) -o $@ $(BASEOBJS) $(LNXOBJS) $(LIBS)
|
||||
|
||||
testupnpdescgen: $(TESTUPNPDESCGENOBJS)
|
||||
|
||||
@@ -69,3 +68,4 @@
|
||||
linux/iptcrdr.o: linux/iptcrdr.h
|
||||
testupnpdescgen.o: upnpdescgen.h
|
||||
upnpdescgen.o: upnpdescgen.h miniupnpdpath.h upnpglobalvars.h
|
||||
+upnppermissions.o: upnppermissions.c
|
Loading…
x
Reference in New Issue
Block a user