Upgrade unfs3 to 0.9.20 (#3662)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11660 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-07-05 13:24:04 +00:00
parent 47de9383c1
commit 2cd1e59dc9
2 changed files with 30 additions and 36 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=unfs3 PKG_NAME:=unfs3
PKG_VERSION:=0.9.17 PKG_VERSION:=0.9.20
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME) PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=cde90d604ef42d8ab0c82ed501179417 PKG_MD5SUM:=2920d9cc7c3cb76da0792669bf035650
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
@ -27,9 +27,9 @@ define Package/unfs3
endef endef
define Package/unfs3/description define Package/unfs3/description
UNFS3 is a user-space implementation of the NFSv3 server UNFS3 is a user-space implementation of the NFSv3 server
specification. It provides a daemon for the MOUNT and NFS specification. It provides a daemon for the MOUNT and NFS
protocols, which are used by NFS clients for accessing files protocols, which are used by NFS clients for accessing files
on the server. on the server.
endef endef

View File

@ -1,34 +1,6 @@
Index: unfs3-0.9.17/Makefile.in --- a/Config/lex.yy.c
=================================================================== +++ b/Config/lex.yy.c
--- unfs3-0.9.17.orig/Makefile.in 2007-07-28 22:40:02.000000000 +0200 @@ -445,9 +445,15 @@
+++ unfs3-0.9.17/Makefile.in 2007-07-28 22:40:02.000000000 +0200
@@ -11,7 +11,7 @@
md5.o mount.o nfs.o password.o readdir.o user.o xdr.o winsupport.o
CONFOBJ = Config/lib.a
EXTRAOBJ = @EXTRAOBJ@
-LDFLAGS = @LDFLAGS@ @LIBS@ @LEXLIB@
+LDFLAGS = @LDFLAGS@ @LIBS@
EXEEXT = @EXEEXT@
prefix = @prefix@
Index: unfs3-0.9.17/configure
===================================================================
--- unfs3-0.9.17.orig/configure 2007-07-28 22:40:02.000000000 +0200
+++ unfs3-0.9.17/configure 2007-07-28 22:40:02.000000000 +0200
@@ -2122,7 +2122,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lfl $LIBS"
+LIBS="$LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
Index: unfs3-0.9.17/Config/lex.yy.c
===================================================================
--- unfs3-0.9.17.orig/Config/lex.yy.c 2007-07-28 22:40:21.000000000 +0200
+++ unfs3-0.9.17/Config/lex.yy.c 2007-07-28 22:40:56.000000000 +0200
@@ -442,9 +442,15 @@
#ifndef YY_SKIP_YYWRAP #ifndef YY_SKIP_YYWRAP
#ifdef __cplusplus #ifdef __cplusplus
@ -47,3 +19,25 @@ Index: unfs3-0.9.17/Config/lex.yy.c
#endif #endif
#endif #endif
--- a/Makefile.in
+++ b/Makefile.in
@@ -12,7 +12,7 @@
md5.o mount.o nfs.o password.o readdir.o user.o xdr.o winsupport.o
CONFOBJ = Config/lib.a
EXTRAOBJ = @EXTRAOBJ@
-LDFLAGS = @LDFLAGS@ @LIBS@ @LEXLIB@
+LDFLAGS = @LDFLAGS@ @LIBS@
EXEEXT = @EXEEXT@
prefix = @prefix@
--- a/configure
+++ b/configure
@@ -2604,7 +2604,7 @@
ac_save_LIBS=$LIBS
ac_cv_lib_lex='none needed'
- for ac_lib in '' -lfl -ll; do
+ for ac_lib in '' -ll; do
LIBS="$ac_lib $ac_save_LIBS"
cat >conftest.$ac_ext <<_ACEOF
`cat $LEX_OUTPUT_ROOT.c`