[packages] mtr: update to 0.80
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22280 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b62e75de8f
commit
2d6be69ef0
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mtr
|
PKG_NAME:=mtr
|
||||||
PKG_VERSION:=0.79
|
PKG_VERSION:=0.80
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
|
PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr
|
||||||
PKG_MD5SUM:=f7c1f873e68e7176f60ae9fbb2ca20f4
|
PKG_MD5SUM:=fa68528eaec1757f52bacf9fea8c68a9
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
@ -38,6 +38,12 @@ define Package/mtr/description
|
|||||||
running statistics about each machine.
|
running statistics about each machine.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
--without-gtk \
|
||||||
|
|
||||||
|
CONFIGURE_VARS += \
|
||||||
|
ac_cv_lib_resolv_res_mkquery=yes \
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
(cd $(PKG_BUILD_DIR); touch \
|
(cd $(PKG_BUILD_DIR); touch \
|
||||||
configure.in \
|
configure.in \
|
||||||
@ -48,11 +54,7 @@ define Build/Configure
|
|||||||
config.h.in \
|
config.h.in \
|
||||||
configure \
|
configure \
|
||||||
);
|
);
|
||||||
$(call Build/Configure/Default, \
|
$(call Build/Configure/Default)
|
||||||
--without-gtk \
|
|
||||||
, \
|
|
||||||
ac_cv_lib_resolv_res_mkquery=yes \
|
|
||||||
)
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/mtr/install
|
define Package/mtr/install
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/dns.c
|
--- a/dns.c
|
||||||
+++ b/dns.c
|
+++ b/dns.c
|
||||||
@@ -869,6 +869,507 @@ void restell(char *s)
|
@@ -880,6 +880,507 @@ void restell(char *s)
|
||||||
fputs("\r",stderr);
|
fputs("\r",stderr);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -5,18 +5,18 @@
|
|||||||
int use_dns = 1;
|
int use_dns = 1;
|
||||||
|
|
||||||
-#ifdef res_ninit
|
-#ifdef res_ninit
|
||||||
-#define RES_INIT() res_ninit(&myres);
|
-#define MY_RES_INIT() res_ninit(&myres);
|
||||||
-#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
-#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
||||||
- res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
|
- res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
|
||||||
-struct __res_state myres;
|
-struct __res_state myres;
|
||||||
-#else
|
-#else
|
||||||
+//#ifdef res_ninit
|
+//#ifdef res_ninit
|
||||||
+//#define RES_INIT() res_ninit(&myres);
|
+//#define MY_RES_INIT() res_ninit(&myres);
|
||||||
+//#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
+//#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
||||||
+// res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
|
+// res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
|
||||||
+//struct __res_state myres;
|
+//struct __res_state myres;
|
||||||
+//#else
|
+//#else
|
||||||
#define RES_INIT() res_init();
|
#define MY_RES_INIT() res_init();
|
||||||
#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
||||||
res_mkquery(a, b, c, d, e, f, g, h, i)
|
res_mkquery(a, b, c, d, e, f, g, h, i)
|
||||||
#define myres _res
|
#define myres _res
|
||||||
|
Loading…
x
Reference in New Issue
Block a user