refresh patches before applying upcoming fix

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13966 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2009-01-10 23:53:44 +00:00
parent 4e59d48856
commit 2de67b2eab
4 changed files with 43 additions and 75 deletions

@ -4,11 +4,9 @@
# - use libnetfilter_queue instead of deprecated libipq # - use libnetfilter_queue instead of deprecated libipq
# #
# Under GPLv2 - Copyright (C) 2008 - EADS - Arnaud Ebalard <arno@natisbad.org> # Under GPLv2 - Copyright (C) 2008 - EADS - Arnaud Ebalard <arno@natisbad.org>
Index: sendd-0.2/Makefile.config --- a/Makefile.config
=================================================================== +++ b/Makefile.config
--- sendd-0.2.orig/Makefile.config 2008-05-27 16:53:49.238160776 +0200 @@ -19,7 +19,7 @@ OS=linux
+++ sendd-0.2/Makefile.config 2008-05-27 16:53:52.866156255 +0200
@@ -19,7 +19,7 @@
#CC=gcc-4.0 #CC=gcc-4.0
# Where to install # Where to install
@ -17,11 +15,9 @@ Index: sendd-0.2/Makefile.config
# Set to "y" to build MT versions of sendd and cgatool # Set to "y" to build MT versions of sendd and cgatool
USE_THREADS=n USE_THREADS=n
Index: sendd-0.2/README --- a/README
=================================================================== +++ b/README
--- sendd-0.2.orig/README 2008-05-27 16:53:49.246168775 +0200 @@ -20,7 +20,7 @@ Linux:
+++ sendd-0.2/README 2008-05-27 16:53:52.866156255 +0200
@@ -20,7 +20,7 @@
o CONFIG_NETFILTER, CONFIG_IPV6, CONFIG_IP6_NF_QUEUE, CONFIG_IP6_NF_IPTABLES, o CONFIG_NETFILTER, CONFIG_IPV6, CONFIG_IP6_NF_QUEUE, CONFIG_IP6_NF_IPTABLES,
CONFIG_IP6_NF_FILTER enabled in your kernel config. CONFIG_IP6_NF_FILTER enabled in your kernel config.
o netfilter ip6tables command o netfilter ip6tables command
@ -30,11 +26,9 @@ Index: sendd-0.2/README
FreeBSD: FreeBSD:
o NETGRAPH, NETGRAPH_BPF, NETGRAPH_ETHER, NETGRAPH_SOCKET enabled in o NETGRAPH, NETGRAPH_BPF, NETGRAPH_ETHER, NETGRAPH_SOCKET enabled in
Index: sendd-0.2/cgatool/Makefile --- a/cgatool/Makefile
=================================================================== +++ b/cgatool/Makefile
--- sendd-0.2.orig/cgatool/Makefile 2008-05-27 16:53:49.278164104 +0200 @@ -25,7 +25,7 @@ endif
+++ sendd-0.2/cgatool/Makefile 2008-05-27 16:53:52.866156255 +0200
@@ -25,7 +25,7 @@
ifeq ($(USE_CONSOLE),y) ifeq ($(USE_CONSOLE),y)
ifeq ($(USE_READLINE),y) ifeq ($(USE_READLINE),y)
@ -43,11 +37,9 @@ Index: sendd-0.2/cgatool/Makefile
endif endif
endif endif
Index: sendd-0.2/sendd/Makefile --- a/sendd/Makefile
=================================================================== +++ b/sendd/Makefile
--- sendd-0.2.orig/sendd/Makefile 2008-05-27 16:53:49.286173430 +0200 @@ -37,7 +37,7 @@ endif
+++ sendd-0.2/sendd/Makefile 2008-05-27 16:53:52.878156241 +0200
@@ -37,7 +37,7 @@
ifeq ($(USE_CONSOLE),y) ifeq ($(USE_CONSOLE),y)
ifeq ($(USE_READLINE),y) ifeq ($(USE_READLINE),y)
@ -56,10 +48,8 @@ Index: sendd-0.2/sendd/Makefile
endif endif
endif endif
Index: sendd-0.2/sendd/os-linux/Makefile --- a/sendd/os-linux/Makefile
=================================================================== +++ b/sendd/os-linux/Makefile
--- sendd-0.2.orig/sendd/os-linux/Makefile 2008-05-27 16:53:49.294197424 +0200
+++ sendd-0.2/sendd/os-linux/Makefile 2008-05-27 16:53:52.910156597 +0200
@@ -1,23 +1,5 @@ @@ -1,23 +1,5 @@
OBJS += os/addr.o os/ipq.o os/rand.o os/snd_linux.o OBJS += os/addr.o os/ipq.o os/rand.o os/snd_linux.o
@ -86,10 +76,8 @@ Index: sendd-0.2/sendd/os-linux/Makefile
-# installed in include/libipq/libipq.h. This rule helps cpp to find it. -# installed in include/libipq/libipq.h. This rule helps cpp to find it.
-os/ipq.o: CPPFLAGS += -I/usr/include/libipq -I/usr/local/include/libipq -os/ipq.o: CPPFLAGS += -I/usr/include/libipq -I/usr/local/include/libipq
+os/ipq.o: CPPFLAGS += -I/usr/include/libnetfilter_queue +os/ipq.o: CPPFLAGS += -I/usr/include/libnetfilter_queue
Index: sendd-0.2/sendd/os-linux/ipq.c --- a/sendd/os-linux/ipq.c
=================================================================== +++ b/sendd/os-linux/ipq.c
--- sendd-0.2.orig/sendd/os-linux/ipq.c 2008-05-27 16:53:49.306181136 +0200
+++ sendd-0.2/sendd/os-linux/ipq.c 2008-05-27 16:55:57.602168158 +0200
@@ -33,7 +33,7 @@ @@ -33,7 +33,7 @@
#include <sys/select.h> #include <sys/select.h>
#include <netinet/in.h> #include <netinet/in.h>
@ -344,10 +332,8 @@ Index: sendd-0.2/sendd/os-linux/ipq.c
+ if (h != NULL) + if (h != NULL)
+ nfq_close(h); + nfq_close(h);
} }
Index: sendd-0.2/sendd/os-linux/snd_linux.c --- a/sendd/os-linux/snd_linux.c
=================================================================== +++ b/sendd/os-linux/snd_linux.c
--- sendd-0.2.orig/sendd/os-linux/snd_linux.c 2008-05-27 16:53:49.314164060 +0200
+++ sendd-0.2/sendd/os-linux/snd_linux.c 2008-05-27 16:53:52.914160667 +0200
@@ -40,13 +40,13 @@ @@ -40,13 +40,13 @@
void void
os_specific_add_fds(fd_set *fds, int *maxfd) os_specific_add_fds(fd_set *fds, int *maxfd)
@ -364,7 +350,7 @@ Index: sendd-0.2/sendd/os-linux/snd_linux.c
} }
int int
@@ -59,7 +59,7 @@ @@ -59,7 +59,7 @@ int
os_specific_init(void) os_specific_init(void)
{ {
if (linux_rand_init() < 0 || if (linux_rand_init() < 0 ||
@ -373,7 +359,7 @@ Index: sendd-0.2/sendd/os-linux/snd_linux.c
return (-1); return (-1);
} }
return (0); return (0);
@@ -68,6 +68,6 @@ @@ -68,6 +68,6 @@ os_specific_init(void)
void void
os_specific_fini(void) os_specific_fini(void)
{ {
@ -381,10 +367,8 @@ Index: sendd-0.2/sendd/os-linux/snd_linux.c
+ linux_nfq_fini(); + linux_nfq_fini();
linux_rand_fini(); linux_rand_fini();
} }
Index: sendd-0.2/sendd/os-linux/snd_linux.h --- a/sendd/os-linux/snd_linux.h
=================================================================== +++ b/sendd/os-linux/snd_linux.h
--- sendd-0.2.orig/sendd/os-linux/snd_linux.h 2008-05-27 16:53:49.330169232 +0200
+++ sendd-0.2/sendd/os-linux/snd_linux.h 2008-05-27 16:53:52.914160667 +0200
@@ -33,10 +33,10 @@ @@ -33,10 +33,10 @@
#ifndef _SEND_LINUX_H #ifndef _SEND_LINUX_H
#define _SEND_LINUX_H #define _SEND_LINUX_H

@ -4,12 +4,9 @@ may optionnaly honor this setting (5.1.3). This is particularly
useful on embedded systems where both the entropy and the processing useful on embedded systems where both the entropy and the processing
power are limited. power are limited.
Index: sendd-0.2/sendd/config.c --- a/sendd/config.c
=================================================================== +++ b/sendd/config.c
diff -urN sendd-0.2/sendd/config.c sendd-0.2.new/sendd/config.c @@ -82,6 +82,7 @@ struct snd_conf snd_confs[] = {
--- sendd-0.2/sendd/config.c 2008-04-18 16:21:46.000000000 +0200
+++ sendd-0.2.new/sendd/config.c 2008-09-09 15:41:11.000000000 +0200
@@ -82,6 +82,7 @@
SND_CFS(snd_cga_params, NULL, 1), SND_CFS(snd_cga_params, NULL, 1),
SND_CFIB(snd_full_secure, 1, 0), SND_CFIB(snd_full_secure, 1, 0),
SND_CFII(snd_min_key_bits, 1024, "bits", 0), SND_CFII(snd_min_key_bits, 1024, "bits", 0),
@ -17,12 +14,9 @@ diff -urN sendd-0.2/sendd/config.c sendd-0.2.new/sendd/config.c
SND_CFII(snd_nonce_cache_gc_intvl, 2, "seconds", 0), SND_CFII(snd_nonce_cache_gc_intvl, 2, "seconds", 0),
SND_CFII(snd_pfx_cache_gc_intvl, 40, "seconds", 0), SND_CFII(snd_pfx_cache_gc_intvl, 40, "seconds", 0),
SND_CFS(snd_pkixip_conf, NULL, 0), SND_CFS(snd_pkixip_conf, NULL, 0),
Index: sendd-0.2/sendd/sig_rfc3971.c --- a/sendd/sig_rfc3971.c
=================================================================== +++ b/sendd/sig_rfc3971.c
diff -urN sendd-0.2/sendd/sig_rfc3971.c sendd-0.2.new/sendd/sig_rfc3971.c @@ -147,7 +147,7 @@ ver(struct iovec *iov, int iovlen, uint8
--- sendd-0.2/sendd/sig_rfc3971.c 2008-04-18 16:21:46.000000000 +0200
+++ sendd-0.2.new/sendd/sig_rfc3971.c 2008-09-10 11:14:35.000000000 +0200
@@ -147,7 +147,7 @@
EVP_MD_CTX ctx[1]; EVP_MD_CTX ctx[1];
EVP_PKEY *pub; EVP_PKEY *pub;
int rv = -1; int rv = -1;
@ -31,7 +25,7 @@ diff -urN sendd-0.2/sendd/sig_rfc3971.c sendd-0.2.new/sendd/sig_rfc3971.c
DEFINE_TIMESTAMP_VARS(); DEFINE_TIMESTAMP_VARS();
DBG_HEXDUMP(&dbg_cryptox, "key: ", key, klen); DBG_HEXDUMP(&dbg_cryptox, "key: ", key, klen);
@@ -164,6 +164,12 @@ @@ -164,6 +164,12 @@ ver(struct iovec *iov, int iovlen, uint8
"minimum: %d)", EVP_PKEY_bits(pub), min_bits); "minimum: %d)", EVP_PKEY_bits(pub), min_bits);
return (-1); return (-1);
} }
@ -44,12 +38,9 @@ diff -urN sendd-0.2/sendd/sig_rfc3971.c sendd-0.2.new/sendd/sig_rfc3971.c
real_slen = EVP_PKEY_size(pub); real_slen = EVP_PKEY_size(pub);
if (real_slen < slen) { if (real_slen < slen) {
Index: sendd-0.2/sendd/snd_config.h --- a/sendd/snd_config.h
=================================================================== +++ b/sendd/snd_config.h
diff -urN sendd-0.2/sendd/snd_config.h sendd-0.2.new/sendd/snd_config.h @@ -42,6 +42,7 @@ enum snd_conf_syms {
--- sendd-0.2/sendd/snd_config.h 2008-04-18 16:21:46.000000000 +0200
+++ sendd-0.2.new/sendd/snd_config.h 2008-09-09 15:09:45.000000000 +0200
@@ -42,6 +42,7 @@
snd_cga_params, snd_cga_params,
snd_full_secure, snd_full_secure,
snd_min_key_bits, snd_min_key_bits,

@ -7,11 +7,9 @@ option to 8 bytes. Before that, send was padding with N bytes
which would align to the number of bytes representing a pointer which would align to the number of bytes representing a pointer
on your architecture. on your architecture.
Index: sendd-0.2/sendd/snd_proto.h --- a/sendd/snd_proto.h
============================================================ +++ b/sendd/snd_proto.h
--- sendd-0.2/sendd/snd_proto.h 2008-04-18 16:21:46.000000000 +0200 @@ -69,7 +69,7 @@ struct snd_opt_sig {
+++ sendd-0.2.new/sendd/snd_proto.h 2008-10-05 16:08:34.000000000 +0200
@@ -69,7 +69,7 @@
uint32_t reserved; /* opt hdr + reserved */ uint32_t reserved; /* opt hdr + reserved */
uint8_t keyhash[SND_KEYHASH_LEN]; uint8_t keyhash[SND_KEYHASH_LEN];
uint8_t sig[0]; uint8_t sig[0];

@ -2,11 +2,9 @@ We should always link with libncurses. This is not noticeable
when building the debian packages because we install libncurses5 when building the debian packages because we install libncurses5
runtime library as a dependency. runtime library as a dependency.
Index: sendd-0.2/cgatool/Makefile --- a/cgatool/Makefile
=================================================================== +++ b/cgatool/Makefile
--- sendd-0.2/cgatool/Makefile 2008-10-05 16:26:28.000000000 +0200 @@ -17,7 +17,7 @@ LDLIBS= $(DEPLIBS)
+++ sendd-0.2.new/cgatool/Makefile 2008-10-21 18:03:28.000000000 +0200
@@ -17,7 +17,7 @@
LDFLAGS= -L../libs/.libs LDFLAGS= -L../libs/.libs
endif endif
@ -15,17 +13,14 @@ Index: sendd-0.2/cgatool/Makefile
ifeq ($(USE_THREADS),y) ifeq ($(USE_THREADS),y)
LDLIBS += -lpthread LDLIBS += -lpthread
Index: sendd-0.2/sendd/Makefile --- a/sendd/Makefile
=================================================================== +++ b/sendd/Makefile
diff -urN sendd-0.2/sendd/Makefile sendd-0.2.new/sendd/Makefile @@ -28,7 +28,7 @@ LDLIBS= $(DEPLIBS)
--- sendd-0.2/sendd/Makefile 2008-05-27 17:04:08.000000000 +0200
+++ sendd-0.2.new/sendd/Makefile 2008-10-21 18:49:05.000000000 +0200
@@ -28,7 +28,7 @@
LDFLAGS= -L../libs/.libs LDFLAGS= -L../libs/.libs
endif endif
-LDLIBS += -lcrypto -LDLIBS += -lcrypto
+LDLIBS += -lcrypto -lncurses +LDLIBS += -lcrypto -lncurses
LDLIBS += $(OSLIBS) LDLIBS += $(OSLIBS)
ifeq ($(USE_THREADS),y) ifeq ($(USE_THREADS),y)