[packages] lighttpd: add a patch fixing upstream issue [http://redmine.lighttpd.net/issues/2157 2157] with recent OpenSSL (closes: #6996)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20600 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2010-03-30 12:04:24 +00:00
parent 34de41c60e
commit 2e2e9bcb18
2 changed files with 14 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.26
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/

View File

@ -0,0 +1,13 @@
http://redmine.lighttpd.net/issues/2157
--- a/src/network.c
+++ b/src/network.c
@@ -525,7 +525,7 @@ int network_init(server *srv) {
if (!s->ssl_use_sslv2) {
/* disable SSLv2 */
- if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
+ if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
ERR_error_string(ERR_get_error(), NULL));
return -1;