mini_sendmail:

* Update 1.3.5 > 1.3.6
 * Refresh patches
 * Cleanup Makefile

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8530 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2007-08-28 16:01:46 +00:00
parent 256f2934b4
commit 2e90ed1c08
3 changed files with 15 additions and 16 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,13 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mini-sendmail
PKG_VERSION:=1.3.5
PKG_VERSION:=1.3.6
PKG_RELEASE:=2
PKG_SOURCE:=mini_sendmail-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.acme.com/software/mini_sendmail/
PKG_MD5SUM:=fff344184e98cff0ea4d817da9d29383
PKG_CAT:=zcat
PKG_MD5SUM:=fb1585d2ad81c519a26d83bfd783dee8
PKG_BUILD_DIR:=$(BUILD_DIR)/mini_sendmail-$(PKG_VERSION)
@ -33,12 +32,8 @@ define Package/mini-sendmail
URL:=http://www.acme.com/software/mini_sendmail/
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
OFLAGS="$(TARGET_CFLAGS)" \
all
endef
MAKE_FLAGS += \
OFLAGS="$(TARGET_CFLAGS)"
define Package/mini-sendmail/install
$(INSTALL_DIR) $(1)/usr/sbin

View File

@ -1,6 +1,8 @@
--- mini_sendmail-1.3.5.org/mini_sendmail.c 2003-11-17 03:03:35.000000000 +0100
+++ mini_sendmail-1.3.5/mini_sendmail.c 2007-04-08 19:46:42.000000000 +0200
@@ -539,6 +539,7 @@
Index: mini_sendmail-1.3.6/mini_sendmail.c
===================================================================
--- mini_sendmail-1.3.6.orig/mini_sendmail.c 2007-08-28 17:58:37.000000000 +0200
+++ mini_sendmail-1.3.6/mini_sendmail.c 2007-08-28 17:58:37.000000000 +0200
@@ -542,6 +542,7 @@
}
/* Strip off any angle brackets. */
@ -8,7 +10,7 @@
while ( len > 0 && *recipient == '<' )
{
++recipient;
@@ -548,6 +549,23 @@
@@ -551,6 +552,23 @@
--len;
(void) snprintf( buf, sizeof(buf), "RCPT TO:<%.*s>", len, recipient );

View File

@ -1,5 +1,7 @@
--- mini_sendmail-1.3.5/Makefile.orig 2002-01-04 07:05:25.000000000 +0100
+++ mini_sendmail-1.3.5/Makefile 2005-06-17 01:57:06.000000000 +0200
Index: mini_sendmail-1.3.6/Makefile
===================================================================
--- mini_sendmail-1.3.6.orig/Makefile 2007-08-28 17:58:37.000000000 +0200
+++ mini_sendmail-1.3.6/Makefile 2007-08-28 17:58:37.000000000 +0200
@@ -7,9 +7,10 @@
BINDIR = /usr/local/sbin
MANDIR = /usr/local/man