[packages] python-curl: fix build failure

* add a patch to prevent use of host static curl library



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22109 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2010-07-10 00:47:54 +00:00
parent 6b05a95d33
commit 30330d92d1

View File

@ -0,0 +1,12 @@
--- a/setup.py
+++ b/setup.py
@@ -97,8 +97,7 @@ else:
else:
extra_compile_args.append(e)
libs = split_quoted(
- os.popen("'%s' --libs" % CURL_CONFIG).read()+\
- os.popen("'%s' --static-libs" % CURL_CONFIG).read())
+ os.popen("'%s' --libs" % CURL_CONFIG).read())
for e in libs:
if e[:2] == "-l":
libraries.append(e[2:])