[package] update confuse to 2.6 (#5375)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16512 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6c330f26a3
commit
30ba8cdfaa
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=confuse
|
PKG_NAME:=confuse
|
||||||
PKG_VERSION:=2.5
|
PKG_VERSION:=2.6
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/confuse/
|
PKG_SOURCE_URL:=http://bzero.se/confuse
|
||||||
PKG_MD5SUM:=4bc9b73d77ebd571ac834619ce0b3582
|
PKG_MD5SUM:=0e883d66f0f58fc33585b430c652aa30
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -25,15 +25,18 @@ define Package/confuse
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/confuse/description
|
define Package/confuse/description
|
||||||
libConfuse is a configuration file parser library, licensed under the terms of the LGPL,
|
libConfuse is a configuration file parser library, licensed under the
|
||||||
and written in C. It supports sections and (lists of) values (strings, integers, floats,
|
terms of the ISC license, and written in C. It supports sections and
|
||||||
booleans or other sections), as well as some other features (such as single/double-quoted
|
(lists of) values (strings, integers, floats, booleans or other
|
||||||
strings, environment variable expansion, functions and nested include statements). It makes
|
sections), as well as some other features (such as single/double-quoted
|
||||||
it very easy to add configuration file capability to a program using a simple API.
|
strings, environment variable expansion, functions and nested include
|
||||||
|
statements). It makes it very easy to add configuration file capability
|
||||||
The goal of libConfuse is not to be the configuration file parser library with a gazillion
|
to a program using a simple API.
|
||||||
of features. Instead, it aims to be easy to use and quick to integrate with your code.
|
|
||||||
libConfuse was called libcfg before, but was changed to not confuse with other similar libraries.
|
The goal of libConfuse is not to be the configuration file parser
|
||||||
|
library with a gazillion of features. Instead, it aims to be easy to use
|
||||||
|
and quick to integrate with your code. libConfuse was called libcfg
|
||||||
|
before, but was changed to not confuse with other similar libraries.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC)
|
||||||
@ -42,7 +45,8 @@ CONFIGURE_ARGS += \
|
|||||||
--enable-shared \
|
--enable-shared \
|
||||||
--enable-static \
|
--enable-static \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
--without-libiconv-prefix \ --without-libintl-prefix \
|
--without-libiconv-prefix \
|
||||||
|
--without-libintl-prefix \
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
MAKE_FLAGS += \
|
||||||
-C $(PKG_BUILD_DIR)/src \
|
-C $(PKG_BUILD_DIR)/src \
|
||||||
@ -61,7 +65,7 @@ define Build/UninstallDev
|
|||||||
rm -rf \
|
rm -rf \
|
||||||
$(STAGING_DIR)/usr/include/confuse.h \
|
$(STAGING_DIR)/usr/include/confuse.h \
|
||||||
$(STAGING_DIR)/usr/lib/libconfuse.{a,so*}
|
$(STAGING_DIR)/usr/lib/libconfuse.{a,so*}
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/confuse/install
|
define Package/confuse/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
--- confuse-2.5/support/config.sub.orig 2008-05-15 23:06:18.000000000 -0500
|
|
||||||
+++ confuse-2.5/support/config.sub 2008-05-15 23:06:45.000000000 -0500
|
|
||||||
@@ -230,7 +230,7 @@
|
|
||||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
|
||||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
|
||||||
| am33_2.0 \
|
|
||||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
|
||||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
|
||||||
| c4x | clipper \
|
|
||||||
| d10v | d30v | dlx | dsp16xx \
|
|
||||||
| fr30 | frv \
|
|
||||||
@@ -297,7 +297,7 @@
|
|
||||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
|
||||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
|
||||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
|
||||||
- | avr-* \
|
|
||||||
+ | avr-* | avr32-* \
|
|
||||||
| bs2000-* \
|
|
||||||
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
|
|
||||||
| clipper-* | cydra-* \
|
|
24
libs/confuse/patches/001-no_werror.patch
Normal file
24
libs/confuse/patches/001-no_werror.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -urN confuse-2.6/src/Makefile.am confuse-2.6.new/src/Makefile.am
|
||||||
|
--- confuse-2.6/src/Makefile.am 2007-10-13 13:18:28.000000000 +0200
|
||||||
|
+++ confuse-2.6.new/src/Makefile.am 2009-06-18 18:00:02.000000000 +0200
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
|
||||||
|
|
||||||
|
if cc_is_gcc
|
||||||
|
-AM_CFLAGS=-Wall -Werror
|
||||||
|
+AM_CFLAGS=-Wall
|
||||||
|
endif
|
||||||
|
|
||||||
|
LIBS = @LIBS@
|
||||||
|
diff -urN confuse-2.6/src/Makefile.in confuse-2.6.new/src/Makefile.in
|
||||||
|
--- confuse-2.6/src/Makefile.in 2007-12-29 11:56:12.000000000 +0100
|
||||||
|
+++ confuse-2.6.new/src/Makefile.in 2009-06-18 17:59:55.000000000 +0200
|
||||||
|
@@ -196,7 +196,7 @@
|
||||||
|
libconfuse_la_SOURCES = confuse.c lexer.l
|
||||||
|
libconfuse_la_LIBADD = $(LTLIBINTL)
|
||||||
|
include_HEADERS = confuse.h
|
||||||
|
-@cc_is_gcc_TRUE@AM_CFLAGS = -Wall -Werror
|
||||||
|
+@cc_is_gcc_TRUE@AM_CFLAGS = -Wall
|
||||||
|
CLEANFILES = *~ \#*\#
|
||||||
|
AM_LFLAGS = -Pcfg_yy -olex.yy.c
|
||||||
|
all: all-am
|
Loading…
x
Reference in New Issue
Block a user