[packages] motion: update to v3.2.11.1, add dependency on libpthread, cleanup

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17944 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2009-10-06 03:02:53 +00:00
parent 941760df41
commit 3195d5d877
3 changed files with 13 additions and 46 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2008 OpenWrt.org # Copyright (C) 2008-2009 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,20 +8,20 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=motion PKG_NAME:=motion
PKG_VERSION:=3.2.10.1 PKG_VERSION:=3.2.11.1
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \ PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
@SF/motion @SF/motion
PKG_MD5SUM:=5ffdc958313345c69d3e0d5ec5c013cd PKG_MD5SUM:=4e729f129d8f9b9abaed5121c3cd0037
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
define Package/motion define Package/motion
SECTION:=multimedia SECTION:=multimedia
CATEGORY:=Multimedia CATEGORY:=Multimedia
DEPENDS:=+libjpeg DEPENDS:=+libjpeg +libpthread
TITLE:=webcam motion sensing and logging TITLE:=webcam motion sensing and logging
URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
endef endef
@ -30,14 +30,11 @@ define Package/motion/conffiles
/etc/motion.conf /etc/motion.conf
endef endef
define Build/Configure CONFIGURE_ARGS+= \
$(call Build/Configure/Default, \ --without-ffmpeg \
--without-ffmpeg \ --without-jpeg-mmx \
--without-jpeg-mmx \ --without-mysql \
--without-mysql \ --without-pgsql \
--without-pgsql \
)
endef
define Build/Compile define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE) -C $(PKG_BUILD_DIR) \

View File

@ -1,30 +0,0 @@
--- a/motion.c
+++ b/motion.c
@@ -1611,6 +1611,7 @@
* httpd-control snaps are always enabled.
*/
+#ifdef HAVE_FFMPEG
/* time_current_frame is used both for snapshot and timelapse features */
time_current_frame = cnt->currenttime;
@@ -1620,7 +1621,7 @@
event(cnt, EVENT_IMAGE_SNAPSHOT, cnt->current_image->image, NULL, NULL, &cnt->current_image->timestamp_tm);
cnt->snapshot = 0;
}
-
+#endif /* HAVE_FFMPEG */
/***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
@@ -1695,9 +1696,9 @@
event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
+ time_last_frame = time_current_frame;
#endif /* HAVE_FFMPEG */
- time_last_frame = time_current_frame;
/***** MOTION LOOP - VIDEO LOOPBACK SECTION *****/

View File

@ -1,14 +1,14 @@
--- a/Makefile.in --- a/Makefile.in
+++ b/Makefile.in +++ b/Makefile.in
@@ -32,6 +32,7 @@ @@ -31,6 +31,7 @@ examplesdir = $(datadir)/@PACKAGE_NAME@-
# install. #
################################################################################ ################################################################################
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" \ CFLAGS = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" -Dsysconfdir=\"$(sysconfdir)\"
-Dsysconfdir=\"$(sysconfdir)\" -Ddocdir=\"$(docdir)\"
+CPPFLAGS = @CPPFLAGS@ +CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@ LDFLAGS = @LDFLAGS@
LIBS = @LIBS@ LIBS = @LIBS@
VIDEO_OBJ = @VIDEO@ VIDEO_OBJ = @VIDEO@
@@ -119,7 +120,7 @@ @@ -118,7 +119,7 @@ endif
################################################################################ ################################################################################
$(DEPEND_FILE): *.h $(SRC) $(DEPEND_FILE): *.h $(SRC)
@echo "Generating dependencies, please wait..." @echo "Generating dependencies, please wait..."