xmail: Update to version 1.27

This patch updates xmail to the latest version available, and
includes a quick fix for IPv6 support in CtrlClnt (XMail's
control client) commandline utility.

Signed-off-by: Luis Dallos <ld@nkvd.ignorelist.com>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@39497 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2014-02-05 23:00:23 +00:00
parent 840d46aacb
commit 323e2cbce2
5 changed files with 14 additions and 15 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xmail
PKG_VERSION:=1.26
PKG_RELEASE:=4
PKG_VERSION:=1.27
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.xmailserver.org/
PKG_MD5SUM:=26d35c2fc104d79ebb6397c7dece5b15
PKG_MD5SUM:=73c9d95012709d7b11511dfb6dd6ab3d
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
@ -43,7 +43,7 @@ endef
define Package/xmail/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/* $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/{CtrlClnt,MkUsers,XMCrypt,XMail,sendmail} $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) $(PKG_BUILD_DIR)/MailRoot.tar.bz2 $(1)/etc/
$(INSTALL_DIR) $(1)/etc/config

View File

@ -1,11 +1,11 @@
--- a/Makefile.common
+++ b/Makefile.common
@@ -76,15 +76,15 @@
SENDMAILOBJS = SendMail.o
@@ -77,15 +77,15 @@ SENDMAILOBJS = $(addprefix $(OUTDIR)/, $
%.o : %.cpp
- ${CC} ${CPPFLAGS} ${CFLAGS} -c $*.cpp
+ ${CXX} ${CPPFLAGS} ${CFLAGS} -c $*.cpp
$(OUTDIR)/%.o: %.cpp
- ${CC} ${CPPFLAGS} ${CFLAGS} -o $(OUTDIR)/$*.o -c $*.cpp
+ ${CXX} ${CPPFLAGS} ${CFLAGS} -o $(OUTDIR)/$*.o -c $*.cpp
all: ${OUTDIR} ${MKMACHDEPINC} ${MAILSVR} ${CRTLCLNT} ${XMCRYPT} ${MKUSERS} ${SENDMAIL}

View File

@ -11,5 +11,5 @@
+LD = $(CXX)
+#STRIP = strip
ifneq ("$(WITH_SSL_INCLUDE)", "")
CFLAGS := $(CFLAGS) -I$(WITH_SSL_INCLUDE)
ifeq ("$(XMAIL_FILE_OFF_BITS)", "")
CFLAGS := $(CFLAGS) -D_FILE_OFFSET_BITS=64

View File

@ -1,6 +1,5 @@
diff -urN xmail-1.25.orig/SysMachine.h xmail-1.25/SysMachine.h
--- xmail-1.25.orig/SysMachine.h 1970-01-01 01:00:00.000000000 +0100
+++ xmail-1.25/SysMachine.h 2008-07-28 10:16:47.000000000 +0200
--- /dev/null
+++ b/SysMachine.h
@@ -0,0 +1,30 @@
+#ifndef _MACHDEFS_H
+#define _MACHDEFS_H

View File

@ -1,6 +1,6 @@
--- a/Makefile.common
+++ b/Makefile.common
@@ -24,10 +24,10 @@
@@ -24,10 +24,10 @@ ifeq ($(DEBUG_OSSL), 1)
endif
ifeq ($(XMAIL_DEBUG), 1)