orbit2: fix build with recent glib version
This fixes a build problem introduced in r37953. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@37991 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d312a0cce9
commit
32d18992b6
22
libs/orbit2/patches/020-build-fix.patch
Normal file
22
libs/orbit2/patches/020-build-fix.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -243,7 +243,7 @@ AC_SUBST(pkglibdir)
|
||||||
|
|
||||||
|
if test "$enable_maintainer_mode" = "yes"; then
|
||||||
|
DISABLE_DEPRECATED_CFLAGS=" \
|
||||||
|
- -DG_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES"
|
||||||
|
+ -DG_DISABLE_SINGLE_INCLUDES"
|
||||||
|
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
|
||||||
|
fi
|
||||||
|
|
||||||
|
--- a/linc2/src/Makefile.am
|
||||||
|
+++ b/linc2/src/Makefile.am
|
||||||
|
@@ -13,7 +13,7 @@ INCLUDES = \
|
||||||
|
-I$(top_srcdir)/linc2/include \
|
||||||
|
$(LINC_CFLAGS) \
|
||||||
|
$(WARN_CFLAGS) \
|
||||||
|
- -DG_DISABLE_DEPRECATED
|
||||||
|
+ $(DISABLE_DEPRECATED_CFLAGS)
|
||||||
|
|
||||||
|
if OS_WIN32
|
||||||
|
else
|
Loading…
x
Reference in New Issue
Block a user