[packages] jamvm fixes:

- enable on mipsel (closes: #4027)
 - set a reasonable max heap size for embedded devices (closes: #3157)
   can always be overridden with cmdline args
 - add dependency on libptread
 - remove duplicate use of TARGET_CFLAGS
 - bump release number


git-svn-id: svn://svn.openwrt.org/openwrt/packages@12656 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2008-09-23 10:21:05 +00:00
parent e791c243f9
commit 333257fb94
2 changed files with 15 additions and 4 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=jamvm
PKG_VERSION:=1.5.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/jamvm
@ -24,7 +24,7 @@ define Package/jamvm
CATEGORY:=Languages
TITLE:=A compact Java Virtual Machine
URL:=http://sourceforge.net/projects/jamvm
DEPENDS:=+libffi-sable @!mips @!mipsel
DEPENDS:=+libffi-sable +libpthread @!mips
endef
define Package/jamvm/description
@ -42,7 +42,7 @@ CONFIGURE_ARGS+= \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CPPFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
all
endef

View File

@ -0,0 +1,11 @@
--- jamvm-1.5.0-old/src/jam.h 2007-10-26 05:08:41.000000000 +0200
+++ jamvm-1.5.0-new/src/jam.h 2008-02-06 10:52:01.000000000 +0100
@@ -676,7 +676,7 @@
/* default maximum size of object heap */
#ifndef DEFAULT_MAX_HEAP
-#define DEFAULT_MAX_HEAP 128*MB
+#define DEFAULT_MAX_HEAP 8*MB
#endif
/* default size of the Java stack */