[packages] git: update to 2.0.0
Signed-off-by: Peter Wagner <tripolar@gmx.at> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40879 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e598683945
commit
355fd025be
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=git
|
||||
PKG_VERSION:=1.9.3
|
||||
PKG_VERSION:=2.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
|
||||
PKG_MD5SUM:=560200d1db05a2dd2b8a2b3718655463
|
||||
PKG_MD5SUM:=0646202ae979e4339f3e47f2375b5773
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -536,16 +536,7 @@ EXTRA_PROGRAMS =
|
||||
@@ -532,16 +532,7 @@ EXTRA_PROGRAMS =
|
||||
# ... and all the rest that could be moved out of bindir to gitexecdir
|
||||
PROGRAMS += $(EXTRA_PROGRAMS)
|
||||
|
||||
@ -18,7 +18,7 @@
|
||||
|
||||
# Binary suffix, set to .exe for Windows builds
|
||||
X =
|
||||
@@ -993,6 +984,12 @@ BUILTIN_OBJS += builtin/var.o
|
||||
@@ -1002,6 +993,12 @@ BUILTIN_OBJS += builtin/var.o
|
||||
BUILTIN_OBJS += builtin/verify-pack.o
|
||||
BUILTIN_OBJS += builtin/verify-tag.o
|
||||
BUILTIN_OBJS += builtin/write-tree.o
|
||||
@ -31,7 +31,7 @@
|
||||
|
||||
GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
|
||||
EXTLIBS =
|
||||
@@ -1156,7 +1153,7 @@ endif
|
||||
@@ -1165,7 +1162,7 @@ endif
|
||||
EXTLIBS += -lz
|
||||
|
||||
ifndef NO_OPENSSL
|
||||
@ -40,7 +40,7 @@
|
||||
ifdef OPENSSLDIR
|
||||
BASIC_CFLAGS += -I$(OPENSSLDIR)/include
|
||||
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
|
||||
@@ -2054,10 +2051,6 @@ endif
|
||||
@@ -2049,10 +2046,6 @@ endif
|
||||
git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
|
||||
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
|
||||
|
||||
@ -51,7 +51,7 @@
|
||||
git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
|
||||
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
|
||||
$(LIBS) $(CURL_LIBCURL)
|
||||
@@ -2366,24 +2359,22 @@ endif
|
||||
@@ -2364,24 +2357,22 @@ endif
|
||||
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
|
||||
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
|
||||
{ test "$$bindir/" = "$$execdir/" || \
|
||||
@ -118,7 +118,7 @@
|
||||
+#include "../upload-pack.c"
|
||||
--- a/daemon.c
|
||||
+++ b/daemon.c
|
||||
@@ -1148,7 +1148,7 @@ static int serve(struct string_list *lis
|
||||
@@ -1125,7 +1125,7 @@ static int serve(struct string_list *lis
|
||||
return service_loop(&socklist);
|
||||
}
|
||||
|
||||
@ -129,7 +129,7 @@
|
||||
struct string_list listen_addr = STRING_LIST_INIT_NODUP;
|
||||
--- a/fast-import.c
|
||||
+++ b/fast-import.c
|
||||
@@ -3365,7 +3365,7 @@ static void parse_argv(void)
|
||||
@@ -3356,7 +3356,7 @@ static void parse_argv(void)
|
||||
read_marks();
|
||||
}
|
||||
|
||||
@ -222,7 +222,7 @@
|
||||
const char **user_argv;
|
||||
--- a/upload-pack.c
|
||||
+++ b/upload-pack.c
|
||||
@@ -781,7 +781,7 @@ static int upload_pack_config(const char
|
||||
@@ -790,7 +790,7 @@ static int upload_pack_config(const char
|
||||
return parse_hide_refs_config(var, value, "uploadpack");
|
||||
}
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user