libnfsidmap:
* cleanup Makefile * fix compile * refresh patch using quilt git-svn-id: svn://svn.openwrt.org/openwrt/packages@7935 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
734e42c3a2
commit
35ae0c0930
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libnfsidmap
|
||||
PKG_VERSION:=0.20
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/
|
||||
@ -27,28 +27,26 @@ define Package/libnfsidmap
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default, \
|
||||
|
||||
MAKE_FLAGS += \
|
||||
OPT="$(TARGET_CFLAGS)" \
|
||||
INSTALLSUID="install -m 4755" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install \
|
||||
)
|
||||
endef
|
||||
all install
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(INSTALL_DIR) $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/nfsidmap.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(INSTALL_DIR) $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnfsidmap.{a,so*} $(STAGING_DIR)/usr/lib
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
|
||||
$(INSTALL_DIR) $(STAGING_DIR)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnfsidmap.pc $(STAGING_DIR)/usr/lib/pkgconfig
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/include/nfsidmap.h
|
||||
$(STAGING_DIR)/usr/lib/libnfsidmap.{a,so*}
|
||||
$(STAGING_DIR)/usr/include/nfsidmap.h \
|
||||
$(STAGING_DIR)/usr/lib/libnfsidmap.{a,so*} \
|
||||
$(STAGING_DIR)/usr/lib/pkgconfig/libnfsidmap.pc
|
||||
endef
|
||||
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- libnfsidmap-0.20/nss.c~ 2007-02-05 08:13:05.000000000 -0800
|
||||
+++ libnfsidmap-0.20/nss.c 2007-06-07 15:18:45.000000000 -0700
|
||||
Index: libnfsidmap-0.20/nss.c
|
||||
===================================================================
|
||||
--- libnfsidmap-0.20.orig/nss.c 2007-07-12 11:42:09.000000000 +0200
|
||||
+++ libnfsidmap-0.20/nss.c 2007-07-12 11:42:09.000000000 +0200
|
||||
@@ -295,9 +295,9 @@
|
||||
ret = -ENOENT;
|
||||
goto out;
|
||||
|
Loading…
x
Reference in New Issue
Block a user