[packages] portmap fixes:

- disable pie (closes: #3095)
 - use start-stop-daemon
 - bump release number


git-svn-id: svn://svn.openwrt.org/openwrt/packages@11001 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2008-05-02 01:20:40 +00:00
parent 359cf4f358
commit 35ea947770
3 changed files with 20 additions and 8 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007 OpenWrt.org
# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=portmap
PKG_VERSION:=6.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://neil.brown.name/portmap/

View File

@ -1,16 +1,16 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2006-2008 OpenWrt.org
START=40
BIN=portmap
DEFAULT=/etc/default/$BIN
NAME=portmap
PROG=/usr/sbin/$NAME
DEFAULT=/etc/default/$NAME
start() {
[ -f $DEFAULT ] && . $DEFAULT
$BIN $OPTIONS
start-stop-daemon -q -S -x $PROG -- $OPTIONS
}
stop() {
killall $BIN
start-stop-daemon -q -K -x $PROG -- $OPTIONS
}

View File

@ -0,0 +1,12 @@
diff -ur portmap_6.0.org/Makefile portmap_6.0/Makefile
--- portmap_6.0.org/Makefile 2008-04-19 22:44:35.000000000 +0200
+++ portmap_6.0/Makefile 2008-04-19 00:02:01.000000000 +0200
@@ -127,7 +127,7 @@
CPPFLAGS += $(HOSTS_ACCESS)
portmap: CFLAGS += -fpie
portmap: LDLIBS += $(WRAP_LIB)
-portmap: LDFLAGS += -pie
+#portmap: LDFLAGS += -pie
portmap: portmap.o pmap_check.o from_local.o
from_local: CPPFLAGS += -DTEST