[curl]: upgrade to 7.36.0

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>



git-svn-id: svn://svn.openwrt.org/openwrt/packages@40024 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
kaloz 2014-03-26 14:26:49 +00:00
parent 9796f7f26e
commit 3647123476
4 changed files with 16 additions and 39 deletions

View File

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=curl
PKG_VERSION:=7.35.0
PKG_VERSION:=7.36.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
ftp://ftp.planetmirror.com/pub/curl/ \
http://www.mirrormonster.com/curl/download/ \
http://curl.mirrors.cyberservers.net/download/
PKG_MD5SUM:=c18fbdd031adb0529ae09fce399f2d10
PKG_MD5SUM:=e6d1f9d1b59da5062109ffe14e0569a4
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING

View File

@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -2898,6 +2898,7 @@ CURL_VERIFY_RUNTIMELIBS
@@ -2901,6 +2901,7 @@ CURL_VERIFY_RUNTIMELIBS
AC_CHECK_SIZEOF(size_t)
AC_CHECK_SIZEOF(long)

View File

@ -1,36 +0,0 @@
--- a/lib/urldata.h
+++ b/lib/urldata.h
@@ -117,6 +117,9 @@
#include <polarssl/entropy.h>
#include <polarssl/ctr_drbg.h>
#endif /* POLARSSL_VERSION_NUMBER<0x01010000 */
+#if POLARSSL_VERSION_NUMBER>=0x01030000
+#include <polarssl/compat-1.2.h>
+#endif
#endif /* USE_POLARSSL */
#ifdef USE_CYASSL
--- a/lib/vtls/polarssl.c
+++ b/lib/vtls/polarssl.c
@@ -37,6 +37,10 @@
#include <polarssl/x509.h>
#include <polarssl/version.h>
+#if POLARSSL_VERSION_NUMBER >= 0x01030000
+#include <polarssl/compat-1.2.h>
+#endif
+
#if POLARSSL_VERSION_NUMBER >= 0x01000000
#include <polarssl/error.h>
#endif /* POLARSSL_VERSION_NUMBER >= 0x01000000 */
@@ -311,8 +315,8 @@ polarssl_connect_step1(struct connectdat
&connssl->crl,
conn->host.name);
- ssl_set_own_cert(&connssl->ssl,
- &connssl->clicert, &connssl->rsa);
+ ssl_set_own_cert_rsa(&connssl->ssl,
+ &connssl->clicert, &connssl->rsa);
if(!Curl_inet_pton(AF_INET, conn->host.name, &addr) &&
#ifdef ENABLE_IPV6

View File

@ -0,0 +1,13 @@
--- a/src/tool_hugehelp.h
+++ b/src/tool_hugehelp.h
@@ -23,6 +23,10 @@
***************************************************************************/
#include "tool_setup.h"
+#ifdef USE_MANUAL
void hugehelp(void);
+#else
+#define hugehelp() Curl_nop_stmt
+#endif
#endif /* HEADER_CURL_TOOL_HUGEHELP_H */