[packages] httping: update to 1.5.1
* add nossl variant * drop unused extra_flags patch * refresh patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@27857 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0ae15bc58a
commit
36e2a8c8ce
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
# Copyright (C) 2006-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,37 +8,69 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=httping
|
PKG_NAME:=httping
|
||||||
PKG_VERSION:=1.4.4
|
PKG_VERSION:=1.5.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=http://www.vanheusden.com/httping
|
PKG_SOURCE_URL:=http://www.vanheusden.com/httping
|
||||||
PKG_MD5SUM:=e36bb30bd758c766d7260bdde6fe6450
|
PKG_MD5SUM:=aeecd67cf90015e50cb03356f89d3c2c
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/httping
|
define Package/httping/Default
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
DEPENDS:=+libopenssl
|
|
||||||
TITLE:=Httping is like 'ping' but for http-requests
|
TITLE:=Httping is like 'ping' but for http-requests
|
||||||
URL:=http://www.vanheusden.com/httping/
|
URL:=http://www.vanheusden.com/httping/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/httping/description
|
define Package/httping/Default/description
|
||||||
Give it an url, and it'll show you how long it takes to connect, send a
|
Give it an url, and it'll show you how long it takes to connect, send a
|
||||||
request and retrieve the reply (only the headers). Be aware that the
|
request and retrieve the reply (only the headers). Be aware that the
|
||||||
transmission across the network also takes time!
|
transmission across the network also takes time!
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/httping
|
||||||
|
$(call Package/httping/Default)
|
||||||
|
DEPENDS+= +libopenssl
|
||||||
|
TITLE+= (with SSL support)
|
||||||
|
VARIANT:=ssl
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/httping/description
|
||||||
|
$(call Package/httping/Default/description)
|
||||||
|
This package is built with SSL support.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/httping-nossl
|
||||||
|
$(call Package/httping/Default)
|
||||||
|
TITLE+= (without SSL support)
|
||||||
|
VARIANT:=nossl
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/httping-nossl/description
|
||||||
|
$(call Package/httping/Default/description)
|
||||||
|
This package is built without SSL support.
|
||||||
|
endef
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
MAKE_FLAGS += \
|
||||||
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
|
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)"
|
||||||
|
|
||||||
|
ifeq ($(BUILD_VARIANT),nossl)
|
||||||
|
MAKE_FLAGS += \
|
||||||
|
SSL="no" \
|
||||||
|
CFLAGS+="-DNO_SSL"
|
||||||
|
endif
|
||||||
|
|
||||||
define Package/httping/install
|
define Package/httping/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/httping $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/httping $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
Package/httping-nossl/install = $(Package/httping/install)
|
||||||
|
|
||||||
$(eval $(call BuildPackage,httping))
|
$(eval $(call BuildPackage,httping))
|
||||||
|
$(eval $(call BuildPackage,httping-nossl))
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -18,7 +18,7 @@ TARGET=httping
|
|
||||||
|
|
||||||
WFLAGS=-Wall -W
|
|
||||||
OFLAGS=-O2
|
|
||||||
-CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
|
|
||||||
+CFLAGS+=$(EXTRA_CFLAGS) $(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
|
|
||||||
|
|
||||||
PACKAGE=$(TARGET)-$(VERSION)
|
|
||||||
PREFIX=/usr
|
|
||||||
@@ -47,7 +47,7 @@ ifeq ($(SSL),no)
|
|
||||||
CFLAGS+=-DNO_SSL
|
|
||||||
else
|
|
||||||
OBJS+=mssl.o
|
|
||||||
-LDFLAGS+=-lssl -lcrypto
|
|
||||||
+LDFLAGS+=$(EXTRA_LDFLAGS) -lssl -lcrypto
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifeq ($(DEBUG),yes)
|
|
@ -4,7 +4,7 @@
|
|||||||
#include "utils.h"
|
#include "utils.h"
|
||||||
#include "error.h"
|
#include "error.h"
|
||||||
|
|
||||||
+#define VERSION "1.4.4"
|
+#define VERSION "1.5.1"
|
||||||
+
|
+
|
||||||
static volatile int stop = 0;
|
static volatile int stop = 0;
|
||||||
|
|
||||||
@ -18,7 +18,7 @@
|
|||||||
#ifndef NO_SSL
|
#ifndef NO_SSL
|
||||||
fprintf(stderr, "SSL support included\n");
|
fprintf(stderr, "SSL support included\n");
|
||||||
#endif
|
#endif
|
||||||
@@ -606,7 +608,7 @@ int main(int argc, char *argv[])
|
@@ -637,7 +639,7 @@ int main(int argc, char *argv[])
|
||||||
if (useragent)
|
if (useragent)
|
||||||
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
||||||
else
|
else
|
||||||
|
Loading…
x
Reference in New Issue
Block a user