[packages] ffmpeg: update to 0.5.2

* add OSS demuxer & PCM signed 16-bit encoder/decoder for audio output
 * add an FFMPEG_PATENTED config item to include support for patented codecs - need help to spot them
 * fix IPv6 support


git-svn-id: svn://svn.openwrt.org/openwrt/packages@21816 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2010-06-16 18:19:46 +00:00
parent 51126de1aa
commit 37672bb2e0
3 changed files with 119 additions and 157 deletions

View File

@ -1,17 +1,23 @@
menu "Configuration"
depends PACKAGE_libffmpeg
# FFmpeg configuration config FFMPEG_IPV6
bool "Enable IPv6"
default IPV6
if PACKAGE_libffmpeg config FFMPEG_PATENTED
bool "Include patented codecs and technologies"
default BUILD_PATENTED
config FFMPEG_FFSERVER_SUPPORT config FFMPEG_FFSERVER_SUPPORT
bool bool "Include support for FFmpeg streaming support"
select FFMPEG_MUXER_ffm select FFMPEG_MUXER_ffm
select FFMPEG_DEMUXER_rtsp select FFMPEG_DEMUXER_rtsp
select FFMPEG_PROTOCOL_rtp select FFMPEG_PROTOCOL_rtp
config FFMPEG_LIBDLNA_SUPPORT config FFMPEG_LIBDLNA_SUPPORT
bool bool "Include support for libdlna/ushare"
default y if PACKAGE_libdlna depends FFMPEG_PATENTED
select FFMPEG_DECODER_ac3 select FFMPEG_DECODER_ac3
select FFMPEG_DECODER_atrac3 select FFMPEG_DECODER_atrac3
select FFMPEG_DECODER_h264 select FFMPEG_DECODER_h264
@ -33,235 +39,212 @@ config FFMPEG_LIBDLNA_SUPPORT
comment "Encoders ---" comment "Encoders ---"
config FFMPEG_ENCODER_ac3 config FFMPEG_ENCODER_ac3
bool bool "AC3"
prompt "AC3" depends FFMPEG_PATENTED
select FFMPEG_PARSER_ac3 select FFMPEG_PARSER_ac3
config FFMPEG_ENCODER_jpegls config FFMPEG_ENCODER_jpegls
bool bool "JPEG-LS"
prompt "JPEG-LS"
config FFMPEG_ENCODER_mpeg1video config FFMPEG_ENCODER_mpeg1video
bool bool "MPEG-1 Video"
prompt "MPEG-1 Video"
config FFMPEG_ENCODER_mpeg2video config FFMPEG_ENCODER_mpeg2video
bool bool "MPEG-2 Video"
prompt "MPEG-2 Video" depends FFMPEG_PATENTED
config FFMPEG_ENCODER_mpeg4 config FFMPEG_ENCODER_mpeg4
bool bool "MPEG-4"
prompt "MPEG-4" depends FFMPEG_PATENTED
config FFMPEG_ENCODER_pcm_s16be
bool "PCM signed 16-bit big-endian"
config FFMPEG_ENCODER_pcm_s16le
bool "PCM signed 16-bit little-endian"
config FFMPEG_ENCODER_png config FFMPEG_ENCODER_png
bool bool "PNG"
prompt "PNG"
select FFMPEG_ENCODER_zlib select FFMPEG_ENCODER_zlib
config FFMPEG_ENCODER_zlib config FFMPEG_ENCODER_zlib
bool bool "Zlib"
prompt "Zlib"
comment "Decoders ---" comment "Decoders ---"
config FFMPEG_DECODER_ac3 config FFMPEG_DECODER_ac3
bool bool "AC3"
prompt "AC3" depends FFMPEG_PATENTED
select FFMPEG_PARSER_ac3 select FFMPEG_PARSER_ac3
config FFMPEG_DECODER_atrac3 config FFMPEG_DECODER_atrac3
bool bool "ATRAC3"
prompt "ATRAC3" depends FFMPEG_PATENTED
config FFMPEG_DECODER_gif config FFMPEG_DECODER_gif
bool bool "GIF"
prompt "GIF"
config FFMPEG_DECODER_h264 config FFMPEG_DECODER_h264
bool bool "H.264"
prompt "H.264" depends FFMPEG_PATENTED
select FFMPEG_PARSER_h264
config FFMPEG_DECODER_jpegls config FFMPEG_DECODER_jpegls
bool bool "JPEG-LS"
prompt "JPEG-LS"
config FFMPEG_DECODER_mp3 config FFMPEG_DECODER_mp3
bool bool "MP3"
prompt "MP3" depends FFMPEG_PATENTED
select FFMPEG_PARSER_mpegaudio
config FFMPEG_DECODER_mpegvideo config FFMPEG_DECODER_mpegvideo
bool bool "MPEG Video"
prompt "MPEG Video"
config FFMPEG_DECODER_mpeg1video config FFMPEG_DECODER_mpeg1video
bool bool "MPEG-1 Video"
prompt "MPEG-1 Video"
config FFMPEG_DECODER_mpeg2video config FFMPEG_DECODER_mpeg2video
bool bool "MPEG-2 Video"
prompt "MPEG-2 Video" depends FFMPEG_PATENTED
config FFMPEG_DECODER_mpeg4 config FFMPEG_DECODER_mpeg4
bool bool "MPEG-4"
prompt "MPEG-4" depends FFMPEG_PATENTED
config FFMPEG_DECODER_mpeg4aac config FFMPEG_DECODER_mpeg4aac
bool bool "MPEG-4 (AAC)"
prompt "MPEG-4 (AAC)" depends FFMPEG_PATENTED
config FFMPEG_DECODER_pcm_s16be
bool "PCM signed 16-bit big-endian"
config FFMPEG_DECODER_pcm_s16le
bool "PCM signed 16-bit little-endian"
config FFMPEG_DECODER_png config FFMPEG_DECODER_png
bool bool "PNG"
prompt "PNG"
select FFMPEG_DECODER_zlib select FFMPEG_DECODER_zlib
config FFMPEG_DECODER_wmav1 config FFMPEG_DECODER_wmav1
bool bool "WMAv1"
prompt "WMAv1" depends FFMPEG_PATENTED
config FFMPEG_DECODER_wmav2 config FFMPEG_DECODER_wmav2
bool bool "WMAv2"
prompt "WMAv2" depends FFMPEG_PATENTED
config FFMPEG_DECODER_zlib config FFMPEG_DECODER_zlib
bool bool "Zlib"
prompt "Zlib"
comment "Muxers ---" comment "Muxers ---"
config FFMPEG_MUXER_ac3 config FFMPEG_MUXER_ac3
bool bool "AC3"
prompt "AC3" depends FFMPEG_PATENTED
select FFMPEG_PARSER_ac3
config FFMPEG_MUXER_ffm config FFMPEG_MUXER_ffm
bool bool "FFM (ffserver live feed)"
prompt "FFM (ffserver live feed)"
config FFMPEG_MUXER_h264 config FFMPEG_MUXER_h264
bool bool "H.264"
prompt "H.264" depends FFMPEG_PATENTED
select FFMPEG_PARSER_h264
config FFMPEG_MUXER_mp3 config FFMPEG_MUXER_mp3
bool bool "MP3"
prompt "MP3"
config FFMPEG_MUXER_mp4 config FFMPEG_MUXER_mp4
bool bool "MP4"
prompt "MP4"
config FFMPEG_MUXER_mpeg1video config FFMPEG_MUXER_mpeg1video
bool bool "MPEG-1 Video"
prompt "MPEG-1 Video"
config FFMPEG_MUXER_mpeg2video config FFMPEG_MUXER_mpeg2video
bool bool "MPEG-2 Video"
prompt "MPEG-2 Video"
config FFMPEG_MUXER_mpegts config FFMPEG_MUXER_mpegts
bool bool "MPEG-2 (TS)"
prompt "MPEG-2 (TS)"
config FFMPEG_MUXER_oss
bool "OSS (Open Sound System playback)"
config FFMPEG_MUXER_rtp config FFMPEG_MUXER_rtp
bool bool "RTP"
prompt "RTP"
comment "Demuxers ---" comment "Demuxers ---"
config FFMPEG_DEMUXER_ac3 config FFMPEG_DEMUXER_ac3
bool bool "AC3"
prompt "AC3"
select FFMPEG_PARSER_ac3
config FFMPEG_DEMUXER_ffm config FFMPEG_DEMUXER_ffm
bool bool "FFM (ffserver live feed)"
prompt "FFM (ffserver live feed)"
config FFMPEG_DEMUXER_h264 config FFMPEG_DEMUXER_h264
bool bool "H.264"
prompt "H.264" depends FFMPEG_PATENTED
select FFMPEG_PARSER_h264
config FFMPEG_DEMUXER_mp3 config FFMPEG_DEMUXER_mp3
bool bool "MP3"
prompt "MP3"
config FFMPEG_DEMUXER_mpegvideo config FFMPEG_DEMUXER_mpegvideo
bool bool "MPEG Video"
prompt "MPEG Video"
select FFMPEG_PARSER_mpegvideo
config FFMPEG_DEMUXER_mpegps config FFMPEG_DEMUXER_mpegps
bool bool "MPEG-2 (PS)"
prompt "MPEG-2 (PS)"
config FFMPEG_DEMUXER_mpegts config FFMPEG_DEMUXER_mpegts
bool bool "MPEG-2 (TS)"
prompt "MPEG-2 (TS)"
config FFMPEG_DEMUXER_rm
bool "RM"
help
RealMedia format demuxer
config FFMPEG_DEMUXER_rtsp config FFMPEG_DEMUXER_rtsp
bool bool "RTSP"
prompt "RTSP" select FFMPEG_DEMUXER_rm
select FFMPEG_DEMUXER_sdp select FFMPEG_DEMUXER_sdp
config FFMPEG_DEMUXER_sdp config FFMPEG_DEMUXER_sdp
bool bool "SDP"
prompt "SDP"
select FFMPEG_DEMUXER_mpegts select FFMPEG_DEMUXER_mpegts
comment "Parsers ---" comment "Parsers ---"
config FFMPEG_PARSER_ac3 config FFMPEG_PARSER_ac3
bool bool "AC3"
prompt "AC3"
config FFMPEG_PARSER_h264 config FFMPEG_PARSER_h264
bool bool "H.264"
prompt "H.264" depends FFMPEG_PATENTED
select FFMPEG_DECODER_h264
config FFMPEG_PARSER_mpegaudio config FFMPEG_PARSER_mpegaudio
bool bool "MPEG Audio"
prompt "MPEG Audio"
config FFMPEG_PARSER_mpegvideo config FFMPEG_PARSER_mpegvideo
bool bool "MPEG Video"
prompt "MPEG Video"
config FFMPEG_PARSER_mpeg4video config FFMPEG_PARSER_mpeg4video
bool bool "MPEG-4 Video"
prompt "MPEG-4 Video"
comment "Protocols ---" comment "Protocols ---"
config FFMPEG_PROTOCOL_file config FFMPEG_PROTOCOL_file
bool bool "file:"
prompt "file:"
config FFMPEG_PROTOCOL_http config FFMPEG_PROTOCOL_http
bool bool "http:"
prompt "http:"
config FFMPEG_PROTOCOL_pipe config FFMPEG_PROTOCOL_pipe
bool bool "pipe:"
prompt "pipe:"
config FFMPEG_PROTOCOL_rtp config FFMPEG_PROTOCOL_rtp
bool bool "rtp:"
prompt "rtp:"
select FFMPEG_PROTOCOL_udp select FFMPEG_PROTOCOL_udp
config FFMPEG_PROTOCOL_tcp config FFMPEG_PROTOCOL_tcp
bool bool "tcp:"
prompt "tcp:"
config FFMPEG_PROTOCOL_udp config FFMPEG_PROTOCOL_udp
bool bool "udp:"
prompt "udp:"
config FFMPEG_PROTOCOL_IPv6 endmenu
bool
prompt "IPv6"
endif

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2006-2009 OpenWrt.org # Copyright (C) 2006-2010 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,14 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=ffmpeg PKG_NAME:=ffmpeg
PKG_VERSION:=20080419 PKG_VERSION:=0.5.2
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-export-snapshot-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/ PKG_SOURCE_URL:=http://ffmpeg.org/releases/
PKG_MD5SUM:=63aeb859941b96ed3ef7b0c7a643bf4d PKG_MD5SUM:=
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-export-2008-04-19
FFMPEG_ENCODERS:= \ FFMPEG_ENCODERS:= \
ac3 \ ac3 \
@ -23,6 +21,8 @@ FFMPEG_ENCODERS:= \
mpeg1video \ mpeg1video \
mpeg2video \ mpeg2video \
mpeg4 \ mpeg4 \
pcm_s16be \
pcm_s16le \
png \ png \
zlib \ zlib \
@ -38,6 +38,8 @@ FFMPEG_DECODERS:= \
mpeg4 \ mpeg4 \
mpeg4aac \ mpeg4aac \
mpegvideo \ mpegvideo \
pcm_s16be \
pcm_s16le \
png \ png \
wmav1 \ wmav1 \
wmav2 \ wmav2 \
@ -52,6 +54,7 @@ FFMPEG_MUXERS:= \
mpeg1video \ mpeg1video \
mpeg2video \ mpeg2video \
mpegts \ mpegts \
oss \
rtp \ rtp \
FFMPEG_DEMUXERS:= \ FFMPEG_DEMUXERS:= \
@ -62,6 +65,7 @@ FFMPEG_DEMUXERS:= \
mpegps \ mpegps \
mpegts \ mpegts \
mpegvideo \ mpegvideo \
rm \
rtsp \ rtsp \
sdp \ sdp \
v4l2 \ v4l2 \
@ -129,7 +133,7 @@ $(call Package/ffmpeg/Default)
SECTION:=libs SECTION:=libs
CATEGORY:=Libraries CATEGORY:=Libraries
TITLE+= libraries TITLE+= libraries
DEPENDS+= +libpthread +libfaad2 +zlib DEPENDS+= +libpthread +zlib
MENU:=1 MENU:=1
endef endef
@ -184,7 +188,7 @@ define Build/Configure
--enable-ffmpeg \ --enable-ffmpeg \
--enable-ffserver \ --enable-ffserver \
--enable-gpl \ --enable-gpl \
--enable-libfaad \ --disable-libfaad \
--disable-mmx \ --disable-mmx \
--disable-mmx2 \ --disable-mmx2 \
--enable-pthreads \ --enable-pthreads \
@ -195,6 +199,10 @@ define Build/Configure
--enable-zlib \ --enable-zlib \
--enable-postproc \ --enable-postproc \
\ \
$(if $(CONFIG_FFMPEG_IPV6),,--disable-ipv6) \
\
--disable-bsfs \
--disable-devices \
--disable-encoders \ --disable-encoders \
$(FFMPEG_CONFIGURE_ENCODERS) \ $(FFMPEG_CONFIGURE_ENCODERS) \
--disable-decoders \ --disable-decoders \
@ -205,7 +213,6 @@ define Build/Configure
$(FFMPEG_CONFIGURE_DEMUXERS) \ $(FFMPEG_CONFIGURE_DEMUXERS) \
--disable-parsers \ --disable-parsers \
$(FFMPEG_CONFIGURE_PARSERS) \ $(FFMPEG_CONFIGURE_PARSERS) \
--disable-bsfs \
--disable-protocols \ --disable-protocols \
$(FFMPEG_CONFIGURE_PROTOCOLS) \ $(FFMPEG_CONFIGURE_PROTOCOLS) \
) )

View File

@ -1,28 +0,0 @@
--- a/configure
+++ b/configure
@@ -881,11 +881,11 @@ logfile="config.err"
# installation paths
prefix="/usr/local"
-libdir='$(PREFIX)/lib'
+libdir='${prefix}/lib'
shlibdir="$libdir"
-incdir='$(PREFIX)/include'
-mandir='$(PREFIX)/share/man'
-bindir='$(PREFIX)/bin'
+incdir='${prefix}/include'
+mandir='${prefix}/share/man'
+bindir='${prefix}/bin'
# toolchain
cc="gcc"
@@ -1936,8 +1936,7 @@ echo "#ifndef FFMPEG_CONFIG_H" >> $TMPH
echo "#define FFMPEG_CONFIG_H" >> $TMPH
echo "#define FFMPEG_CONFIGURATION \"$FFMPEG_CONFIGURATION\"" >> $TMPH
-echo "PREFIX=$prefix" >> config.mak
-echo "prefix=\$(DESTDIR)\$(PREFIX)" >> config.mak
+echo "prefix=$prefix" >> config.mak
echo "LIBDIR=\$(DESTDIR)$libdir" >> config.mak
echo "SHLIBDIR=\$(DESTDIR)$shlibdir" >> config.mak
echo "INCDIR=\$(DESTDIR)$incdir" >> config.mak