net/bwping: BWPing is a small utility for bandwidth measuring. (thank you Florian Sesser)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26727 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
91d39ae951
commit
37b2313141
42
net/bwping/Makefile
Normal file
42
net/bwping/Makefile
Normal file
@ -0,0 +1,42 @@
|
||||
#
|
||||
# Copyright (C) 2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bwping
|
||||
PKG_VERSION:=1.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/bwping
|
||||
PKG_MD5SUM:=4c2215551df7f00de8559fd0cd1ff4db
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/bwping
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=Open Source bandwidth measurement tool
|
||||
URL:=http://bwping.sourceforge.net
|
||||
endef
|
||||
|
||||
define Package/bwping/description
|
||||
BWPing
|
||||
BWPing is a bandwidth measurement tool based on ICMP echo
|
||||
request/reply. It is especially well suited for lossy links. BWPing
|
||||
does not not require any special software on the remote host (only
|
||||
the ability to respond on ICMP echo request messages).
|
||||
endef
|
||||
|
||||
define Package/bwping/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,bwping))
|
12
net/bwping/patches/100-getopt-returns-int.patch
Normal file
12
net/bwping/patches/100-getopt-returns-int.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urN bwping-1.2.orig/bwping.c bwping-1.2/bwping.c
|
||||
--- bwping-1.2.orig/bwping.c 2010-01-22 17:49:29.000000000 +0000
|
||||
+++ bwping-1.2/bwping.c 2010-12-07 12:30:26.000000000 +0000
|
||||
@@ -221,7 +221,7 @@
|
||||
unsigned int bufsize, tos, transmitted_number, received_number;
|
||||
unsigned long int kbps, pktsize, volume, rperiod, received_volume;
|
||||
unsigned long long int min_interval, interval, current_interval, integral_error;
|
||||
- char ch;
|
||||
+ int ch;
|
||||
char *ep, *target;
|
||||
fd_set fds;
|
||||
struct sockaddr_in to;
|
Loading…
x
Reference in New Issue
Block a user