[packages]dovecot update to v2.2.4

git-svn-id: svn://svn.openwrt.org/openwrt/packages@37142 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
tripolar 2013-07-03 01:49:27 +00:00
parent dd0334d60b
commit 38066e1177
4 changed files with 23 additions and 109 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dovecot
PKG_VERSION:=1.2.13
PKG_RELEASE:=2
PKG_VERSION:=2.2.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
PKG_MD5SUM:=aaee3b5fd59e01780305553248f686bc
PKG_SOURCE_URL:=http://www.dovecot.org/releases/2.2
PKG_MD5SUM:=984cfc921a83c580c52c86e128e9dac2
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/dovecot
SECTION:=mail
CATEGORY:=Mail
DEPENDS:=+libopenssl +librt +zlib +libbz2
DEPENDS:=+libopenssl +librt +zlib +libbz2 +libcap
TITLE:=An IMAP and POP3 daemon
URL:=http://www.dovecot.org/
endef
@ -35,9 +35,8 @@ endef
CONFIGURE_ARGS += \
--without-gssapi \
--without-pam \
--without-libcap \
--with-moduledir=/usr/lib/dovecot/modules \
--with-notify=dnotify \
--with-notify=dnotify
CONFIGURE_VARS += \
RPCGEN= \
@ -50,22 +49,23 @@ CONFIGURE_VARS += \
lib_cv_va_copy=yes \
lib_cv_va_copy=yes \
lib_cv___va_copy=yes \
lib_cv_va_val_copy=yes \
lib_cv_va_val_copy=yes
define Package/dovecot/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/dovecot-example.conf $(1)/etc/dovecot.conf
$(INSTALL_DIR) $(1)/usr/lib/dovecot
$(INSTALL_DIR) $(1)/etc/init.d \
$(1)/etc/dovecot \
$(1)/usr/share/doc/dovecot/example-config \
$(1)/usr/lib/dovecot \
$(1)/usr/bin \
$(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/etc/dovecot/* $(1)/etc/dovecot/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/share/doc/dovecot/example-config $(1)/usr/share/doc/dovecot/example-config
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/doveconf $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
find $(1)/usr/lib/dovecot/modules/ \
-name "*.a" -o -name "*.la" | xargs rm
endef
define Package/dovecot/conffiles
/etc/dovecot.conf
$(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot
rm $(1)/usr/lib/dovecot/dovecot-config
find $(1)/usr/lib/dovecot/ -name "*.a" -o -name "*.la" | xargs rm
endef
$(eval $(call BuildPackage,dovecot))

View File

@ -1,7 +1,8 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006-2011 OpenWrt.org
START=99
START=75
STOP=75
SERVICE_PID_FILE=/var/run/dovecot/master.pid

View File

@ -1,5 +1,5 @@
--- a/configure.in
+++ b/configure.in
--- a/configure.ac
+++ b/configure.ac
@@ -398,9 +398,9 @@ have_ioloop=no
if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then

View File

@ -1,87 +0,0 @@
--- a/dovecot-example.conf
+++ b/dovecot-example.conf
@@ -537,20 +537,20 @@
protocol imap {
# Login executable location.
- #login_executable = /usr/libexec/dovecot/imap-login
+ #login_executable = /usr/lib/dovecot/imap-login
# IMAP executable location. Changing this allows you to execute other
# binaries before the imap process is executed.
#
# This would write rawlogs into user's ~/dovecot.rawlog/, if it exists:
- # mail_executable = /usr/libexec/dovecot/rawlog /usr/libexec/dovecot/imap
+ # mail_executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/imap
# <doc/wiki/Debugging/Rawlog.txt>
#
# This would attach gdb into the imap process and write backtraces into
# /tmp/gdbhelper.* files:
- # mail_executable = /usr/libexec/dovecot/gdbhelper /usr/libexec/dovecot/imap
+ # mail_executable = /usr/lib/dovecot/gdbhelper /usr/lib/dovecot/imap
#
- #mail_executable = /usr/libexec/dovecot/imap
+ #mail_executable = /usr/lib/dovecot/imap
# Maximum IMAP command line length in bytes. Some clients generate very long
# command lines with huge mailboxes, so you may need to raise this if you get
@@ -614,11 +614,11 @@ protocol imap {
protocol pop3 {
# Login executable location.
- #login_executable = /usr/libexec/dovecot/pop3-login
+ #login_executable = /usr/lib/dovecot/pop3-login
# POP3 executable location. See IMAP's mail_executable above for examples
# how this could be changed.
- #mail_executable = /usr/libexec/dovecot/pop3
+ #mail_executable = /usr/lib/dovecot/pop3
# Don't try to set mails non-recent or seen with POP3 sessions. This is
# mostly intended to reduce disk I/O. With maildir it doesn't move files
@@ -743,7 +743,7 @@ protocol lda {
##
# Executable location
-#auth_executable = /usr/libexec/dovecot/dovecot-auth
+#auth_executable = /usr/lib/dovecot/dovecot-auth
# Set max. process size in megabytes.
#auth_process_size = 256
@@ -872,7 +872,7 @@ auth default {
# database (passwd usually), you can use static userdb.
# REMEMBER: You'll need /etc/pam.d/dovecot file created for PAM
# authentication to actually work. <doc/wiki/PasswordDatabase.PAM.txt>
- passdb pam {
+ #passdb pam {
# [session=yes] [setcred=yes] [failure_show_msg=yes] [max_requests=<n>]
# [cache_key=<key>] [<service name>]
#
@@ -905,15 +905,15 @@ auth default {
# args = session=yes %Ls
# args = cache_key=%u dovecot
#args = dovecot
- }
+ #}
# System users (NSS, /etc/passwd, or similiar)
# In many systems nowadays this uses Name Service Switch, which is
# configured in /etc/nsswitch.conf. <doc/wiki/AuthDatabase.Passwd.txt>
- #passdb passwd {
+ passdb passwd {
# [blocking=yes] - See userdb passwd for explanation
#args =
- #}
+ }
# Shadow passwords for system users (NSS, /etc/shadow or similiar).
# Deprecated by PAM nowadays.
@@ -1192,7 +1192,7 @@ plugin {
# a dictionary so it can be quickly determined which mailboxes contain
# expired mails. The actual expunging is done in a nightly cronjob, which
# you must set up:
- # dovecot --exec-mail ext /usr/libexec/dovecot/expire-tool
+ # dovecot --exec-mail ext /usr/lib/dovecot/expire-tool
#expire = Trash 7 Spam 30
#expire_dict = proxy::expire