ortp: fix memset size argument usage

As reported by GCC 4.8, the size argument passed to memset() was incorrect.

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39923 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2014-03-13 16:52:16 +00:00
parent 977de77cc1
commit 384533ef74
2 changed files with 13 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2010 OpenWrt.org
# Copyright (C) 2010-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ortp
PKG_VERSION:=0.16.3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \

View File

@ -0,0 +1,11 @@
--- a/src/stun.c
+++ b/src/stun.c
@@ -399,7 +399,7 @@ stunParseMessage( char* buf, unsigned in
char* body;
unsigned int size;
ortp_debug("stun: Received stun message: %i bytes\n", bufLen);
- memset(msg, 0, sizeof(msg));
+ memset(msg, 0, sizeof(*msg));
if (sizeof(StunMsgHdr) > bufLen)
{