[packages] mercurial: update to 1.8.4, refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27120 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fb7c41c455
commit
390d4e0861
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mercurial
|
PKG_NAME:=mercurial
|
||||||
PKG_VERSION:=1.8
|
PKG_VERSION:=1.8.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://mercurial.selenic.com/release
|
PKG_SOURCE_URL:=http://mercurial.selenic.com/release
|
||||||
PKG_MD5SUM:=c97b39832f2da60f951d1b7701688bd2
|
PKG_MD5SUM:=b3dcc3de473e003dd1cc0500dcd9de47
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=python-mini
|
PKG_BUILD_DEPENDS:=python-mini
|
||||||
|
|
||||||
|
@ -97,16 +97,16 @@
|
|||||||
archives.append({"type" : i[0], "extension": i[1],
|
archives.append({"type" : i[0], "extension": i[1],
|
||||||
--- a/mercurial/hgweb/hgweb_mod.py
|
--- a/mercurial/hgweb/hgweb_mod.py
|
||||||
+++ b/mercurial/hgweb/hgweb_mod.py
|
+++ b/mercurial/hgweb/hgweb_mod.py
|
||||||
@@ -39,7 +39,7 @@ class hgweb(object):
|
@@ -40,7 +40,7 @@ class hgweb(object):
|
||||||
hook.redirect(True)
|
|
||||||
self.mtime = -1
|
self.mtime = -1
|
||||||
|
self.size = -1
|
||||||
self.reponame = name
|
self.reponame = name
|
||||||
- self.archives = 'zip', 'gz', 'bz2'
|
- self.archives = 'zip', 'gz', 'bz2'
|
||||||
+ self.archives = 'zip', 'gz'
|
+ self.archives = 'zip', 'gz'
|
||||||
self.stripecount = 1
|
self.stripecount = 1
|
||||||
# a repo owner may set web.templates in .hg/hgrc to get any file
|
# a repo owner may set web.templates in .hg/hgrc to get any file
|
||||||
# readable by the user running the CGI script
|
# readable by the user running the CGI script
|
||||||
@@ -280,7 +280,6 @@ class hgweb(object):
|
@@ -284,7 +284,6 @@ class hgweb(object):
|
||||||
yield {"type" : i, "extension" : spec[2], "node" : nodeid}
|
yield {"type" : i, "extension" : spec[2], "node" : nodeid}
|
||||||
|
|
||||||
archive_specs = {
|
archive_specs = {
|
||||||
@ -157,7 +157,7 @@
|
|||||||
bundletype = btypes.get(bundletype)
|
bundletype = btypes.get(bundletype)
|
||||||
if bundletype not in changegroup.bundletypes:
|
if bundletype not in changegroup.bundletypes:
|
||||||
raise util.Abort(_('unknown bundle type specified with --type'))
|
raise util.Abort(_('unknown bundle type specified with --type'))
|
||||||
@@ -4307,7 +4306,7 @@ table = {
|
@@ -4316,7 +4315,7 @@ table = {
|
||||||
_('a base changeset assumed to be available at the destination'),
|
_('a base changeset assumed to be available at the destination'),
|
||||||
_('REV')),
|
_('REV')),
|
||||||
('a', 'all', None, _('bundle all changesets in the repository')),
|
('a', 'all', None, _('bundle all changesets in the repository')),
|
||||||
|
Loading…
x
Reference in New Issue
Block a user