crtmpserver: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41308 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8dcfd9b2e1
commit
3aca237a9d
@ -1,85 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2010-2014 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=crtmpserver
|
|
||||||
PKG_REV:=726
|
|
||||||
PKG_VERSION:=r$(PKG_REV)
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=--username=anonymous --password= https://svn.rtmpd.com/crtmpserver/trunk
|
|
||||||
PKG_SOURCE_SUBDIR:=crtmpserver-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
|
||||||
PKG_SOURCE_PROTO:=svn
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/crtmpserver
|
|
||||||
SECTION:=multimedia
|
|
||||||
CATEGORY:=Multimedia
|
|
||||||
DEPENDS:=+libopenssl +libstdcpp +liblua
|
|
||||||
TITLE:=C++ RTMP Server
|
|
||||||
URL:=http://www.rtmpd.com/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/crtmpserver/description
|
|
||||||
C++ RTMP Server it is a high performance streaming server able to
|
|
||||||
stream (live or recorded) in the following technologies:
|
|
||||||
* To and from Flash (RTMP,RTMPE, RTMPS, RTMPT, RTMPTE)
|
|
||||||
* To and from embedded devices: iPhone, Android
|
|
||||||
* From surveillance cameras
|
|
||||||
* IP-TV using MPEG-TS and RTSP/RTCP/RTP protocols
|
|
||||||
|
|
||||||
Also, crtmpserver can be used as a high performance rendes-vous
|
|
||||||
server. For example, it enables you to do:
|
|
||||||
* Audio/Video conferencing
|
|
||||||
* Online gaming
|
|
||||||
* Online collaboration
|
|
||||||
* Simple/complex chat applications
|
|
||||||
endef
|
|
||||||
|
|
||||||
# XXX: this hack handles the usr/bin vs bin difference of backfire and trunk
|
|
||||||
TS_BASE:=$(wildcard $(TOOLCHAIN_DIR)/bin/$(TARGET_CC))
|
|
||||||
TS_BASE:=$(dir $(if $(TS_BASE),$(TS_BASE),$(wildcard $(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CC))))
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
(cd $(PKG_BUILD_DIR)/builders/make; \
|
|
||||||
cp linux.mk linux-openwrt-uclibc.mk; \
|
|
||||||
$(SED) 's,^TOOLCHAIN_BASE[[:space:]]*=.*,TOOLCHAIN_BASE=$(TS_BASE),' \
|
|
||||||
-e 's,^TOOLCHAIN_PREFIX[[:space:]]*=.*,TOOLCHAIN_PREFIX=$(TARGET_CROSS),' \
|
|
||||||
-e 's,^CCOMPILER[[:space:]]*=.*,CCOMPILER=$(TARGET_CC),' \
|
|
||||||
-e 's,^CXXCOMPILER[[:space:]]*=.*,CXXCOMPILER=$(TARGET_CXX),' \
|
|
||||||
-e 's,^OPTIMIZATIONS[[:space:]]*=.*,OPTIMIZATIONS=-O2,' \
|
|
||||||
-e 's,^SSL_BASE[[:space:]]*=.*,SSL_BASE=$(STAGING_DIR)/usr,' \
|
|
||||||
linux-openwrt-uclibc.mk)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/builders/make \
|
|
||||||
CFLAGS="$(TARGET_CFLAGS)" \
|
|
||||||
PLATFORM=linux-openwrt-uclibc
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/crtmpserver/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/builders/make/output/dynamic/crtmpserver $(1)/usr/bin/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/crtmpserver
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/builders/make/output/dynamic/*.so $(1)/usr/lib/crtmpserver/
|
|
||||||
$(foreach app,flvplayback samplefactory admin stresstest appselector vptests applestreamingclient proxypublish, \
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/crtmpserver/$(app); \
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/builders/make/output/dynamic/applications/$(app)/lib$(app).so \
|
|
||||||
$(1)/usr/lib/crtmpserver/$(app)/; \
|
|
||||||
)
|
|
||||||
$(INSTALL_DIR) $(1)/etc
|
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/builders/make/output/dynamic/crtmpserver.lua $(1)/etc/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/share/crtmpserver/appselector
|
|
||||||
$(INSTALL_DIR) $(1)/usr/share/crtmpserver/media
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,crtmpserver))
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/builders/make/compile.mk
|
|
||||||
+++ b/builders/make/compile.mk
|
|
||||||
@@ -67,7 +67,7 @@ TINYXML_OBJS = $(TINYXML_SRCS:.cpp=.tiny
|
|
||||||
|
|
||||||
#common
|
|
||||||
COMMON_INCLUDE=$(LUA_INCLUDE) $(TINYXML_INCLUDE) $(SSL_INCLUDE) -I$(PROJECT_BASE_PATH)/sources/common/include
|
|
||||||
-COMMON_LIBS=$(SSL_LIB) -L$(OUTPUT_DYNAMIC) -llua -ltinyxml
|
|
||||||
+COMMON_LIBS=$(SSL_LIB) -L$(OUTPUT_DYNAMIC) -llua -ltinyxml -lcrypt
|
|
||||||
COMMON_SRCS = $(shell find $(PROJECT_BASE_PATH)/sources/common/src -type f -name "*.cpp")
|
|
||||||
COMMON_OBJS = $(COMMON_SRCS:.cpp=.common.o)
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
--- a/builders/make/linux.mk
|
|
||||||
+++ b/builders/make/linux.mk
|
|
||||||
@@ -31,8 +31,8 @@ OPTIMIZATIONS = -O3
|
|
||||||
COMPILE_FLAGS = $(FPIC) $(OPTIMIZATIONS) $(CFLAGS)
|
|
||||||
|
|
||||||
#linking flags
|
|
||||||
-dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,"\$$ORIGIN"
|
|
||||||
-dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,"\$$ORIGIN"
|
|
||||||
+dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,/usr/lib/crtmpserver
|
|
||||||
+dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,/usr/lib/crtmpserver
|
|
||||||
|
|
||||||
#compile switches
|
|
||||||
PLATFORM_DEFINES = \
|
|
@ -1,51 +0,0 @@
|
|||||||
--- a/builders/cmake/crtmpserver/crtmpserver.lua
|
|
||||||
+++ b/builders/cmake/crtmpserver/crtmpserver.lua
|
|
||||||
@@ -44,7 +44,7 @@ configuration=
|
|
||||||
{
|
|
||||||
-- this is the root directory of all applications
|
|
||||||
-- usually this is relative to the binary execuable
|
|
||||||
- rootDirectory="applications",
|
|
||||||
+ rootDirectory="/usr/lib/crtmpserver",
|
|
||||||
|
|
||||||
|
|
||||||
--this is where the applications array starts
|
|
||||||
@@ -68,7 +68,7 @@ configuration=
|
|
||||||
-- this is the folder from where the current application gets it's content.
|
|
||||||
-- It is optional. If not specified, it will be defaulted to:
|
|
||||||
-- <rootDirectory>/<name>/mediaFolder
|
|
||||||
- -- mediaFolder="/some/directory/where/media/files/are/stored"
|
|
||||||
+ mediaFolder="/usr/share/crtmpserver/appselector",
|
|
||||||
-- the application will also be known by that names. It is optional
|
|
||||||
--aliases=
|
|
||||||
--{
|
|
||||||
@@ -89,13 +89,6 @@ configuration=
|
|
||||||
},
|
|
||||||
{
|
|
||||||
ip="0.0.0.0",
|
|
||||||
- port=8081,
|
|
||||||
- protocol="inboundRtmps",
|
|
||||||
- sslKey="server.key",
|
|
||||||
- sslCert="server.crt"
|
|
||||||
- },
|
|
||||||
- {
|
|
||||||
- ip="0.0.0.0",
|
|
||||||
port=8080,
|
|
||||||
protocol="inboundRtmpt"
|
|
||||||
},
|
|
||||||
@@ -105,7 +98,7 @@ configuration=
|
|
||||||
description="FLV Playback Sample",
|
|
||||||
name="flvplayback",
|
|
||||||
protocol="dynamiclinklibrary",
|
|
||||||
- mediaFolder="/Volumes/android/backup/media/",
|
|
||||||
+ mediaFolder="/media/",
|
|
||||||
aliases=
|
|
||||||
{
|
|
||||||
"simpleLive",
|
|
||||||
@@ -183,6 +176,7 @@ configuration=
|
|
||||||
name="samplefactory",
|
|
||||||
description="asdsadasdsa",
|
|
||||||
protocol="dynamiclinklibrary",
|
|
||||||
+ mediaFolder="/usr/share/ctmpserver/media",
|
|
||||||
aliases=
|
|
||||||
{
|
|
||||||
"httpOutboundTest"
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/builders/make/linux.mk
|
|
||||||
+++ b/builders/make/linux.mk
|
|
||||||
@@ -38,7 +38,7 @@ dynamic_exec_flags = $(FPIC) $(OPTIMIZAT
|
|
||||||
PLATFORM_DEFINES = \
|
|
||||||
-DLINUX \
|
|
||||||
-DLITTLE_ENDIAN_BYTE_ALIGNED \
|
|
||||||
- -DNET_EPOLL
|
|
||||||
+ -DNET_SELECT
|
|
||||||
|
|
||||||
SSL_BASE=/usr/local
|
|
||||||
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/builders/make/compile.mk
|
|
||||||
+++ b/builders/make/compile.mk
|
|
||||||
@@ -43,10 +43,16 @@ FEATURES_DEFINES = \
|
|
||||||
-DHAS_PROTOCOL_RTP \
|
|
||||||
-DHAS_PROTOCOL_TS \
|
|
||||||
-DHAS_PROTOCOL_VAR \
|
|
||||||
+ -DHAS_PROTOCOL_CLI \
|
|
||||||
+ -DHAS_PROTOCOL_HLS \
|
|
||||||
+ -DHAS_PROTOCOL_RAWHTTPSTREAM \
|
|
||||||
-DHAS_LUA \
|
|
||||||
-DHAS_MEDIA_MP3 \
|
|
||||||
-DHAS_MEDIA_MP4 \
|
|
||||||
- -DHAS_MEDIA_FLV
|
|
||||||
+ -DHAS_MEDIA_FLV \
|
|
||||||
+ -DHAS_MEDIA_NSV \
|
|
||||||
+ -DHAS_SYSLOG
|
|
||||||
+
|
|
||||||
|
|
||||||
|
|
||||||
DEFINES = $(PLATFORM_DEFINES) $(FEATURES_DEFINES)
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/builders/make/compile.mk
|
|
||||||
+++ b/builders/make/compile.mk
|
|
||||||
@@ -59,7 +59,7 @@ DEFINES = $(PLATFORM_DEFINES) $(FEATURES
|
|
||||||
|
|
||||||
#library paths
|
|
||||||
SSL_INCLUDE=-I$(SSL_BASE)/include
|
|
||||||
-SSL_LIB=-L$(SSL_BASE)/lib -lssl -lcrypto
|
|
||||||
+SSL_LIB=-L$(SSL_BASE)/lib -lssl -lcrypto -ldl
|
|
||||||
|
|
||||||
#lua
|
|
||||||
LUA_INCLUDE=-I$(PROJECT_BASE_PATH)/3rdparty/lua-dev
|
|
@ -1,10 +0,0 @@
|
|||||||
--- a/sources/common/include/platform/linux/linuxplatform.h
|
|
||||||
+++ b/sources/common/include/platform/linux/linuxplatform.h
|
|
||||||
@@ -59,6 +59,7 @@
|
|
||||||
#include <sys/socket.h>
|
|
||||||
#include <string.h>
|
|
||||||
#include <stdarg.h>
|
|
||||||
+#include <unistd.h>
|
|
||||||
using namespace std;
|
|
||||||
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user