[packages] remove asterisk-addons-1.4.x (#8898)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25645 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a20282f558
commit
3ba0874fc2
@ -1,177 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2007 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=asterisk-addons
|
|
||||||
PKG_VERSION:=1.4.8
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
|
|
||||||
PKG_MD5SUM:=d4e75c39f737b5ba2a75a4420e1a5a78
|
|
||||||
|
|
||||||
PKG_FIXUP = libtool
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/asterisk-addons/Default
|
|
||||||
SUBMENU:=asterisk14 (Complete Open Source PBX), v1.4.x
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
TITLE:=Asterisk addons
|
|
||||||
URL:=http://www.asterisk.org/
|
|
||||||
MAINTAINER:=Hans Zandbelt <hans.zandbelt@gmail.com>
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/asterisk-addons/Default/description
|
|
||||||
Asterisk addons contains additional modules for Asterisk which are, for
|
|
||||||
one reason or another, not included in the normal base distribution.
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-chan-mobile
|
|
||||||
$(call Package/asterisk-addons/Default)
|
|
||||||
DEPENDS:= +asterisk14 +bluez-libs
|
|
||||||
TITLE+= Mobile channel support
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/asterisk14-chan-mobile/description
|
|
||||||
$(call Package/asterisk-addons/Default/description)
|
|
||||||
This package contains the chan_mobile module for Asterisk.
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-chan-ooh323
|
|
||||||
$(call Package/asterisk-addons/Default)
|
|
||||||
DEPENDS:= +asterisk14
|
|
||||||
TITLE+= OO H.323 channel support
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/asterisk14-chan-ooh323/description
|
|
||||||
$(call Package/asterisk-addons/Default/description)
|
|
||||||
This package contains the Objective Open H.323 support module for Asterisk.
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-format-mp3
|
|
||||||
$(call Package/asterisk-addons/Default)
|
|
||||||
DEPENDS:= +asterisk14
|
|
||||||
TITLE+= MP3 format support
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/asterisk14-format-mp3/description
|
|
||||||
$(call Package/asterisk-addons/Default/description)
|
|
||||||
This package contains the MP3 support module for Asterisk.
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-mysql
|
|
||||||
$(call Package/asterisk-addons/Default)
|
|
||||||
DEPENDS:= +asterisk14 +libmysqlclient
|
|
||||||
TITLE+= MySQL support
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/asterisk14-mysql/description
|
|
||||||
$(call Package/asterisk-addons/Default/description)
|
|
||||||
This package contains MySQL support modules for Asterisk.
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
EXTRA_CFLAGS:=$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)
|
|
||||||
EXTRA_LDFLAGS:=$(TARGET_LDFLAGS)
|
|
||||||
|
|
||||||
ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-mysql),)
|
|
||||||
EXTRA_CFLAGS+= -I$(STAGING_DIR)/usr/include/mysql
|
|
||||||
EXTRA_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/mysql
|
|
||||||
endif
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--with-asterisk="$(STAGING_DIR)/usr/include/asterisk-1.4" \
|
|
||||||
--with-bluetooth="$(STAGING_DIR)/usr" \
|
|
||||||
--with-ncurses="$(STAGING_DIR)/usr" \
|
|
||||||
--with-mysqlclient="$(STAGING_DIR)/usr" \
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
( cd $(PKG_BUILD_DIR); ./bootstrap.sh )
|
|
||||||
$(call Build/Configure/Default,,,)
|
|
||||||
$(call Build/Configure/Default,,,asterisk-ooh323c)
|
|
||||||
endef
|
|
||||||
|
|
||||||
# XXX: explanations
|
|
||||||
# - use AM_CFLAGS for asterisk-ooh323c
|
|
||||||
# - use OPTIMIZE & OPTIONS for format_mp3
|
|
||||||
|
|
||||||
MAKE_ARGS:= \
|
|
||||||
AM_CFLAGS="$(TARGET_CFLAGS)" \
|
|
||||||
OPTIMIZE="$(TARGET_CFLAGS) -DLOW_MEMORY" \
|
|
||||||
OPTIONS="" \
|
|
||||||
NOISY_BUILD="yes" \
|
|
||||||
BLUETOOTH_LIB="$(TARGET_LDFLAGS) -lbluetooth" \
|
|
||||||
|
|
||||||
MAKE_VARS:= \
|
|
||||||
CFLAGS="$(EXTRA_CFLAGS)" \
|
|
||||||
LDFLAGS="$(EXTRA_LDFLAGS)" \
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules
|
|
||||||
$(MAKE_VARS) \
|
|
||||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
|
||||||
$(MAKE_ARGS) \
|
|
||||||
all
|
|
||||||
$(MAKE_VARS) \
|
|
||||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
|
||||||
$(MAKE_ARGS) \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
install samples
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-chan-mobile/conffiles
|
|
||||||
/etc/asterisk/mobile.conf
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/asterisk14-chan-mobile/install
|
|
||||||
$(INSTALL_DIR) $(1)/etc/asterisk
|
|
||||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/mobile.conf $(1)/etc/asterisk/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_mobile.so $(1)/usr/lib/asterisk/modules/
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-chan-ooh323/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_ooh323.so $(1)/usr/lib/asterisk/modules/
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-format-mp3/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/format_mp3.so $(1)/usr/lib/asterisk/modules/
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/asterisk14-mysql/conffiles
|
|
||||||
/etc/asterisk/cdr_mysql.conf
|
|
||||||
/etc/asterisk/res_mysql.conf
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/asterisk14-mysql/install
|
|
||||||
$(INSTALL_DIR) $(1)/etc/asterisk
|
|
||||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/cdr_mysql.conf $(1)/etc/asterisk/
|
|
||||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/res_mysql.conf $(1)/etc/asterisk/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/app_addon_sql_mysql.so $(1)/usr/lib/asterisk/modules/
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/cdr_addon_mysql.so $(1)/usr/lib/asterisk/modules/
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_config_mysql.so $(1)/usr/lib/asterisk/modules/
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,asterisk14-chan-mobile))
|
|
||||||
$(eval $(call BuildPackage,asterisk14-chan-ooh323))
|
|
||||||
$(eval $(call BuildPackage,asterisk14-format-mp3))
|
|
||||||
$(eval $(call BuildPackage,asterisk14-mysql))
|
|
File diff suppressed because it is too large
Load Diff
@ -1,12 +0,0 @@
|
|||||||
diff -Nru asterisk-addons-1.4.8.org/menuselect/Makefile asterisk-addons-1.4.8/menuselect/Makefile
|
|
||||||
--- asterisk-addons-1.4.8.org/menuselect/Makefile 2009-01-08 22:31:41.000000000 +0100
|
|
||||||
+++ asterisk-addons-1.4.8/menuselect/Makefile 2009-06-04 22:21:23.000000000 +0200
|
|
||||||
@@ -52,7 +52,7 @@
|
|
||||||
$(OBJS) menuselect_gtk.o menuselect_curses.o menuselect_stub.o: autoconfig.h menuselect.h
|
|
||||||
|
|
||||||
makeopts autoconfig.h: autoconfig.h.in makeopts.in
|
|
||||||
- @./configure $(CONFIGURE_SILENT) CC= LD= AR= CFLAGS=
|
|
||||||
+ @./configure $(CONFIGURE_SILENT) CC= LD= AR= CFLAGS= LDFLAGS=
|
|
||||||
|
|
||||||
menuselect gmenuselect: mxml/libmxml.a
|
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
--- asterisk-addons-1.4.8/configure.ac.org 2011-02-16 15:32:41.000000000 +0100
|
|
||||||
+++ asterisk-addons-1.4.8/configure.ac 2011-02-16 15:36:05.000000000 +0100
|
|
||||||
@@ -191,11 +191,13 @@
|
|
||||||
fi
|
|
||||||
if test x"${MYSQL_CONFIG}" != xNo; then
|
|
||||||
MYSQLCLIENT_libs=`mysql_config --libs`
|
|
||||||
+ MYSQLCLIENT_include=`mysql_config --include`
|
|
||||||
|
|
||||||
AC_CHECK_LIB([mysqlclient], [mysql_init], [], [], ${MYSQLCLIENT_libs})
|
|
||||||
|
|
||||||
if test "${ac_cv_lib_mysqlclient_mysql_init}" = "yes"; then
|
|
||||||
MYSQLCLIENT_LIB="${MYSQLCLIENT_libs}"
|
|
||||||
+ MYSQLCLIENT_INCLUDE="${MYSQLCLIENT_include}/.."
|
|
||||||
PBX_MYSQLCLIENT=1
|
|
||||||
elif test ! -z "${MYSQLCLIENT_MANDATORY}";
|
|
||||||
then
|
|
Loading…
x
Reference in New Issue
Block a user