mxml: moved to github
c606a0a040
Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@44195 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3f553e3fea
commit
3bc7e9f8ca
@ -1,56 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2010 Tobias Schneider
|
|
||||||
# Copyright (C) 2007 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=mxml
|
|
||||||
PKG_VERSION:=2.8
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://www.msweet.org/files/project3/
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_MD5SUM:=d85ee6d30de053581242c4a86e79a5d2
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/mxml
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
TITLE:=mini-xml
|
|
||||||
URL:=http://www.minixml.org/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/mxml/description
|
|
||||||
A small xml library.
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
$(call Build/Configure/Default, \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
mkdir -p $(1)/usr/include
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/mxml.h $(1)/usr/include/
|
|
||||||
mkdir -p $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/libmxml.so* $(1)/usr/lib/
|
|
||||||
mkdir -p $(1)/usr/lib/pkgconfig
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/mxml.pc $(1)/usr/lib/pkgconfig/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/mxml/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/libmxml.so* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,mxml))
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -88,7 +88,7 @@ PUBLIBOBJS = mxml-attr.o mxml-entity.o m
|
|
||||||
mxml-index.o mxml-node.o mxml-search.o mxml-set.o
|
|
||||||
LIBOBJS = $(PUBLIBOBJS) mxml-private.o mxml-string.o
|
|
||||||
OBJS = mxmldoc.o testmxml.o $(LIBOBJS)
|
|
||||||
-TARGETS = $(LIBMXML) mxmldoc testmxml mxml.xml doc/mxml.man
|
|
||||||
+TARGETS = $(LIBMXML)
|
|
||||||
|
|
||||||
|
|
||||||
#
|
|
Loading…
x
Reference in New Issue
Block a user